Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » how to set the i18n tip when the browser version is too low?
how to set the i18n tip when the browser version is too low? [message #1404090] Tue, 29 July 2014 14:52 Go to next message
Song David is currently offline Song DavidFriend
Messages: 194
Registered: April 2011
Senior Member
Hi,
When the browser version is lower than the versions RAP required, the applcation can not be visited and a warning tip is displayed like below:

Your browser or browser-setup is not supported.
Please use one of: IE 7+, Firefox 3.5+, Safari 4+, Google Chrome 7+ or Opera 10+.
Ensure that Javascript is enabled and XMLHttpRequests are allowed.



1. how to set the i18n to translate the tip?
2. how to beautify the page ?


Thanks a lot

David
Re: how to set the i18n tip when the browser version is too low? [message #1404102 is a reply to message #1404090] Tue, 29 July 2014 15:36 Go to previous messageGo to next message
Markus Knauer is currently offline Markus KnauerFriend
Messages: 123
Registered: July 2009
Senior Member

At least the I18N problem can be solved easily. The Eclipse Babel project provides translations into many languages. See https://www.eclipse.org/babel/ for details or help translate Eclipse via http://babel.eclipse.org/babel/translate.php?project=rt.rap&version=2.3&file=org.eclipse.rap.rwt/org/eclipse/rap/rwt/internal/RWTMessages.properties (you need to login with an Eclipse user ID first).

This message in particular is defined in the RWTMessages.properties file in RWT and can be internationalized like every other string in Eclipse:

http://git.eclipse.org/c/rap/org.eclipse.rap.git/tree/bundles/org.eclipse.rap.rwt/src/org/eclipse/rap/rwt/internal/RWTMessages.properties

Hope that helps...

Markus


--

Twitter: @mknauer23 and @EclipseRAP
Blog: http://eclipsesource.com/blogs/

Professional services for RAP and RCP?
http://eclipsesource.com/services/rap/
Re: how to set the i18n tip when the browser version is too low? [message #1404287 is a reply to message #1404102] Wed, 30 July 2014 23:49 Go to previous message
Song David is currently offline Song DavidFriend
Messages: 194
Registered: April 2011
Senior Member
Thanks Markus, but how to customize the tip page? or swap the html file or add css code to beautify it ?
Previous Topic:There is a scroll problem with the RAP 2.2/2.3 in Chrome 35+
Next Topic:[RAP] [E4] UIThreadTerminatedError in LoginLifecycle
Goto Forum:
  


Current Time: Tue Apr 21 11:55:43 GMT 2015

Powered by FUDForum. Page generated in 0.14191 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software