Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Eclipse Juno JSP compilation errors don't show in overview column(Eclipse Juno JSP compilation errors don't show in overview column)
Eclipse Juno JSP compilation errors don't show in overview column [message #1403793] Sun, 27 July 2014 14:40 Go to next message
A B is currently offline A BFriend
Messages: 9
Registered: November 2013
Junior Member
I had possted this on Eclipse Newcomers forum and was advised to post it to this forum, so here I am.

We are using Eclipse Juno with Websphere 8.5 for Developers version.

========================================
Eclipse Java EE IDE for Web Developers.

Version: Juno Service Release 2
Build id: 20130225-0426
========================================

One of our existing apps uses JSPs. The editor does not show the compilation errors in scriptlets. I looked at various posts on the net and tried many of those things, e.g. - Validation options, open with JSP editor, open Eclipse with JDK using -vm parameter ( I am using the JDK from WAS for Developers ) etc. None of those experiments have helped me in activating the error-indication for the JSP.

Can anyone give me any suggestion as to why I don't get the compilation errors - real-time, automatic validation or manual validation? Or any suggestion on how can I activate it?

I know the below is from MyEclipse, but this is what I am looking for
http://docs.myeclipseide.com/topic/com.genuitec.myeclipse.web.doc/html/quickstarts/webprojects/index.html?cp=1_8_1_3_3#developing_jsp_resoruce

Hope this is available in the open source version of Eclipse as well, preferably Juno, or Kepler.

Thank you
Re: Eclipse Juno JSP compilation errors don't show in overview column [message #1404077 is a reply to message #1403793] Tue, 29 July 2014 13:05 Go to previous messageGo to next message
A B is currently offline A BFriend
Messages: 9
Registered: November 2013
Junior Member
Is this not possible at all? Do developers not do it with palin eclipse? I had hoped I will get a response on this forum on how to do it or steps on enabling it.
Re: Eclipse Juno JSP compilation errors don't show in overview column [message #1404099 is a reply to message #1404077] Tue, 29 July 2014 15:24 Go to previous messageGo to next message
Nick Sandonato is currently offline Nick SandonatoFriend
Messages: 126
Registered: July 2009
Senior Member
The validation should work without any real configuration.

If you create a new dynamic web project with a new JSP and you introduce compilation errors in scriptlets, do you have the same problem? Or is it for existing projects only?

One thing you might be able to try is to remove the folders jspsearch/ and translators/ from [path_to_your_workspace]/.metadata/.plugins/org.eclipse.jst.jsp.core. After this, manually validate your project or JSPs again.

If that doesn't work, you may file a bug [1] with any steps or details about the projects that you're using. Sample projects are always helpful.

[1] https://bugs.eclipse.org/bugs/enter_bug.cgi?product=WTP%20Source%20Editing
Re: Eclipse Juno JSP compilation errors don't show in overview column [message #1404146 is a reply to message #1404099] Wed, 30 July 2014 02:25 Go to previous message
A B is currently offline A BFriend
Messages: 9
Registered: November 2013
Junior Member
I created a new sample project and from the workspace, I tried to remove the folders jspsearch/ and translators/ from [path_to_workspace]/.metadata/.plugins/org.eclipse.jst.jsp.core. After this, manually validated the project or JSPs again. It still did not show any compilation errors.

As suggested, I have opened a bug report on Eclipse

https://bugs.eclipse.org/bugs/show_bug.cgi?id=440688



[Updated on: Wed, 30 July 2014 02:27]

Report message to a moderator

Previous Topic:Extensions in Qlikview
Next Topic:Web Service Tools separate installation
Goto Forum:
  


Current Time: Tue May 05 20:30:02 GMT 2015

Powered by FUDForum. Page generated in 0.02464 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software