Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Incompatible JVM [I've gone through the sticker, still doesn't work]
Incompatible JVM [I've gone through the sticker, still doesn't work] [message #1403653] Thu, 24 July 2014 21:57 Go to next message
Rui Cunha is currently offline Rui CunhaFriend
Messages: 3
Registered: July 2014
Junior Member
I had eclipse installed (juno version I think) when - after an update - it just stopped working, I couldn't create any project, when I did "file, create project" I only had two folders instead of the usual "Java, c++, etc". So I uninstalled it in the software market (I'm using Ubuntu) and tried to install the standard package for eclipse. (I think it comes with Java 8.0) Luna

When I downloaded the tar.gz I tried to run it and got Incompatible JVM. I tried this

Quote:
-startup
plugins/org.eclipse.equinox.launcher_1.3.0.v20140415-2008.jar
--launcher.library
plugins/org.eclipse.equinox.launcher.gtk.linux.x86_1.1.200.v20140603-1326
-product
org.eclipse.epp.package.standard.product
--launcher.defaultAction
openFile
-showsplash
org.eclipse.platform
--launcher.XXMaxPermSize
256m
--launcher.defaultAction
openFile
--launcher.appendVmargs
-vm
/usr/lib/jvm/java-6-openjdk-i386/jre/bin/java
-vmargs
-Dosgi.requiredJavaVersion=1.7
-XX:MaxPermSize=256m
-Xms40m
-Xmx512m


And other vm's including the default one. Still doesn't work. I really don't understand why and would enjoy a step by step since I've been working around this in the folders and can't do anything about it! Crying or Very Sad

Here is how my eclipse looked after that update, as an extra that might clue you into what happened...

http:// www.imagebam.com/image/417324340551622
http:// www.imagebam.com/image/c25d04340552586
http:// www.imagebam.com/image/3c7a76340551624
Re: Incompatible JVM [I've gone through the sticker, still doesn't work] [message #1403656 is a reply to message #1403653] Thu, 24 July 2014 23:22 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3510
Registered: July 2009
Senior Member

Which file did you download from Eclipse.org? I'm guessing it has x86_64 in the name?

Nitin Dahyabhai
Eclipse Web Tools Platform
Re: Incompatible JVM [I've gone through the sticker, still doesn't work] [message #1403657 is a reply to message #1403656] Thu, 24 July 2014 23:49 Go to previous messageGo to next message
Rui Cunha is currently offline Rui CunhaFriend
Messages: 3
Registered: July 2014
Junior Member
It was the 32 bit version...
Re: Incompatible JVM [I've gone through the sticker, still doesn't work] [message #1403658 is a reply to message #1403656] Thu, 24 July 2014 23:49 Go to previous message
Rui Cunha is currently offline Rui CunhaFriend
Messages: 3
Registered: July 2014
Junior Member
It was the 32 bit version...
Previous Topic:NIEM
Next Topic:ECLIPSE MAJORLY GONE WRONG,WINDOWS 7
Goto Forum:
  


Current Time: Mon Oct 14 03:14:50 GMT 2019

Powered by FUDForum. Page generated in 0.02573 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top