Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » scout » Deploying RAP product target(HTTP 403 error)
Deploying RAP product target [message #1403581] Thu, 24 July 2014 13:48 Go to next message
Dominic Hanlan is currently offline Dominic HanlanFriend
Messages: 98
Registered: July 2009
Member
Hi,

I have a basic RAP scout app which works perfectly on the local machine under eclipse. I am using DataSourceSecurityFilter and everything is fine.

When I deploy to the live target or any machine other than the eclipse environment the problems start.

The browser displays the login dialog and then I get a blank screen. Looking at the tomcat access log I get a 403 error on all my GETS

192.168.0.17 - - [24/Jul/2014:14:33:46 +0100] "GET /bindersWeb/res/html-styles.css HTTP/1.1" 403 961
192.168.0.17 - - [24/Jul/2014:14:33:46 +0100] "GET /bindersWeb/res/eclipseScoutBackground.png HTTP/1.1" 403 961
192.168.0.17 - - [24/Jul/2014:14:33:46 +0100] "GET /bindersWeb/res/loading.gif HTTP/1.1" 403 961
192.168.0.17 - - [24/Jul/2014:14:33:46 +0100] "GET /bindersWeb/rwt-resources/rap-client.js HTTP/1.1" 403 961
192.168.0.17 - - [24/Jul/2014:14:33:46 +0100] "GET /bindersWeb/rwt-resources/resources.js HTTP/1.1" 403 961
192.168.0.17 - - [24/Jul/2014:14:33:46 +0100] "GET /bindersWeb/rwt-resources/web-resources/ca-16.png HTTP/1.1" 403 961



My RAP plugin has the DataSourceSecurityFilter defined below, is there an alias problem? if so how does it work on the local machine?? I tried changing the /web alias to just / with the same result.

Any ideas????

Regards

/Dominic


    </filter>
      <filter
            aliases="/web"
            class="org.eclipse.scout.http.servletfilter.security.DataSourceSecurityFilter"
            ranking="40">
         <init-param
               name="active"
               value="true">
         </init-param>

[Updated on: Thu, 24 July 2014 14:09]

Report message to a moderator

Re: Deploying RAP product target [message #1403592 is a reply to message #1403581] Thu, 24 July 2014 14:10 Go to previous messageGo to next message
Dominic Hanlan is currently offline Dominic HanlanFriend
Messages: 98
Registered: July 2009
Member
Just updated the alias for the security filter to "/ /web" ... still no luck
Re: Deploying RAP product target [message #1694948 is a reply to message #1403592] Sun, 10 May 2015 10:32 Go to previous messageGo to next message
Boy D'Poy is currently offline Boy D'PoyFriend
Messages: 63
Registered: October 2011
Member
i experience the same problem even when i totally deactivate all filters on my app.
it fails at export time on both installed tomcat 7.0.52 & jetty 9.2.10
note: everything worked fine a short time ago ... with probably an old increment of tomcat 7 (that i unfortunatelly forgot due to regular updates of my linux system)
any help would be very appreciated! Wink


Once You Go Scout, You Never Come Out!
Re: Deploying RAP product target [message #1695640 is a reply to message #1694948] Mon, 18 May 2015 10:18 Go to previous message
Boy D'Poy is currently offline Boy D'PoyFriend
Messages: 63
Registered: October 2011
Member
not doing basic, or ldap, db or anonymous authentification, I wrote my own auth filter (where HttpServletRequest#getUserPrincipal() & HttpServletRequest#getRemoteUser() returns null wich is normal for my business), so I had to deactivate the HttpAuthJaasFilter in my production config.ini file like this:
org.eclipse.scout.rt.server.commons.servletfilter.helper.HttpAuthJaasFilter#active=false


Once You Go Scout, You Never Come Out!

[Updated on: Mon, 18 May 2015 10:52]

Report message to a moderator

Previous Topic:Scout M7: Require-Bundle: org.eclipse.rap.fileupload
Next Topic:RAP: Open File (pdf, xls,...) openUrlInBrowser
Goto Forum:
  


Current Time: Sat Jul 04 20:55:51 GMT 2015

Powered by FUDForum. Page generated in 0.04613 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software