Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse 4 » Eclipse 4.x API and 3.x API plugins in one RCP application
Eclipse 4.x API and 3.x API plugins in one RCP application [message #1403246] Tue, 22 July 2014 15:25 Go to next message
Karl Puperze is currently offline Karl PuperzeFriend
Messages: 36
Registered: August 2011
Member
We have migrated our RCP product to Eclipse 4.4 using the compatibility layer. We would like to continue our work based on Eclipse 4.4 standards and migrate our old plugins from time to time. This means, that we have 4.x and 3.x based plugins in one RCP product. We already have implemented an application model and added a new 4.x based plugin with an application model fragment. This works. But is it possible to make extensions to 3.x based plugin stuff from a 4.x based plugin? E.g. add a command contribution (popup menu) in an application model fragment to a view, which has been registered in a 3.x based plugin?
Re: Eclipse 4.x API and 3.x API plugins in one RCP application [message #1412895 is a reply to message #1403246] Wed, 27 August 2014 10:01 Go to previous message
Karl Puperze is currently offline Karl PuperzeFriend
Messages: 36
Registered: August 2011
Member
This does not work. We wrote our own Compatibility Layer base on 3.x API, so that we can use IEclipseContext and annotations in our Views, Editors and Wizards and continue without the application model.
Previous Topic:Invalid ToolItem state with "org.eclipse.ui.file.save"
Next Topic:Remove CVS plugin from bundles?
Goto Forum:
  


Current Time: Thu Jan 21 09:27:38 GMT 2021

Powered by FUDForum. Page generated in 0.02519 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top