Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Eclipse Juno Crashes Frequently without warning(Eclipse Juno crashes frequently)
Eclipse Juno Crashes Frequently without warning [message #1402865] Thu, 17 July 2014 23:39 Go to next message
A B is currently offline A BFriend
Messages: 11
Registered: November 2013
Junior Member
We are trying to adopt Eclipse Juno ( 4.2 ) with WAS 8.5 for Developers in our organisation.

We have a few developers whose Eclipse keeps on crashing without any prior warning and all their work gets lost in the middle of things. Sometimes, it crashes even when they are just browsing the code.

We are on Windows 7 64-bit.

So far, we have been unable to find the causes of the crashes.

How can we go about debugging this problem and finding a solution?

Let me know, if I can provide any other details.

Thank you

Re: Eclipse Juno Crashes Frequently without warning [message #1402872 is a reply to message #1402865] Fri, 18 July 2014 05:03 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 31559
Registered: July 2009
Senior Member
What do you mean by a crash? You mean the JVM itself just dies with a
JVM dump? If that's the case, it's probably best to get a new version
of the JVM. I know I used to have problems bringing up help which
caused the JVM to crash. It was a problem with Lucene (used by help for
indexing) that could be avoided with some magical JVM option to turn off
some feature in the JIT and went away with later versions of the JVM...


On 18/07/2014 1:39 AM, A B wrote:
> We are trying to adopt Eclipse Juno ( 4.2 ) with WAS 8.5 for
> Developers in our organisation.
>
> We have a few developers whose Eclipse keeps on crashing without any
> prior warning and all their work gets lost in the middle of things.
> Sometimes, it crashes even when they are just browsing the code.
>
> We are on Windows 7 64-bit.
> So far, we have been unable to find the causes of the crashes.
>
> How can we go about debugging this problem and finding a solution?
>
> Let me know, if I can provide any other details.
>
> Thank you
>
>


Ed Merks
Professional Support: https://www.macromodeling.com/
Re: Eclipse Juno Crashes Frequently without warning [message #1402923 is a reply to message #1402872] Fri, 18 July 2014 11:32 Go to previous messageGo to next message
A B is currently offline A BFriend
Messages: 11
Registered: November 2013
Junior Member
I will ask the developers who are complaining about this issue whether they get a JVM dump. One of the developers said that - if he leaves Eclipse open but doing something else, then also Eclipse crashes on him at least 2-3 times a day.

Is there a specific version / level of JVM I should make sure we use?

Our currently certified version is 6u26. Of course, it is possible that the developers experiencing the crash have a different jvm associated with Eclipse

Thank you
Re: Eclipse Juno Crashes Frequently without warning [message #1402959 is a reply to message #1402923] Fri, 18 July 2014 18:09 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 31559
Registered: July 2009
Senior Member
In the end, a crash of the JVM is a JVM bug so best use a newer JVM if
you experience JVM crashes. Certainly 6u26 is a very old version of 1.6...


On 18/07/2014 1:32 PM, A B wrote:
> I will ask the developers who are complaining about this issue whether
> they get a JVM dump. One of the developers said that - if he leaves
> Eclipse open but doing something else, then also Eclipse crashes on
> him at least 2-3 times a day.
>
> Is there a specific version / level of JVM I should make sure we use?
>
> Our currently certified version is 6u26. Of course, it is possible
> that the developers experiencing the crash have a different jvm
> associated with Eclipse
>
> Thank you
>


Ed Merks
Professional Support: https://www.macromodeling.com/
Re: Eclipse Juno Crashes Frequently without warning [message #1402965 is a reply to message #1402959] Fri, 18 July 2014 20:16 Go to previous messageGo to next message
A B is currently offline A BFriend
Messages: 11
Registered: November 2013
Junior Member
We added the -vm parameter to the eclipse.ini to use the Java 7u60 version and we will watch if that helps.

In the meantime, if someone can help me decipher the logs that get generated when Eclipse crashes, I would really appreciate it.

I have attached the logs here.

Thanks
Re: Eclipse Juno Crashes Frequently without warning [message #1402990 is a reply to message #1402965] Sat, 19 July 2014 11:19 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 31559
Registered: July 2009
Senior Member
I get the impression it's crashing in the main event loop processing the
UI event queue where it's off in some low-level OS-specific code.
There's not much detail here beyond that. I'm hopeful that a decent
recent JVM will help.

On 18/07/2014 10:16 PM, A B wrote:
> We added the -vm parameter to the eclipse.ini to use the Java 7u60 version and we will watch if that helps.
>
> In the meantime, if someone can help me decipher the logs that get generated when Eclipse crashes, I would really appreciate it.
>
> I have attached the logs here.
>
> Thanks


Ed Merks
Professional Support: https://www.macromodeling.com/
Re: Eclipse Juno Crashes Frequently without warning [message #1403452 is a reply to message #1402990] Wed, 23 July 2014 19:23 Go to previous messageGo to next message
A B is currently offline A BFriend
Messages: 11
Registered: November 2013
Junior Member
Thank you.

So, we changed the -vm parameter in eclipse.ini to point to the Websphere 8.5 - JDK 7 vm. After that the original crashing has gone away.

Now we have a new issue. Eclipse now crashes with "Microsoft Visual C++ Runtime Library" as title on the window. Another pop-up that says Java (TM) Platform SE library has stopped working.

What else do I need to look at to eliminate the new error now? Are there any parameters we need to look at, from eclipse.ini after adding the -vm parameter?

Thank you
Re: Eclipse Juno Crashes Frequently without warning [message #1708081 is a reply to message #1403452] Sat, 12 September 2015 10:57 Go to previous message
A B is currently offline A BFriend
Messages: 11
Registered: November 2013
Junior Member
I realize this is more than a year old, but recently, we found a solution, so posting it here. The issue was resolved when we changed the default editor for xhtml pages from "Rich Page Editor" to another type. The Rich Page Editor was continuously causing memory leak, which was ultimately leading to the crashing of entire workspace after a few hours.
Previous Topic:Custom application based on Eclipse IDE
Next Topic:Web development in Eclipse
Goto Forum:
  


Current Time: Fri Oct 30 02:51:54 GMT 2020

Powered by FUDForum. Page generated in 0.03048 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top