Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » e(fx)clipse » Error Loading Hooks on Luna
Error Loading Hooks on Luna [message #1402689] Thu, 17 July 2014 10:52 Go to next message
Michael Jastram is currently offline Michael JastramFriend
Messages: 192
Registered: April 2010
Location: Düsseldorf, Germany
Senior Member
I *suspect* that I have a Kepler vs. Luna problem. I am building an application that is based on Luna and needs JavaFX access with Java 7.

I configured my application by adding the following VM argument:

-Dosgi.framework.extensions=org.eclipse.fx.osgi

... but I get this error message:

!SESSION 2014-07-17 12:30:13.402 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.7.0_40
java.vendor=Oracle Corporation
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US

!ENTRY org.eclipse.osgi 4 0 2014-07-17 12:30:13.734
!MESSAGE error loading hook: org.eclipse.fx.osgi.fxloader.FXClassLoadingConfigurator
!STACK 0
java.lang.NoClassDefFoundError: org/eclipse/osgi/baseadaptor/HookConfigurator
	at java.lang.ClassLoader.defineClass1(Native Method)
	at java.lang.ClassLoader.defineClass(ClassLoader.java:792)
	at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
...


The Problem seems to be the HookConfigurator - from Kepler to Luna, the package name changed, from

org.eclipse.osgi.baseadaptor.HookConfigurator

to

org.eclipse.osgi.internal.hookregistry.HookConfigurator

I used the following update site: http://download.eclipse.org/efxclipse/updates-released/0.9.0/site

So this leads to three questions:


  • Am I right that this is a Kepler-Luna incompatibilityy?
  • If so, is there another update site I can use? I need an update site (vs. download), as there is a maven build, relying on a target platform definition consisting exclusively of update sites.
  • I am confused, as 0.9.0 seems to work with Luna quite happily, at least in the IDE. However, I do not want to install the complete IDE features, as I don't want all the JDT dependencies.


Thanks for your help!

- Michael
Re: Error Loading Hooks on Luna [message #1402713 is a reply to message #1402689] Thu, 17 July 2014 11:36 Go to previous messageGo to next message
Thomas Schindl is currently offline Thomas SchindlFriend
Messages: 5866
Registered: July 2009
Senior Member
Yes - if your runtime is based on Luna you need to use the 1.0.0 nightly
builds and their adapter hooks - the reason is that Equinox does not
support the old SPI.

That the tooling 0.9.0 tooling works in Luna is that it does not need to
hooks (unless you open the JavaFX Live Preview which will fail!).

A complete target platform composed solely of runtime components can be
fetched from http://download.eclipse.org/efxclipse/runtime-nightly/site
or http://download.eclipse.org/efxclipse/runtime-nightly/site_assembly.zip

This p2 repo is completely self-contained because it holds equinox, p2,
e(fx)clipse-runtime components and e4.

If you write an RCP application we have another p2 repo which only holds
the adapter hooks and can be retrieved from
http://download.eclipse.org/efxclipse/runtime-shared-nightly/site/ and
http://download.eclipse.org/efxclipse/runtime-shared-nightly/site_assembly.zip

Tom

On 17.07.14 12:52, Michael Jastram wrote:
> I *suspect* that I have a Kepler vs. Luna problem. I am building an
> application that is based on Luna and needs JavaFX access with Java 7.
>
> I configured my application by adding the following VM argument:
>
> -Dosgi.framework.extensions=org.eclipse.fx.osgi
>
> .. but I get this error message:
>
> !SESSION 2014-07-17 12:30:13.402
> -----------------------------------------------
> eclipse.buildId=unknown
> java.version=1.7.0_40
> java.vendor=Oracle Corporation
> BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US
>
> !ENTRY org.eclipse.osgi 4 0 2014-07-17 12:30:13.734
> !MESSAGE error loading hook:
> org.eclipse.fx.osgi.fxloader.FXClassLoadingConfigurator
> !STACK 0
> java.lang.NoClassDefFoundError:
> org/eclipse/osgi/baseadaptor/HookConfigurator
> at java.lang.ClassLoader.defineClass1(Native Method)
> at java.lang.ClassLoader.defineClass(ClassLoader.java:792)
> at
> java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
> ..
>
> The Problem seems to be the HookConfigurator - from Kepler to Luna, the
> package name changed, from
>
> org.eclipse.osgi.baseadaptor.HookConfigurator
>
> to
> org.eclipse.osgi.internal.hookregistry.HookConfigurator
>
> I used the following update site:
> http://download.eclipse.org/efxclipse/updates-released/0.9.0/site
>
> So this leads to three questions:
>
>
> Am I right that this is a Kepler-Luna incompatibilityy?
> If so, is there another update site I can use? I need an update site
> (vs. download), as there is a maven build, relying on a target platform
> definition consisting exclusively of update sites.
> I am confused, as 0.9.0 seems to work with Luna quite happily, at least
> in the IDE. However, I do not want to install the complete IDE
> features, as I don't want all the JDT dependencies.
>
>
> Thanks for your help!
>
> - Michael
Re: Error Loading Hooks on Luna [message #1402726 is a reply to message #1402713] Thu, 17 July 2014 11:58 Go to previous messageGo to next message
Michael Jastram is currently offline Michael JastramFriend
Messages: 192
Registered: April 2010
Location: Düsseldorf, Germany
Senior Member
Hi Tom,

Thanks for the blazingly fast response. I plugged in the new URL, and everything worked right away. I assume that I can just switch to 1.0.0, once it's officially released, right?

Best,

- Michael
Re: Error Loading Hooks on Luna [message #1402736 is a reply to message #1402726] Thu, 17 July 2014 12:14 Go to previous message
Thomas Schindl is currently offline Thomas SchindlFriend
Messages: 5866
Registered: July 2009
Senior Member
Hi,

Yes you can - we are starting the ramp down for 1.0.0 at the beginning
of next week and plan to release end of month.

Tom

On 17.07.14 13:58, Michael Jastram wrote:
> Hi Tom,
>
> Thanks for the blazingly fast response. I plugged in the new URL, and
> everything worked right away. I assume that I can just switch to 1.0.0,
> once it's officially released, right?
>
> Best,
>
> - Michael
Previous Topic:Important upcoming change in toolitem-enablement check
Next Topic:SwingNode - ClassNotFoundException
Goto Forum:
  


Current Time: Wed Sep 02 08:48:30 GMT 2015

Powered by FUDForum. Page generated in 0.06133 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software