Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Hudson » hudson jobs failed at the end with Failed to join the process(hudson.util.IOException2: Failed to join the process)
hudson jobs failed at the end with Failed to join the process [message #1402529] Thu, 17 July 2014 05:40 Go to next message
Lina Muryanto is currently offline Lina MuryantoFriend
Messages: 4
Registered: July 2014
Junior Member
Hi,
I am using hudson 3.1.2.
I have Hudson SSH Slaves plugin version 3.0.2 installed.

I have been running into the following at the end of running my hudson jobs

FATAL: command execution failed
hudson.util.IOException2: Failed to join the process
at hudson.Proc$RemoteProc.join(Proc.java:362)
at hudson.Launcher$ProcStarter.join(Launcher.java:273)
at hudson.tasks.CommandInterpreter.perform(CommandInterpreter.java:79)
at hudson.tasks.CommandInterpreter.perform(CommandInterpreter.java:54)
at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:34)
at hudson.model.AbstractBuild$AbstractRunner.perform(AbstractBuild.java:736)
at hudson.model.Build$RunnerImpl.build(Build.java:181)
at hudson.model.Build$RunnerImpl.doRun(Build.java:136)
at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:524)
at hudson.model.Run.run(Run.java:1450)
at hudson.matrix.MatrixRun.run(MatrixRun.java:142)
at hudson.model.ResourceController.execute(ResourceController.java:82)
at hudson.model.Executor.run(Executor.java:137)
Caused by: java.util.concurrent.ExecutionException: java.lang.NoClassDefFoundError: hudson/remoting/Channel$3
at hudson.remoting.Channel$2.adapt(Channel.java:677)
at hudson.remoting.Channel$2.adapt(Channel.java:672)
at hudson.remoting.FutureAdapter.get(FutureAdapter.java:48)
at hudson.Proc$RemoteProc.join(Proc.java:353)
... 12 more
Caused by: java.lang.NoClassDefFoundError: hudson/remoting/Channel$3
at hudson.remoting.Channel.flushPipe(Channel.java:695)
at hudson.Launcher$RemoteLaunchCallable.call(Launcher.java:839)
at hudson.Launcher$RemoteLaunchCallable.call(Launcher.java:797)
at hudson.remoting.UserRequest.perform(UserRequest.java:107)
at hudson.remoting.UserRequest.perform(UserRequest.java:41)
at hudson.remoting.Request$2.run(Request.java:276)
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:439)
at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
at java.util.concurrent.FutureTask.run(FutureTask.java:138)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:895)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:918)
at java.lang.Thread.run(Thread.java:680)
Notifying upstream projects of job completion
Finished: FAILURE


Powered by Hudson Open Source Continuous Integration Server from the Eclipse Foundation
Instance: Hudson Page generated: Jul 16, 2014 10:33:53 PM

===============
Please help,
Lina


Re: hudson jobs failed at the end with Failed to join the process [message #1403634 is a reply to message #1402529] Thu, 24 July 2014 17:28 Go to previous messageGo to next message
Winston Prakash is currently offline Winston PrakashFriend
Messages: 495
Registered: August 2011
Location: Fremont, CA USA
Senior Member
You might want to backup your slave directory and delete it and let Hudson recreate it. Looks like some old version of slave.jar is causing this.

Winston Prakash
Eclipse Hudson team
Re: hudson jobs failed at the end with Failed to join the process [message #1403735 is a reply to message #1403634] Fri, 25 July 2014 17:12 Go to previous messageGo to next message
Lina Muryanto is currently offline Lina MuryantoFriend
Messages: 4
Registered: July 2014
Junior Member
Thanks Winston,
Where can I find the slave directory?
Is it the one under my $HUDSON_HOME/jobs/<jobname>/configurations/axis-hudson/<slavename> ??

Lina
Re: hudson jobs failed at the end with Failed to join the process [message #1403752 is a reply to message #1403735] Fri, 25 July 2014 21:55 Go to previous message
Winston Prakash is currently offline Winston PrakashFriend
Messages: 495
Registered: August 2011
Location: Fremont, CA USA
Senior Member
I meant the "Remote FS Root" you specify while setting up slave as shown below

https://dl.dropboxusercontent.com/u/13144273/remote-fs.png


Winston Prakash
Eclipse Hudson team
Previous Topic:Unix slave died
Next Topic:How to build the previous version
Goto Forum:
  


Current Time: Fri May 29 06:45:45 GMT 2015

Powered by FUDForum. Page generated in 0.02822 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software