Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Jubula » ub_app_activate step failing(ub_app_activate step failing)
ub_app_activate step failing [message #1398579] Fri, 11 July 2014 09:14 Go to next message
Bala S is currently offline Bala SFriend
Messages: 3
Registered: July 2014
Location: India
Junior Member
Hi All,
I am automating swing application which is launched as jnlp file.I have created a executeable jar which uses netx to launch the jnlp application with which I was able to launch the application and perform object mapping in Jubula successfully using the default AUT agent, But when I run the test the eclipse minimizes and in Approx ~5 sec the eclipse maximises with test results showing failed ub_app_activate step and other steps are not executed. I tried different activation methods and my application is right after the eclipse but nothing worked out.

1. ub_app_activate is the first step in my test case
2. I have installed Jubula from Eclipse market place as plugin
3. Eclipse Version: Luna Release (4.4.0)
4. Eclipse Build id: 20140612-0600
5. I am using Windows 7 professional with service pack 1, 64 bit
6.Jubula version :Jubula Functional Testing 2.3.0.201406030848

Error details shown at failed ub_app_activate step:
Type: Action Error
Error Description: Execution Error: "java.lang.NullPointerException
at sun.awt.SunToolkit.getSystemEventQueueImplPP(Unknown Source)
at sun.awt.SunToolkit.getSystemEventQueueImplPP(Unknown Source)
at sun.awt.SunToolkit.getSystemEventQueueImpl(Unknown Source)
at java.awt.Toolkit.getEventQueue(Unknown Source)
at java.awt.EventQueue.isDispatchThread(Unknown Source)
at javax.swing.SwingUtilities.isEventDispatchThread(Unknown Source)
at org.eclipse.jubula.rc.swing.driver.EventThreadQueuerAwtImpl.invokeAndWait(EventThreadQueuerAwtImpl.java:45)
at org.eclipse.jubula.rc.swing.driver.RobotAwtImpl.getActiveWindow(RobotAwtImpl.java:815)
at org.eclipse.jubula.rc.swing.driver.RobotAwtImpl.activateApplication(RobotAwtImpl.java:758)
at org.eclipse.jubula.rc.common.tester.AbstractApplicationTester.rcActivate(AbstractApplicationTester.java:636)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.apache.commons.beanutils.MethodUtils.invokeMethod(MethodUtils.java:281)
at org.apache.commons.beanutils.MethodUtils.invokeMethod(MethodUtils.java:225)
at org.eclipse.jubula.rc.common.commands.MethodInvoker.invoke(MethodInvoker.java:64)
at org.eclipse.jubula.rc.common.commands.AbstractCapTestCommand.execute(AbstractCapTestCommand.java:241)
at org.eclipse.jubula.communication.Communicator$ConnectionListener.received(Communicator.java:840)
at org.eclipse.jubula.communication.connection.Connection.fireMessageReceived(Connection.java:401)
at org.eclipse.jubula.communication.connection.Connection.access$2(Connection.java:390)
at org.eclipse.jubula.communication.connection.Connection$ReaderThread.run(Connection.java:453)
"

Can anybody help, please?

Thanks
Re: ub_app_activate step failing [message #1401358 is a reply to message #1398579] Tue, 15 July 2014 13:33 Go to previous message
Achim Loerke is currently offline Achim LoerkeFriend
Messages: 364
Registered: July 2009
Location: Braunschweig, Germany
Senior Member

This might be a racing condition where the test executor recognizes a started Java program (netx, don't know what it does) and tries to get the GUI thread before the actual AUT is running. Try adding a wait at the start of your test and disable automatic AUT activation (in the Expert section of the AUT configuration dialog).

- Achim
Previous Topic:test HTML and RCP in a same AUT
Next Topic:Summer time - vacation time
Goto Forum:
  


Current Time: Wed Sep 02 00:42:44 GMT 2015

Powered by FUDForum. Page generated in 0.01898 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software