Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » e(fx)clipse » e(fx)clipse 1.0-SNAPSHOT - Sample App Errors(Problems with Media Sample App in e(fx)clipse 1.0-SNAPSHOT)
e(fx)clipse 1.0-SNAPSHOT - Sample App Errors [message #1397889] Thu, 10 July 2014 09:59 Go to next message
Danny Tramnitzke is currently offline Danny TramnitzkeFriend
Messages: 15
Registered: April 2014
Junior Member
Hi,

I encountered 6 errors when creating the Media Sample App from
New Project.. -> JavaFX -> Samples -> e4 Media Application

Errors are:

Bundle 'org.eclipse.fx.core.databinding' cannot be resolved	MANIFEST.MF	/MyFirstE4JavaFxApp/META-INF	line 16	Plug-in Problem

Bundle 'org.eclipse.fx.ui.databinding' cannot be resolved	MANIFEST.MF	/MyFirstE4JavaFxApp/META-INF	line 17	Plug-in Problem

Bundle 'org.eclipse.fx.ui.di' cannot be resolved	MANIFEST.MF	/MyFirstE4JavaFxApp/META-INF	line 14	Plug-in Problem

Bundle 'org.eclipse.fx.ui.theme' cannot be resolved	MANIFEST.MF	/MyFirstE4JavaFxApp/META-INF	line 13	Plug-in Problem

Bundle 'org.eclipse.fx.ui.workbench.fx' cannot be resolved	MANIFEST.MF	/MyFirstE4JavaFxApp/META-INF	line 7	Plug-in Problem

Unknown extension point: 'org.eclipse.fx.ui.theme'	plugin.xml	/MyFirstE4JavaFxApp	line 15	Plug-in Problem


I'm using a fresh installation and workspace of eclipse-SDK-4.4-win32-x86_64-efx-1.0.0-SNAPSHOT.zip (downloads.efxclipse.bestsolution.at/downloads/nightly/sdk/eclipse-SDK-4.4-win32-x86_64-efx-1.0.0-SNAPSHOT.zip)

Shouldn't it work out of the box ? Or did I miss the target platform? (which I didn't touch so far!) But an according target platform should be included into the all-in-one eclipse bundle, isn't it ?

I've started eclipse the first time with option: -vm C:\PROGRA~1\Java\jdk8\bin\

My Java Version:
java version "1.8.0"
Java(TM) SE Runtime Environment (build 1.8.0-b132)
Java HotSpot(TM) 64-Bit Server VM (build 25.0-b70, mixed mode)


Regards,
Danny
Re: e(fx)clipse 1.0-SNAPSHOT - Sample App Errors [message #1397910 is a reply to message #1397889] Thu, 10 July 2014 10:32 Go to previous messageGo to next message
Thomas Schindl is currently offline Thomas SchindlFriend
Messages: 5803
Registered: July 2009
Senior Member
If you have not set a target-platform this will not work. You should
follow http://wiki.eclipse.org/Efxclipse/Tutorials/Tutorial3.

The all-in-one download only contains the Tooling, a target should never
by part of your IDE (as it would potentially interfere with other
bundles in your IDE).

Tom

On 10.07.14 11:59, Danny Tramnitzke wrote:
> Hi,
>
> I encountered 6 errors when creating the Media Sample App from New
> Project.. -> JavaFX -> Samples -> e4 Media Application
>
> Errors are:
>
>
> Bundle 'org.eclipse.fx.core.databinding' cannot be resolved
> MANIFEST.MF /MyFirstE4JavaFxApp/META-INF line 16 Plug-in Problem
>
> Bundle 'org.eclipse.fx.ui.databinding' cannot be resolved
> MANIFEST.MF /MyFirstE4JavaFxApp/META-INF line 17 Plug-in Problem
>
> Bundle 'org.eclipse.fx.ui.di' cannot be resolved MANIFEST.MF
> /MyFirstE4JavaFxApp/META-INF line 14 Plug-in Problem
>
> Bundle 'org.eclipse.fx.ui.theme' cannot be resolved MANIFEST.MF
> /MyFirstE4JavaFxApp/META-INF line 13 Plug-in Problem
>
> Bundle 'org.eclipse.fx.ui.workbench.fx' cannot be resolved
> MANIFEST.MF /MyFirstE4JavaFxApp/META-INF line 7 Plug-in Problem
>
> Unknown extension point: 'org.eclipse.fx.ui.theme' plugin.xml
> /MyFirstE4JavaFxApp line 15 Plug-in Problem
>
>
> I'm using a fresh installation and workspace of
> eclipse-SDK-4.4-win32-x86_64-efx-1.0.0-SNAPSHOT.zip
> (downloads.efxclipse.bestsolution.at/downloads/nightly/sdk/eclipse-SDK-4.4-win32-x86_64-efx-1.0.0-SNAPSHOT.zip)
>
>
> Shouldn't it work out of the box ? Or did I miss the target platform?
> (which I didn't touch so far!) But an according target platform should
> be included into the all-in-one eclipse bundle, isn't it ?
>
> I've started eclipse the first time with option: -vm
> C:\PROGRA~1\Java\jdk8\bin\
>
> My Java Version:
>
> java version "1.8.0"
> Java(TM) SE Runtime Environment (build 1.8.0-b132)
> Java HotSpot(TM) 64-Bit Server VM (build 25.0-b70, mixed mode)
>
>
> Regards,
> Danny
Re: e(fx)clipse 1.0-SNAPSHOT - Sample App Errors [message #1397925 is a reply to message #1397910] Thu, 10 July 2014 10:57 Go to previous messageGo to next message
Danny Tramnitzke is currently offline Danny TramnitzkeFriend
Messages: 15
Registered: April 2014
Junior Member
Thanks Tom, it runs now !

Maybe a little hint in that Sample App Project ( e.g. README.txt ) would be helpful.

Regards,
Danny
Re: e(fx)clipse 1.0-SNAPSHOT - Sample App Errors [message #1397936 is a reply to message #1397925] Thu, 10 July 2014 11:13 Go to previous messageGo to next message
Thomas Schindl is currently offline Thomas SchindlFriend
Messages: 5803
Registered: July 2009
Senior Member
File a bug and we can add such a guy!

Tom

On 10.07.14 12:57, Danny Tramnitzke wrote:
> Thanks Tom, it runs now !
>
> Maybe a little hint in that Sample App Project ( e.g. README.txt ) would
> be helpful.
>
> Regards,
> Danny
Re: e(fx)clipse 1.0-SNAPSHOT - Sample App Errors [message #1398048 is a reply to message #1397936] Thu, 10 July 2014 14:29 Go to previous messageGo to next message
Danny Tramnitzke is currently offline Danny TramnitzkeFriend
Messages: 15
Registered: April 2014
Junior Member
Will do.

The next question about errors with 1.0-Snapshot :

Did you tag the sources for that version ? I can only see a tag for 0.9.0 here: http://git.eclipse.org/c/efxclipse/org.eclipse.efxclipse.git/

Now I'm dealing with the next error, a NumberFormatException at a widget renderer component. But before I bother everybody with each single error, I'd like to have a look into the sources first.

[Updated on: Fri, 11 July 2014 07:58]

Report message to a moderator

Re: e(fx)clipse 1.0-SNAPSHOT - Sample App Errors [message #1398217 is a reply to message #1398048] Thu, 10 July 2014 20:18 Go to previous message
Thomas Schindl is currently offline Thomas SchindlFriend
Messages: 5803
Registered: July 2009
Senior Member
For which version? We have not yet released 1.0 so there's no tag for it
yet.

If you see exception/bugs/ feel free to file bugzilla entries - if you
have a clue/patch what's wrong even better - create a gerrit review and
we'll merge fairly all contributions within 1-2 days.

Tom

On 10.07.14 16:29, Danny Tramnitzke wrote:
> Will do.
>
> The next question about errors with 1.0-Snapshot :
>
> Did you tag the sources for that version ? I can only see a tag for
> 0.9.0 here: http://git.eclipse.org/c/efxclipse/org.eclipse.efxclipse.git/
>
> Now I'm dealing with the next error, a NumberFormatException at a widget
> renderer component. But before I bother everybody with each single
> error, I'd like to have a look into the sources first.
Previous Topic:JavaFX Preview
Next Topic:Testing FXCanvas with SWTBot
Goto Forum:
  


Current Time: Thu Jul 30 10:23:54 GMT 2015

Powered by FUDForum. Page generated in 0.02912 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software