Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » TMF (Xtext) » Error after Xtext Utils add
Error after Xtext Utils add [message #1395729] Mon, 07 July 2014 10:01 Go to next message
St. K. is currently offline St. K.Friend
Messages: 6
Registered: June 2014
Junior Member
Hi,

I receive the following error since I install xtext utils into my project. I can now neither generate the grammar (Mwe2) nor generate the Xtext artifacts.
I have been trying to fix it somehow, but all my attemps go wrong.

Any ideas what I'm doing wrong?

EDIT: I did receive a missing ANTLR notification the first time I tried to compile the grammar and it was suggested that I download it. I confirmed with y (yes) and received an error.

0    [main] INFO  lipse.emf.mwe.utils.StandaloneSetup  - Registering platform uri '/Users/stefan/Documents/workspace/PhD-Stefan/eclipse_workspace'
122  [main] INFO  lipse.emf.mwe.utils.StandaloneSetup  - Adding generated EPackage 'org.eclipse.xtext.xbase.XbasePackage'
431  [main] INFO  clipse.emf.mwe.utils.GenModelHelper  - Registered GenModel 'http://www.eclipse.org/Xtext/Xbase/XAnnotations' from 'platform:/resource/org.eclipse.xtext.xbase/model/Xbase.genmodel'
438  [main] INFO  clipse.emf.mwe.utils.GenModelHelper  - Registered GenModel 'http://www.eclipse.org/xtext/xbase/Xtype' from 'platform:/resource/org.eclipse.xtext.xbase/model/Xbase.genmodel'
465  [main] INFO  clipse.emf.mwe.utils.GenModelHelper  - Registered GenModel 'http://www.eclipse.org/xtext/xbase/Xbase' from 'platform:/resource/org.eclipse.xtext.xbase/model/Xbase.genmodel'
465  [main] INFO  clipse.emf.mwe.utils.GenModelHelper  - Registered GenModel 'http://www.eclipse.org/xtext/common/JavaVMTypes' from 'platform:/resource/org.eclipse.xtext.common.types/model/JavaVMTypes.genmodel'
2606 [main] INFO  lipse.emf.mwe.utils.StandaloneSetup  - Adding generated EPackage 'org.eclipse.xtext.common.types.TypesPackage'
2639 [main] INFO  ipse.emf.mwe.utils.DirectoryCleaner  - Cleaning /Users/stefan/Documents/workspace/PhD-Stefan/eclipse_workspace/ch.cern.enice.ctl/../ch.cern.enice.ctl/src-gen
2642 [main] INFO  ipse.emf.mwe.utils.DirectoryCleaner  - Cleaning /Users/stefan/Documents/workspace/PhD-Stefan/eclipse_workspace/ch.cern.enice.ctl/../ch.cern.enice.ctl/model
2642 [main] INFO  ipse.emf.mwe.utils.DirectoryCleaner  - Cleaning /Users/stefan/Documents/workspace/PhD-Stefan/eclipse_workspace/ch.cern.enice.ctl/../ch.cern.enice.ctl.ui/src-gen
2958 [main] ERROR mf.mwe2.launch.runtime.Mwe2Launcher  - org.eclipse.internal.xtend.expression.ast.Identifier.getValue()Ljava/lang/String;
java.lang.NoSuchMethodError: org.eclipse.internal.xtend.expression.ast.Identifier.getValue()Ljava/lang/String;
	at org.eclipse.internal.xpand2.parser.XpandFactory.createTextStatement(XpandFactory.java:77)
	at org.eclipse.internal.xpand2.parser.XpandParser.text(XpandParser.java:1325)
	at org.eclipse.internal.xpand2.parser.XpandParser.template(XpandParser.java:254)
	at org.eclipse.internal.xpand2.parser.XpandParseFacade.file(XpandParseFacade.java:40)
	at org.eclipse.internal.xpand2.parser.XpandParseFacade.file(XpandParseFacade.java:27)
	at org.eclipse.xpand2.XpandExecutionContextImpl$1.parse(XpandExecutionContextImpl.java:173)
	at org.eclipse.xtend.expression.ResourceManagerDefaultImpl.loadResource(ResourceManagerDefaultImpl.java:64)
	at org.eclipse.xpand2.XpandExecutionContextImpl.findTemplate(XpandExecutionContextImpl.java:293)
	at org.eclipse.xpand2.XpandExecutionContextImpl.findTemplate(XpandExecutionContextImpl.java:280)
	at org.eclipse.xpand2.XpandExecutionContextImpl.findDefinition(XpandExecutionContextImpl.java:232)
	at org.eclipse.xpand2.XpandFacade.evaluate2(XpandFacade.java:57)
	at org.eclipse.xtext.generator.AbstractGeneratorFragment.generate(AbstractGeneratorFragment.java:42)
	at org.eclipse.xtext.generator.DefaultGeneratorFragment.generate(DefaultGeneratorFragment.java:122)
	at org.eclipse.xtext.generator.CompositeGeneratorFragment.generate(CompositeGeneratorFragment.java:154)
	at org.eclipse.xtext.generator.Generator.generate(Generator.java:396)
	at org.eclipse.xtext.generator.Generator.invokeInternal(Generator.java:138)
	at org.eclipse.emf.mwe.core.lib.AbstractWorkflowComponent.invoke(AbstractWorkflowComponent.java:126)
	at org.eclipse.emf.mwe.core.lib.Mwe2Bridge.invoke(Mwe2Bridge.java:34)
	at org.eclipse.emf.mwe.core.lib.AbstractWorkflowComponent.invoke(AbstractWorkflowComponent.java:201)
	at org.eclipse.emf.mwe2.runtime.workflow.AbstractCompositeWorkflowComponent.invoke(AbstractCompositeWorkflowComponent.java:35)
	at org.eclipse.emf.mwe2.runtime.workflow.Workflow.run(Workflow.java:19)
	at org.eclipse.emf.mwe2.launch.runtime.Mwe2Runner.run(Mwe2Runner.java:102)
	at org.eclipse.emf.mwe2.launch.runtime.Mwe2Runner.run(Mwe2Runner.java:62)
	at org.eclipse.emf.mwe2.launch.runtime.Mwe2Runner.run(Mwe2Runner.java:52)
	at org.eclipse.emf.mwe2.launch.runtime.Mwe2Launcher.run(Mwe2Launcher.java:74)
	at org.eclipse.emf.mwe2.launch.runtime.Mwe2Launcher.main(Mwe2Launcher.java:35)

[Updated on: Mon, 07 July 2014 10:02]

Report message to a moderator

Re: Error after Xtext Utils add [message #1400595 is a reply to message #1395729] Mon, 14 July 2014 12:39 Go to previous message
Girish Kumar is currently offline Girish KumarFriend
Messages: 48
Registered: May 2011
Member
Hi Stefan Klikovits,

You download the antlr jar by yourself and place it in lib folder in the plugin(create lib folder)
and add the jar by build path---> configure Build Path. update classpath by PDE tools(*context menu).

After doing the above, generate.

Regards
Girish

[Updated on: Mon, 14 July 2014 12:41]

Report message to a moderator

Previous Topic:[Xtext] Need help with implicit imports
Next Topic:Using Existing Ecore in XText
Goto Forum:
  


Current Time: Tue Dec 10 10:10:21 GMT 2019

Powered by FUDForum. Page generated in 0.01314 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top