Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » Bundle resolution problem with two different versions of same bundle
Bundle resolution problem with two different versions of same bundle [message #1394542] Sat, 05 July 2014 13:12 Go to next message
KW is currently offline KWFriend
Messages: 12
Registered: July 2009
Junior Member
Hi all,

I hope that I do post to the correct group with this. If not, please
give me pointer which group is the right one.

I have an RCP app that has a depdendency to batik plugins
(org.eclipse.e4.ui.core):

org.eclipse.e4.ui.core requires Bundle:org.apache.batik.css;
bunble-version="[1.6.0,1.7.0)"

Also, I want to use the vex editor that also has a dependency to the
batik plugins, but to version 1.7.0 instead of to 1.6.0.

org.eclipse.vex.core:
Requires Bundle:org.apache.batik.css; bunble-version="1.7.0"
Requires Bundle:org.apache.batik.util; bunble-version="1.7.0"

When I activate both versions of the batik plugins in the run
configuration (on the tab "Plug-ins" , I get the following bundle
resolution problems at application startup (see below).

Is there a way to provide the rcp app with the 1.6.0 and the 1.7.0
version of the batik plugins?

Thanks
Kris

__________________
!ENTRY org.eclipse.osgi 2 0 2014-07-01 13:01:10.502
!MESSAGE One or more bundles are not resolved because the following root
constraints are not resolved:
!SUBENTRY 1 org.eclipse.osgi 2 0 2014-07-01 13:01:10.502
!MESSAGE Bundle
initial@reference:file:plugins/org.eclipse.e4.ui.css.core_0.10.100.v20130515-1857.jar
was not resolved.
!SUBENTRY 2 org.eclipse.e4.ui.css.core 2 0 2014-07-01 13:01:10.502
!MESSAGE Missing required bundle org.apache.batik.css_[1.6.0,1.7.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2014-07-01 13:01:10.502
!MESSAGE Bundle
initial@reference:file:plugins/org.apache.batik.css_1.7.0.v201011041433.jar
was not resolved.
!SUBENTRY 2 org.apache.batik.css 2 0 2014-07-01 13:01:10.502
!MESSAGE Missing required bundle org.apache.batik.util_[1.7.0,1.8.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2014-07-01 13:01:10.503
!MESSAGE Bundle
initial@reference:file:plugins/org.apache.batik.util_1.6.0.v201011041432.jar
was not resolved.
!SUBENTRY 2 org.apache.batik.util 2 0 2014-07-01 13:01:10.503
!MESSAGE Missing required bundle org.apache.batik.util.gui_[1.6.0,1.7.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2014-07-01 13:01:10.503
!MESSAGE Bundle
initial@reference:file:plugins/org.eclipse.vex.core_1.1.0.M3_KEPLER_201309251650.jar
was not resolved.
!SUBENTRY 2 org.eclipse.vex.core 2 0 2014-07-01 13:01:10.503
!MESSAGE Missing required bundle org.apache.batik.util_1.7.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2014-07-01 13:01:10.503
!MESSAGE Bundle
initial@reference:file:plugins/org.eclipse.ui_3.105.0.v20130522-1122.jar
was not resolved.
!SUBENTRY 2 org.eclipse.ui 2 0 2014-07-01 13:01:10.504
!MESSAGE Missing required capability Require-Capability: osgi.ee;
filter="(|(&(osgi.ee=CDC/Foundation)(version=1.0))(&(osgi.ee=JavaSE)(version=1.3)))".
______________
Re: Bundle resolution problem with two different versions of same bundle [message #1395640 is a reply to message #1394542] Mon, 07 July 2014 07:15 Go to previous messageGo to next message
Jonathan Dumont is currently offline Jonathan DumontFriend
Messages: 58
Registered: March 2011
Location: Laval
Member
Hi,

I have the same problem on my application (see 1385245).
With my Tycho build, it works fine. Unfortunately, I did not managed to solved the problem with the Eclipse Launcher based on features. However, it can be bypassed on your local launch using the Eclipse launcher based on plugins and by adding directly the both versions of the plugin. As the Batik plugins are not singleton, it's possible.

Good luck !


Re: Bundle resolution problem with two different versions of same bundle [message #1395698 is a reply to message #1395640] Mon, 07 July 2014 09:07 Go to previous messageGo to next message
KW is currently offline KWFriend
Messages: 12
Registered: July 2009
Junior Member
Hi Jonathan,

thanks for your answer. Luckily, it works now. Unluckily, I cannot tell
what was the reason. What I did was creating a new launch configuration,
added the plugins, that the validation button was missing and it worked
again...

Regards
Kris

Am 07.07.14 09:15, schrieb Jonathan Dumont:
> Hi,
>
> I have the same problem on my application (see
> https://www.eclipse.org/forums/index.php/m/1385245/#msg_1385245).
> With my Tycho build, it works fine. Unfortunately, I did not managed to
> solved the problem with the Eclipse Launcher based on features. However,
> it can be bypassed on your local launch using the Eclipse launcher based
> on plugins and by adding directly the both versions of the plugin. As
> the Batik plugins are not singleton, it's possible.
>
> Good luck !
Re: Bundle resolution problem with two different versions of same bundle [message #1395714 is a reply to message #1395698] Mon, 07 July 2014 09:35 Go to previous messageGo to next message
Jonathan Dumont is currently offline Jonathan DumontFriend
Messages: 58
Registered: March 2011
Location: Laval
Member
Yes it's what I told in the previous message, with a plugin based configuration, you can add the both plugin versions and it works.
But if you have a feature based launcher (like me ...) I can't figure how to include the both versions.

Regards


Re: Bundle resolution problem with two different versions of same bundle [message #1396568 is a reply to message #1394542] Tue, 08 July 2014 13:49 Go to previous message
Paul Webster is currently offline Paul WebsterFriend
Messages: 6859
Registered: July 2009
Location: Ottawa
Senior Member

On 07/05/2014 09:12 AM, KW wrote:
> Hi all,
>
> I hope that I do post to the correct group with this. If not, please
> give me pointer which group is the right one.
>
> I have an RCP app that has a depdendency to batik plugins
> (org.eclipse.e4.ui.core):
>
> org.eclipse.e4.ui.core requires Bundle:org.apache.batik.css;
> bunble-version="[1.6.0,1.7.0)"

Also, in Luna this was updated to 1.7.0 for org.eclipse.e4.ui.css.core

PW


Previous Topic:Luna reintroduces ClassCastException: ContributionInfo cannot be cast to EditPart
Next Topic:why is so unintuitive the way of create a new project from existing code?
Goto Forum:
  


Current Time: Tue Dec 12 12:24:13 GMT 2017

Powered by FUDForum. Page generated in 0.01558 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software