Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » e(fx)clipse » Using JavaFX in an Eclipse Plugin: Can't import workbench3
Using JavaFX in an Eclipse Plugin: Can't import workbench3 [message #1392879] Thu, 03 July 2014 00:32 Go to next message
Wyatt Spear is currently offline Wyatt SpearFriend
Messages: 10
Registered: July 2009
Junior Member
I need to create an Eclipse plugin and I want to use JavaFX to handle the graphics I will display in a view. This basic tutorial example isn't working for me:

https://wiki.eclipse.org/Efxclipse/Tutorials/Tutorial2

I am using the prebuilt E(fx)clipse distribution, fully updated.

The JavaFX demo plugin I had build errors right out of the box. In the src file itself: FXViewPart cannot be resolved to a type. This is because in the manifest the dependency org.eclipse.fx.ui.workbench3 does not exist. Do I need to do something different to get this to work with the current release?

Thanks,
Wyatt
Re: Using JavaFX in an Eclipse Plugin: Can't import workbench3 [message #1393392 is a reply to message #1392879] Thu, 03 July 2014 18:26 Go to previous messageGo to next message
Wyatt Spear is currently offline Wyatt SpearFriend
Messages: 10
Registered: July 2009
Junior Member
It seems the workbench3 plugin was not present in the plugins folder of the 64 bit windows whole-platform download. It was present in the Linux 64 bit download so I copied it over and it works. Someone might consider respinning the Windows package?
=Wyatt
Re: Using JavaFX in an Eclipse Plugin: Can't import workbench3 [message #1393781 is a reply to message #1393392] Fri, 04 July 2014 08:50 Go to previous message
Thomas Schindl is currently offline Thomas SchindlFriend
Messages: 5619
Registered: July 2009
Senior Member
Did you really follow the tutorial and created a target platform as
outlined there?

To me it looks like you are still developing against your IDE-Plugins
instead of a dedicated target platform.

Tom

On 03.07.14 20:26, Wyatt Spear wrote:
> It seems the workbench3 plugin was not present in the plugins folder of
> the 64 bit windows whole-platform download. It was present in the Linux
> 64 bit download so I copied it over and it works. Someone might consider
> respinning the Windows package?
> =Wyatt
Previous Topic:e(fx)clipse Roadmap
Next Topic:Customization of the MToolItem rendering
Goto Forum:
  


Current Time: Sun Mar 29 04:48:52 GMT 2015

Powered by FUDForum. Page generated in 0.07696 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software