Skip to main content

Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Eclipse EGit pushing latest commit hangs plink.exe(Eclipse and Github no longer owrking using PuTTY.)
Eclipse EGit pushing latest commit hangs plink.exe [message #1390060] Sat, 28 June 2014 21:07
Matteo Dahl is currently offline Matteo DahlFriend
Messages: 1
Registered: June 2014
Junior Member
Yesterday I setup EGit and PuTTY so I can share my latest changes to the code to my RPi which then packs my binary into a executable jar, and with quiet alot of extra work, I got it working to some extent, I could successfully push my local resipotory to github, and my RPi could fetch the latest commit if needed. But I still had some minor problems with my RPi executing my code and compiling etc.

However, today everything suddenly stopped working, I could no more push my local resipotory to github for whatever reason and I have just not been able to figure it out (the funny thing about ALL this is that I thought it would be very beneficial if my RPi could stay up to date with my latest code so I wouldn't have to manually export my code to the RPi by remote desktop and dropbox, but it turned out to be even more complicated than I thought it was).

The most annoying thing is that it was working just fine yesterday, I did change a few things in my project within eclipse but other than that, everything should've been the same. Basically EGit first told me that the server host key was not cached. And I resolved that by calling
from the command line. After that I was left with another problem: PuTTY Fatal Error: Disconnected: No supported authentication methods available, and after Googleing the problem for a good hour or so, I found out that Pageant had apparently no private key in the Pageant key list. So I had to convert the id_dsa private key generated by eclipse to a PuTTY Private Key File, which resolved that issue, after launching EGit again, I first thought it would work, but oh no! I've never been so wrong in all my life. I tried to push my local resipotory to github, but it got stuck at getting remote branches information, so I tried to cancel it. But it didn't work, I couldn't close the wizard due the process had to be cancelled first. So I had to manually TERMINATE the plink.exe process to close the wizard.

I would be so thankful if anyone could help me out here. Thanks in advance!
Previous Topic:Hello World SWT - Could not load SWT library
Next Topic:Maven JAXB Generated Classes not in Eclipse Classpath
Goto Forum:

Current Time: Sun Apr 18 12:51:06 GMT 2021

Powered by FUDForum. Page generated in 0.02466 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top