Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EclipseLink » EclipseLink Performance (vs. OpenJPA)
EclipseLink Performance (vs. OpenJPA) [message #1386308] Mon, 16 June 2014 12:57 Go to next message
An Hoe is currently offline An HoeFriend
Messages: 2
Registered: June 2014
Junior Member
Hi everybody,

has anybody of you changed the JPA provider of an application from EclipseLink to OpenJPA or vice versa and experienced performance issues?

I have a background process which performs a lot of selects and updates and we encountered major performance issues with EclipseLink.
A test with OpenJPA shows that the task runs about 3-5 times faster compared to EclipseLink.

The database is SQL Server 2012.
EclipseLink v2.5.1 vs. OpenJPA v2.3.0

Unfortunately I'm pretty new to JPA and the different implementations of it.

What would be a good approach to nail the difference down and to find the root cause of that behaviour?

Any help is much appreciated.


Thanks and regards,
AH
Re: EclipseLink Performance (vs. OpenJPA) [message #1386380 is a reply to message #1386308] Tue, 17 June 2014 08:49 Go to previous messageGo to next message
An Hoe is currently offline An HoeFriend
Messages: 2
Registered: June 2014
Junior Member
Hi again,

I might have found the biggest difference.

I didn't enable "weaving" up to now.
After enabling it (java -javaagent:eclipselink.jar), the performance looks way better.


https://wiki.eclipse.org/EclipseLink/FAQ/JPA
https://wiki.eclipse.org/EclipseLink/UserGuide/JPA/Advanced_JPA_Development/Performance/Weaving

Here is a good article which helped me in finding this option:
java-persistence-performance.blogspot.de/2011/06/how-to-improve-jpa-performance-by-1825.html


Regards,
AH
Re: EclipseLink Performance (vs. OpenJPA) [message #1389473 is a reply to message #1386380] Fri, 27 June 2014 21:50 Go to previous message
Dave Tiger is currently offline Dave TigerFriend
Messages: 4
Registered: June 2014
Junior Member
HI AH, do you use tomcat? I tried to configure dynamic weaving in tomcat using -javaagent:eclipselink.jar, tomcat failed to start.
Previous Topic:EclipseLink 2.3: Clear cache through application
Next Topic:Get old entity even after caching is disabled.
Goto Forum:
  


Current Time: Wed Jul 01 15:22:45 GMT 2015

Powered by FUDForum. Page generated in 0.01634 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software