Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » RAP elements invisible if border-radius > 0 on Chrome
RAP elements invisible if border-radius > 0 on Chrome [message #1385266] Thu, 05 June 2014 09:40 Go to next message
Michael Fischer is currently offline Michael FischerFriend
Messages: 2
Registered: June 2014
Junior Member
Hello,

I'm using RAP 2.2, Chrome (35.0.1916.114 m), Firefox (29.0.1) and Opera (22.0).

On Chrome since version 35 whenever an element has rounded edges, all child elements are invisible. Opera, Firefox and Chrome 34 work correctly.

I've tested it by creating two buttons, one with rounded edges, one without. I've created a CSS file to set border-radius to 0px and 10px.

Attached are two PNG showing the results on Chrome 35 and Opera. On Chrome, the label on the second button is missing.

Kind regards,
Michael Fischer
Re: RAP elements invisible if border-radius > 0 on Chrome [message #1385314 is a reply to message #1385266] Thu, 05 June 2014 14:58 Go to previous messageGo to next message
Tim Buschtoens is currently offline Tim BuschtoensFriend
Messages: 396
Registered: July 2009
Senior Member
Hi.

It may not be the exact same issue, but probably the same fix:
https://wiki.eclipse.org/RAP/FAQ#Widgets_disappearing_in_Google_Chrome.2C_Safari_or_Opera

Please see if these workarounds work for you, or if the RAP 2.3RC2 fixes
your problem.

Greetings,
Tim

Am 05.06.2014 15:30, schrieb Michael Fischer:
> Hello,
>
> I'm using RAP 2.2, Chrome (35.0.1916.114 m), Firefox (29.0.1) and Opera (22.0).
>
> On Chrome since version 35 whenever an element has rounded edges, all child elements are invisible. Opera, Firefox and Chrome 34 work correctly.
>
> I've tested it by creating two buttons, one with rounded edges, one without. I've created a CSS file to set border-radius to 0px and 10px.
>
> Attached are two PNG showing the results on Chrome 35 and Opera. On Chrome, the label on the second button is missing.
>
> Kind regards,
> Michael Fischer
>

--
Tim Buschtöns

Twitter: @EclipseRAP
Blog: http://eclipsesource.com/blogs/

Professional services for RAP and RCP?
http://eclipsesource.com/services/rap/
Re: RAP elements invisible if border-radius > 0 on Chrome [message #1385398 is a reply to message #1385314] Fri, 06 June 2014 07:40 Go to previous messageGo to next message
Michael Fischer is currently offline Michael FischerFriend
Messages: 2
Registered: June 2014
Junior Member
Hi,

I've tried all suggested fixes and saw that we already had implemented the force hardware acceleration fix. After removing it, everything worked normally.

Enforcing hardware acceleration helped for Chrome 33. But on Chrome 35, I had to remove it.

Thank you,
Michael
Re: RAP elements invisible if border-radius > 0 on Chrome [message #1385402 is a reply to message #1385398] Fri, 06 June 2014 08:34 Go to previous message
Tim Buschtoens is currently offline Tim BuschtoensFriend
Messages: 396
Registered: July 2009
Senior Member
Hi.

Interesting... Possibly this workaround makes things worse in later
Chrome versions. I will add that to the wiki.

Thanks,
Tim

Am 06.06.2014 09:40, schrieb Michael Fischer:
> Hi,
>
> I've tried all suggested fixes and saw that we already had implemented
> the force hardware acceleration fix. After removing it, everything
> worked normally.
>
> Enforcing hardware acceleration helped for Chrome 33. But on Chrome 35,
> I had to remove it.
>
> Thank you,
> Michael

--
Tim Buschtöns

Twitter: @EclipseRAP
Blog: http://eclipsesource.com/blogs/

Professional services for RAP and RCP?
http://eclipsesource.com/services/rap/
Previous Topic:CTabFolder menu problem
Next Topic:[ANN] RAP 2.3RC3 ready to download
Goto Forum:
  


Current Time: Mon Feb 17 00:27:34 GMT 2020

Powered by FUDForum. Page generated in 0.02898 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top