Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Debugging Ruby(Cannot debug Ruby scripts)
Debugging Ruby [message #1384635] Thu, 29 May 2014 19:34 Go to next message
Dennis Duggan is currently offline Dennis DugganFriend
Messages: 2
Registered: May 2014
Junior Member
I am running Kepler 64 bit on Windows 7 and have the following installed:
Dynamic Languages Toolkit - Core Frameworks 2.0.0.v20100518-1923-7L--EAAoOVMSMc4AWEvJ org.eclipse.dltk.core.feature.group Eclipse.org
Dynamic Languages Toolkit - Core Frameworks SDK 2.0.0.v20090730-1127-5--90U45SFRujYToYq6KvGxbBBpP org.eclipse.dltk.core.sdk.feature.group Eclipse.org
Dynamic Languages Toolkit - Ruby Development Tools 2.0.0.v20100505-1154-7G--E_EkMU3NHhvAUo0G org.eclipse.dltk.ruby.feature.group Eclipse.org
Dynamic Languages Toolkit - Ruby Development Tools SDK 2.0.0.v20090730-1127-4--84L23HCMnUW7RPoxKoq2YAFlN org.eclipse.dltk.ruby.sdk.feature.group Eclipse.org

I have installed Ruby run time and I am able to run Ruby scripts but I cannot debug Ruby scripts. No matter how I configure the preference Ruby>debug>engine. I keep getting the runtime error:
/AppData/Local/Temp/dltk3590.tmp/debugger/common/Logger.rb:27:in `logException': uninitialized class variable @@logger in XoredDebugger::Logger (NameError)
from C:/Users/dduggan/AppData/Local/Temp/dltk3590.tmp/debugger/AbstractRunner.rb:60:in `rescue in run'
from C:/Users/dduggan/AppData/Local/Temp/dltk3590.tmp/debugger/AbstractRunner.rb:15:in `run'
from C:/Users/dduggan/AppData/Local/Temp/dltk3590.tmp/debugger/BasicRunner.rb:20:in `<module:XoredDebugger>'
from C:/Users/dduggan/AppData/Local/Temp/dltk3590.tmp/debugger/BasicRunner.rb:12:in `<top (required)>'
from C:/Ruby200-x64/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:55:in `require'
from C:/Ruby200-x64/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:55:in `require'


Is there a Ruby forum that this question should be directed to?

Thanks!
Dennis
Re: Debugging Ruby [message #1384636 is a reply to message #1384635] Thu, 29 May 2014 19:39 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3757
Registered: July 2009
Senior Member

I would think http://www.eclipse.org/forums/eclipse.technology.dltk

Nitin Dahyabhai
Eclipse Web Tools Platform
Re: Debugging Ruby [message #1758358 is a reply to message #1384636] Tue, 28 March 2017 05:15 Go to previous message
Binh Minh Nguyen is currently offline Binh Minh NguyenFriend
Messages: 2
Registered: March 2017
Junior Member
I got the same problem, after update DTLK 5.7 in eclipse, It's still error but don't show detail error anymore, anyone can help pls
Previous Topic:Cannot setup a glassfish server environment in Eclipse Neon.3
Next Topic:Can't install
Goto Forum:
  


Current Time: Sun Jul 12 14:07:44 GMT 2020

Powered by FUDForum. Page generated in 0.03589 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top