Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » Restart application with no cid
Restart application with no cid [message #1373461] Thu, 22 May 2014 07:14 Go to next message
Tiburon T is currently offline Tiburon TFriend
Messages: 61
Registered: October 2011
Member
Hello!

We are facing a strange problem with our logout / restart mechanism. When we reload the page by executing a redirect via JavaScriptExecutor, the reloaded page sometimes does not start correctly and the browser only displays a few line of javascript. In Firebug I can see, that the redirected request still contains the old CID parameter. Can this lead to such problems? Does anybody know of a way to reload the page as if the user just requested it for the first time? Are there any other known problems or bugs when restarting a RAP Application? Unfortunately there are no errors in the client log or any other hints on what might be going wrong.

Edit:

This is what is printed in the browser when the page fails:
{"head":{},"operations":[]}


Any help would be great,

Thanks
Tibu

[Updated on: Thu, 22 May 2014 08:09]

Report message to a moderator

Re: Restart application with no cid [message #1373652 is a reply to message #1373461] Thu, 22 May 2014 09:04 Go to previous messageGo to next message
Ivan Furnadjiev is currently offline Ivan FurnadjievFriend
Messages: 2334
Registered: July 2009
Location: Sofia, Bulgaria
Senior Member
Hi,
no... I'm not aware about such problem. Could you open a bugzilla and
attach a simple project to reproduce the issue?
Best,
Ivan

--
Ivan Furnadjiev

Twitter: @EclipseRAP
Blog: http://eclipsesource.com/blogs/

Professional services for RAP and RCP?
http://eclipsesource.com/services/rap/
Re: Restart application with no cid [message #1376457 is a reply to message #1373461] Fri, 23 May 2014 12:24 Go to previous messageGo to next message
Johannes Eickhold is currently offline Johannes EickholdFriend
Messages: 2
Registered: May 2014
Junior Member
Tiburon T wrote on Thu, 22 May 2014 03:14

We are facing a strange problem with our logout / restart mechanism. When we reload the page by executing a redirect via JavaScriptExecutor, the reloaded page sometimes does not start correctly and the browser only displays a few line of javascript. In Firebug I can see, that the redirected request still contains the old CID parameter. Can this lead to such problems? Does anybody know of a way to reload the page as if the user just requested it for the first time? Are there any other known problems or bugs when restarting a RAP Application? Unfortunately there are no errors in the client log or any other hints on what might be going wrong.

This is what is printed in the browser when the page fails:
{"head":{},"operations":[]}



Hello Tiburon,

we had the same problem problem with a RAP application a few weeks ago. We could solve it but I think our fix does not work in the general case. You should try to understand the following things:
When is your HTTP session destroyed?
When is your new (login again) HTTP session created?
Where are you redirecting to? (Into the same RAP app or to some external servlet / static HTML page?)
Please be aware of the RAP client trying to send a shutdown event to the server when the RAP client's JavaScript is unloaded! This can interfere with external (to RAP) servlets involved in the logout procedure.

It would help if you can explain your logout process in more detail.

Regards, Johannes.

PS: To prevent the RAP client sending the shutdown event, you can try this line before redirecting:

executor.execute("rwt.widgets.Display.getCurrent()._sendShutdown = function() {};")
Re: Restart application with no cid [message #1376590 is a reply to message #1376457] Fri, 23 May 2014 13:37 Go to previous message
Tiburon T is currently offline Tiburon TFriend
Messages: 61
Registered: October 2011
Member
Hello,

thank you very much for your support. We finally figured out, that our logout was executed twice. First manually and then again in preShutdown().

Greetings,
Tibu

[Updated on: Fri, 23 May 2014 17:22]

Report message to a moderator

Previous Topic:Localization RAP 2.3 is not working for the application model
Next Topic:Nice way to get a lazy loaded, session scoped model (MVC)
Goto Forum:
  


Current Time: Sun Feb 23 02:36:14 GMT 2020

Powered by FUDForum. Page generated in 0.01766 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top