Skip to main content

Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » ServerTools (WTP) » Web Services Explorer and SSL
Web Services Explorer and SSL [message #219162] Mon, 11 August 2008 17:17
Eclipse UserFriend
Originally posted by:

I'm creating and testing a web service on IBM's RAD / WAS with the Eclipse WTP Web Services Explorer. I've gotten the web
service to work fine on one of my servers, using SOAP over HTTPS.

However, because of some problems with RAD (it won't let me save any of
my test launchers from the Run menu), I ended up creating a new RAD
workspace, and importing the web service. I created a new profile with a
new server, and installed the web service on it. When I run the Web
Services Explorer , when it tries to connect to my web service, I get
the error message:
IWAB0135E An unexpected error has occurred.
IOException No trusted certificate found

To get the web service working on the other server/profile, I didn't
have to do anything special that I am aware of. I thought maybe the
workspace might be an issue, so I went back to the old workspace, and
created a new profile and server, but the same error is happening. I can
only get the web service to work on the original server, and no other.

I'm not quite sure where the error message is coming from. There are no
error messages in the WAS logs. Is it coming from Eclipse, or the Web
Services Explorer? If so, where would I update the certificates for those?

Someone told me I may have to update the cacerts file for the Eclipse
JRE. So I did that, with the key from my WAS server, but that didn't work.

When using the Web Services Explorer, Eclipse seems to start an
in-process instance of Tomcat to run wsexplorer.jar. But it looks like
it's just using the Eclipse JRE, which I just updated in the steps
above, to no avail. Is there someplace that the embedded Tomcast stores
its certs/keys that needs to be updated?

I've looked all through my Eclipse workspace for logs, but can't find
any messages, other than the message I get on the Web Services Explorer

I've compared the keystores and truststores from the working and
non-working WAS server instances, and they appear to be the same (other
than the key itself, naturally).

Any suggestions? I'm out of ideas.
Previous Topic:Ganymede JEE doesn't seem to recognise JSP 2.1 Tag attributes
Next Topic:Creating a Dynamic Web project
Goto Forum:

Current Time: Sat Oct 24 16:05:19 GMT 2020

Powered by FUDForum. Page generated in 0.01803 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top