Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » TMF (Xtext) » Dependency issue(org.eclipse.xtext.logging missing?)
Dependency issue [message #1279317] Fri, 28 March 2014 15:14 Go to next message
Josh Gentry is currently offline Josh GentryFriend
Messages: 4
Registered: May 2013
Junior Member
I'm trying to provide my language built on xtext to the company to look at. I create an update site, install a clean eclipse (standard), point it at my update site, and install.

Everything installs fine, I create a new file, but when I try to edit it, after typing the first keyword I get:
An internal error occurred during: "XtextReconcilerJob".

java.lang.NullPointerException
	at org.eclipse.xtext.util.EmfStructureComparator.internalIsSameStructure(EmfStructureComparator.java:50)
	at org.eclipse.xtext.util.EmfStructureComparator.isSameStructure(EmfStructureComparator.java:45)
	at org.eclipse.xtext.ui.editor.reconciler.XtextReconcilerDebugger.assertResouceParsedCorrectly(XtextReconcilerDebugger.java:84)
	at org.eclipse.xtext.ui.editor.reconciler.XtextReconciler.doRun(XtextReconciler.java:367)
	at org.eclipse.xtext.ui.editor.reconciler.XtextReconciler.access$2(XtextReconciler.java:350)
	at org.eclipse.xtext.ui.editor.reconciler.XtextReconciler$1.process(XtextReconciler.java:294)
	at org.eclipse.xtext.ui.editor.reconciler.XtextReconciler$1.process(XtextReconciler.java:1)
	at org.eclipse.xtext.util.concurrent.IUnitOfWork$Void.exec(IUnitOfWork.java:36)
	at org.eclipse.xtext.util.concurrent.AbstractReadWriteAcces.modify(AbstractReadWriteAcces.java:81)
	at org.eclipse.xtext.ui.editor.model.XtextDocument$XtextDocumentLocker.modify(XtextDocument.java:219)
	at org.eclipse.xtext.ui.editor.model.XtextDocument.internalModify(XtextDocument.java:103)
	at org.eclipse.xtext.ui.editor.reconciler.XtextReconciler.run(XtextReconciler.java:291)
	at org.eclipse.core.internal.jobs.Worker.run(Worker.java:53)


Googling around I found an exchange between a customer and company that was experiencing a similar issue and it turned out to be that org.eclipse.xtext.logging wasn't in the plugins directory, checking my plugins directory I don't have the JAR either, when I manually copy it in, no more crashes. If I install the xtext SDK and my plugin, no more crashes (which I guess is the work around).

How do I get my plugin to depend on org.eclipse.xtext.logging JAR so it's installed automatically? Or is there some deeper error I should be looking into my language for?

I'm using the latest "released" xtext so 2.4.3.v201309030823.

Re: Dependency issue [message #1279483 is a reply to message #1279317] Fri, 28 March 2014 20:40 Go to previous messageGo to next message
Sven Efftinge is currently offline Sven EfftingeFriend
Messages: 1823
Registered: July 2009
Senior Member
See this bugzilla : https://bugs.eclipse.org/bugs/show_bug.cgi?id=421741

The NPE has been solved four month ago and is avialable since version 2.5.0.
It happend only when you have enabled the DEBUG severity through some
log4j properties file. the plug-in org.eclipse.xtext.logging will set
the severity to WARN. not sure where that DEBUG severity comes from in
your environment.

hth,
Sven

Am 28/03/14 16:14, schrieb Josh Gentry:
> I'm trying to provide my language built on xtext to the company to look
> at. I create an update site, install a clean eclipse (standard), point
> it at my update site, and install.
>
> Everything installs fine, I create a new file, but when I try to edit
> it, after typing the first keyword I get:
>
> An internal error occurred during: "XtextReconcilerJob".
>
> java.lang.NullPointerException
> at
> org.eclipse.xtext.util.EmfStructureComparator.internalIsSameStructure(EmfStructureComparator.java:50)
>
> at
> org.eclipse.xtext.util.EmfStructureComparator.isSameStructure(EmfStructureComparator.java:45)
>
> at
> org.eclipse.xtext.ui.editor.reconciler.XtextReconcilerDebugger.assertResouceParsedCorrectly(XtextReconcilerDebugger.java:84)
>
> at
> org.eclipse.xtext.ui.editor.reconciler.XtextReconciler.doRun(XtextReconciler.java:367)
>
> at
> org.eclipse.xtext.ui.editor.reconciler.XtextReconciler.access$2(XtextReconciler.java:350)
>
> at
> org.eclipse.xtext.ui.editor.reconciler.XtextReconciler$1.process(XtextReconciler.java:294)
>
> at
> org.eclipse.xtext.ui.editor.reconciler.XtextReconciler$1.process(XtextReconciler.java:1)
>
> at
> org.eclipse.xtext.util.concurrent.IUnitOfWork$Void.exec(IUnitOfWork.java:36)
>
> at
> org.eclipse.xtext.util.concurrent.AbstractReadWriteAcces.modify(AbstractReadWriteAcces.java:81)
>
> at
> org.eclipse.xtext.ui.editor.model.XtextDocument$XtextDocumentLocker.modify(XtextDocument.java:219)
>
> at
> org.eclipse.xtext.ui.editor.model.XtextDocument.internalModify(XtextDocument.java:103)
>
> at
> org.eclipse.xtext.ui.editor.reconciler.XtextReconciler.run(XtextReconciler.java:291)
>
> at org.eclipse.core.internal.jobs.Worker.run(Worker.java:53)
>
>
> Googling around I found an exchange between a customer and company that
> was experiencing a similar issue and it turned out to be that
> org.eclipse.xtext.logging wasn't in the plugins directory, checking my
> plugins directory I don't have the JAR either, when I manually copy it
> in, no more crashes. If I install the xtext SDK and my plugin, no more
> crashes (which I guess is the work around).
>
> How do I get my plugin to depend on org.eclipse.xtext.logging JAR so
> it's installed automatically? Or is there some deeper error I should be
> looking into my language for?
>
> I'm using the latest "released" xtext so 2.4.3.v201309030823.
>
>


--
Need professional support for Xtext or other Eclipse Modeling technologies?
Go to: http://xtext.itemis.com
Twitter : @svenefftinge
Blog : http://blog.efftinge.de
Re: Dependency issue [message #1279500 is a reply to message #1279483] Fri, 28 March 2014 21:06 Go to previous message
Josh Gentry is currently offline Josh GentryFriend
Messages: 4
Registered: May 2013
Junior Member
Interesting, thank you. I'm running eclipse on linux x64, guess I should try it under windows to see if that makes a difference. It shouldn't, but you never know. I'll see if I can figure out the debugging flag, it's more information than I started with. Smile
Previous Topic:Xtext Functionality doesnot work when eclipse.ui plugins are supressed
Next Topic:Dual License with EPL and Apache 2.0
Goto Forum:
  


Current Time: Sun Jan 19 19:03:32 GMT 2020

Powered by FUDForum. Page generated in 0.02234 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top