Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » scout » FileChooser in RAP
FileChooser in RAP [message #1264901] Wed, 05 March 2014 15:43 Go to next message
davide . is currently offline davide .Friend
Messages: 12
Registered: March 2014
Junior Member
Hi all. Ive some problem using the file chooser for the rap client of the application.
I'm using eclipse kepler SR1 Build id: 20130919-0819 with Scout SDK (preinstalled).
In my toy project I've included the "RAP FileChooser support (incubator) in the technologies section of the "Scout Object Properties" editor.
index.php/fa/17641/0/
The file chooser works fine in the SWT client; unfortunately, when I run the RAP client, here's what is shown:
index.php/fa/17642/0/

In server's console: the following messages appear:

2014-03-05 16:21:55.370:INFO:oejs.Server:jetty-8.1.10.v20130312
2014-03-05 16:21:55.395:INFO:oejs.AbstractConnector:Started SelectChannelConnector@0.0.0.0:8082
!SESSION 2014-03-05 16:21:53.658 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.7.0_17
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=it_IT
Framework arguments:  -product HelloWorld.ui.rap.product
Command-line arguments:  -product HelloWorld.ui.rap.product -data C:\Users\davide\workspace-scout-org.eclipse.helloworld/../runtime-helloworld-rap-dev.product -dev file:C:/Users/davide/workspace-scout-org.eclipse.helloworld/.metadata/.plugins/org.eclipse.pde.core/helloworld-rap-dev.product/dev.properties -os win32 -ws win32 -arch x86 -consoleLog

!ENTRY org.eclipse.osgi 2 0 2014-03-05 16:21:58.128
!MESSAGE One or more bundles are not resolved because the following root constraints are not resolved:
!SUBENTRY 1 org.eclipse.osgi 2 0 2014-03-05 16:21:58.128
!MESSAGE Bundle update@../../Users/davide/workspace-scout-org.eclipse.helloworld/.metadata/.plugins/org.eclipse.pde.core/.bundle_pool/plugins/org.eclipse.scout.rt.ui.rap.incubator.filechooser_3.9.2.20131003-1321.jar was not resolved.
!SUBENTRY 2 org.eclipse.scout.rt.ui.rap.incubator.filechooser 2 0 2014-03-05 16:21:58.128
!MESSAGE Missing required bundle org.eclipse.scout.rt.ui.rap_[3.9.2,4.0.0).

!ENTRY org.eclipse.osgi 2 0 2014-03-05 16:21:58.162
!MESSAGE The following is a complete list of bundles which are not resolved, see the prior log entry for the root cause if it exists:
!SUBENTRY 1 org.eclipse.osgi 2 0 2014-03-05 16:21:58.162
!MESSAGE Bundle org.eclipse.scout.rt.ui.rap.incubator.filechooser_3.9.2.20131003-1321 [102] was not resolved.
!SUBENTRY 2 org.eclipse.scout.rt.ui.rap.incubator.filechooser 2 0 2014-03-05 16:21:58.162
!MESSAGE Missing required bundle org.eclipse.scout.rt.ui.rap_[3.9.2,4.0.0).


telling me that some bundle is missing. I've already gone to the rap products' page to press the button "Add required plugins", but with no result.
Can someone please help me?
thanks!
  • Attachment: I1.png
    (Size: 11.66KB, Downloaded 277 times)
  • Attachment: I2.png
    (Size: 2.92KB, Downloaded 253 times)
Re: FileChooser in RAP [message #1265907 is a reply to message #1264901] Thu, 06 March 2014 18:26 Go to previous messageGo to next message
Jeremie Bresson is currently offline Jeremie BressonFriend
Messages: 1252
Registered: October 2011
Senior Member
It seems that the "RAP FileChooser support (incubator)" version that was installed when you clicked on the checkbox requires Kepler SR2 Version (Scout 3.9.2). I assume you have another version (maybe SR1).
SR2 was published last week. Download link: Scout Kepler SR2.

Otherwise you need to have the appropriate version of "Eclipse Scout RAP Filechooser (Incubation)" in your target Platform. For Kepler SR1 it is: 3.9.1.20130918-0824.

You will find this version on the Update site:
http://download.eclipse.org/scout/releases/3.9/3.9.1
Re: FileChooser in RAP [message #1270636 is a reply to message #1265907] Thu, 13 March 2014 08:57 Go to previous message
davide . is currently offline davide .Friend
Messages: 12
Registered: March 2014
Junior Member
Hi, thanks for your answer!
Following your hints now it works. That is: I downloaded SR2 that includes all scaout features version 3.9.2.20140218 and started a brand-new single form scout project.

The only thing people have to keep in mind in order to make the FileChooser working in RAP is that you have to enable options: "Mandatory" and "Type Load" (see included picture). Otherwise it won't work. Selecting these options is not needed if you aim at Swing or SWT targets only.
Is this correct? I miss this from the docs.
So anyway thanks and keep going!
index.php/fa/17725/0/
  • Attachment: Immagine.png
    (Size: 17.97KB, Downloaded 239 times)
Previous Topic:Get old value of radio button group after/while changing
Next Topic:Proposal: additional field layout in group boxes
Goto Forum:
  


Current Time: Mon Nov 18 04:16:56 GMT 2019

Powered by FUDForum. Page generated in 0.02716 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top