Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » TMF (Xtext) » Version of dependencies when using xtext
Version of dependencies when using xtext [message #1242931] Mon, 10 February 2014 09:22 Go to next message
Victor Noël is currently offline Victor NoëlFriend
Messages: 112
Registered: June 2010
Senior Member
Hi,

Here is a question I had trouble for sometimes: what should I use as version qualifier for the xtext dependencies when distributing a plugin?

The question arises as 2.5.1 is released: if I update my plugin to 2.5.1, should I restrict it to 2.5.1 and up? Or can I keep it depending on 2.5 in general?

What about upper bound? Is it safe to just exclude 2.6? Does it mean that whatever is release between 2.5 and 2.6 will be compatible even if I don't upgrade my plugin?

Thank you Smile
Re: Version of dependencies when using xtext [message #1242934 is a reply to message #1242931] Mon, 10 February 2014 09:29 Go to previous messageGo to next message
Dennis Huebner is currently offline Dennis HuebnerFriend
Messages: 257
Registered: July 2009
Senior Member

Hello Victor,
2.5.x releases are normally backward compatible. So setting to [2.5,2.6) should be safe enough.

Regards,
Dennis.



+Dennis Huebner

Get professional support from the Xtext committers at www.typefox.io
Re: Version of dependencies when using xtext [message #1242938 is a reply to message #1242934] Mon, 10 February 2014 09:32 Go to previous message
Victor Noël is currently offline Victor NoëlFriend
Messages: 112
Registered: June 2010
Senior Member
Ok, thank you Smile
Previous Topic: EMF Editor Runtime Exception
Next Topic:Restrict default cross reference scope.
Goto Forum:
  


Current Time: Tue Oct 27 22:02:03 GMT 2020

Powered by FUDForum. Page generated in 0.02154 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top