Skip to main content

Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » ServerTools (WTP) » Problems using Web Service creation wizards
Problems using Web Service creation wizards [message #202355] Tue, 16 October 2007 16:02
Eclipse UserFriend
Originally posted by:

I have the following problem trying to use the Web Service creation tools.

I'm using Eclipse 3.3.1 with WTP 2.0.1.

This is what I did:

1) I created a new dynamic web project with the following facets:
Dynamic Web Module 2.4
Java 5.0
Axis2 Web Sevices Core 1.1

Problem #1: I didn't check Axis2 Web Services Extensions, but if I look
in Project properties, under "Project facets", I also find Axis2 Web
Services Extensions... why?

Problem #2: I'm actually using Axis2 1.2: I read that it is supported by
WTP, but I can't change the version of the facet from 1.1 to 1.2

2) I have a Tomcat 5.5 Server configured and correctly working; I
removed from it any other Dynamic Web Project and added just the new one

3) I created the following class:

package test;

public class WebServiceTest
public String sayHelloWorld()
return "Hello world!";

4) I did right click => Web Services => Create web service on it

5) I leaved the default options and clicked Next

6) I selected to generate a new services.xml

After several minutes, the dialog asked me to start the server: I
clicked on the "Start server" and Eclipse seemed to start the server...
The "Server Start Job" appeared in the progress bar on the bottom right
corner, but it stayed there for other SEVERAL minutes... At last, I got
nervous and hit "Back", cancelled the web service creation wizard and
tried to stop the "Server Start Job" without success. I had to close
Eclispe and start it again...

Then, I looked at what the web service creation wizard did...
It created the stucture:


The last folder is ok: it contains WebServiceTest.class, that is my
"Hello World" web service class correctly compiled.

The problem is that "TestService" containes the WHOLE WEB-INF/classes of
ANOTHER webapp, that isn't related to my WebServiceTest project in any
way and that I removed from my Tomcat 5.5 server!!!!
I now realized that even if I removed that webapp from the server, its
corresponding module was still listed in "Module" tab of the server
configuration page... Anyone, no webservice was in that project, and I
was not working with that project!!

The services.xml file in TestService/META-INF contains a reference to
class a.TestService, which was a trial that I had done before, using
another test project that I had also removed, so it isn't in my
workspace anymore!!!
In that previous trial, I had some other similar errors: I had more
different dynamic web projects associated with the server. I tried to
develop a web service within one of them and the creation wizard
published the result bundling compiled code from ANOTHER project, even
if I correctly set up the "Configuration" (server, web service runtime
AND service project) section of the Web Services wizard dialog.

Do you have any idea on what is happening?

Previous Topic:Europa TPTP startup error
Next Topic:Call for EclipseCon 2008 submissions ... for Web Tools!
Goto Forum:

Current Time: Sat Jul 02 03:14:53 GMT 2022

Powered by FUDForum. Page generated in 0.01742 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top