Skip to main content

Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EPF » [SOLVED] RichText on Windows7 64bits issue(No richtext available so that it is not possible to enter any text)
[SOLVED] RichText on Windows7 64bits issue [message #1232298] Thu, 16 January 2014 16:24 Go to next message
Nils L. is currently offline Nils L.Friend
Messages: 3
Registered: January 2014
Junior Member

I'm a new user of EPF and I've starting using it to build our internal processes.
My main drawback until now is that I still not managed to install the richtext pluggin.

What is the issue?
When on a page where I have the "main description" inputbox, it is not possible to enter any text.

What I've done?
I've downloaded the package "epf-richtext-" and copied the existing files and folders into my EPF folder.

What is my environment?
Windows 7 64bits

Error seen in EPF log:
!ENTRY org.eclipse.epf.richtext 4 0 2014-01-16 17:07:51.836
at org.eclipse.epf.richtext.actions.PasteAction.copyLinkResources(
at org.eclipse.epf.richtext.actions.PasteAction.execute(
at org.eclipse.epf.richtext.RichText$5.widgetSelected(
at org.eclipse.swt.widgets.TypedListener.handleEvent(
at org.eclipse.swt.widgets.EventTable.sendEvent(
at org.eclipse.swt.widgets.Widget.sendEvent(
at org.eclipse.swt.widgets.Display.runDeferredEvents(
at org.eclipse.swt.widgets.Display.readAndDispatch(
at org.eclipse.ui.internal.Workbench.runEventLoop(
at org.eclipse.ui.internal.Workbench.runUI(
at org.eclipse.ui.internal.Workbench.access$4(
at org.eclipse.ui.internal.Workbench$
at org.eclipse.core.databinding.observable.Realm.runWithDefault(
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(
at org.eclipse.epf.rcp.ui.MainApplication.createWorkbenchAdvisor(
at org.eclipse.epf.rcp.ui.MainApplication.start(
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(
at org.eclipse.equinox.launcher.Main.basicRun(

So after hours of tries and searches on Internet, I don't really know what to do.
This tool is the one I would like to use, so that I feel quite sad to be blocked only on this point.

Many thanks to any one that could help me Wink



[Updated on: Fri, 17 January 2014 14:26]

Report message to a moderator

Re: RichText on Windows7 64bits issue [message #1232561 is a reply to message #1232298] Fri, 17 January 2014 07:56 Go to previous messageGo to next message
Nils L. is currently offline Nils L.Friend
Messages: 3
Registered: January 2014
Junior Member

One complement I've discovered in the log file at the very begining of the session start part, I can see this:
!SESSION 2014-01-17 08:47:07.740 -----------------------------------------------
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=fr_FR
Command-line arguments:  -os win32 -ws win32 -arch x86 -data @user.home/EPF/workspace.151

!ENTRY org.eclipse.epf.rcp.ui 1 0 2014-01-17 08:47:23.819
!MESSAGE INFO: Application start directory =C:\nils.laumaille\utils\EPF-composer-

!ENTRY org.eclipse.ui.workbench 2 0 2014-01-17 08:47:28.036
!MESSAGE A handler conflict occurred.  This may disable some commands.
!SUBENTRY 1 org.eclipse.ui.workbench 2 0 2014-01-17 08:47:28.036
!MESSAGE Conflict for 'AUTOGEN:::org.eclipse.ui.cheatsheets.actionSet/org.eclipse.ui.cheatsheets.actions.CheatSheetHelpMenuAction':

Perhaps this exception is the root cause.

Any ideas?

Re: RichText on Windows7 64bits issue [message #1232699 is a reply to message #1232561] Fri, 17 January 2014 14:25 Go to previous message
Nils L. is currently offline Nils L.Friend
Messages: 3
Registered: January 2014
Junior Member
I finally solved my issue.

The cause was IE9 ... indeed I don't know how I found that but it seems that the RichText uses IE but on my computer the 32bits version of IE9 was not working.
So I reinstalled it and registered the ddl back ... and small miracle in my day, EPF richtext now works.

I hope this feedback could help some users in the same situation.

Previous Topic:Plugins for EPF Composer
Next Topic:How do I install EPF in mac os X
Goto Forum:

Current Time: Tue Jun 28 19:48:47 GMT 2022

Powered by FUDForum. Page generated in 0.02069 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top