Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF » [editor] UI remove class prefix when similar to package name(reuse of package name in class prefix lead to an automatic removal)
[editor] UI remove class prefix when similar to package name [message #1219683] Thu, 05 December 2013 12:08 Go to next message
rodney medina is currently offline rodney medinaFriend
Messages: 2
Registered: December 2013
Junior Member
Hi, (excuse me for my english)

I found a problem when reusing the model's name in a class's name.

Here an example :

model : Library.ecore
a class in the model : LibraryClass1

After generating the editor, the UI indicate only Class1.

I have noted that the file plugin.properties contain this error.
ex: _UI_LibraryClass1_type = Class1

Is this a bug, a naming convention or do i have to handle manually this problem ?

Merci d'avance.

[Updated on: Thu, 05 December 2013 13:45]

Report message to a moderator

Re: [editor] UI remove class prefix when similar to package name [message #1219712 is a reply to message #1219683] Thu, 05 December 2013 14:22 Go to previous messageGo to next message
Christian W. Damus is currently offline Christian W. DamusFriend
Messages: 1195
Registered: July 2009
Location: Canada
Senior Member

Hi,

You can change the type-name label that is generated for your EClass in
the plugin.properties file of your model's edit plug-in. EMF will not
overwrite your change if and when you later re-generate the model.

Look for the _UI_LibraryClass1_type key in the plugin.properties.

HTH,

Christian


On 2013-12-05 13:34:03 +0000, rodney medina said:

> Hi, (excuse me for my english)
>
> I found a problem when reusing the model's name in a class's name.
>
> Here an example :
>
> model : Library.ecore
> a class in the model : LibraryClass1
>
> After generating the editor, the UI indicate only Class1.
>
> I found that this issue came from the label modification :
>
> class LibraryWizard -> initialObjectField.add(getLabel(objectName));
>
> class DelegatingResourceLocator -> method getString(String key)
>
> Is this a bug, a naming convention or do i have to handle manually this
> problem ?
>
> Merci d'avance.
Re: [editor] UI remove class prefix when similar to package name [message #1219761 is a reply to message #1219712] Thu, 05 December 2013 17:03 Go to previous message
rodney medina is currently offline rodney medinaFriend
Messages: 2
Registered: December 2013
Junior Member
It's a workaround but it works perfectly.

Thank you very much you Christian !

[Updated on: Thu, 05 December 2013 17:04]

Report message to a moderator

Previous Topic:[CDO] CDO client app with maven
Next Topic:[Texo/EMF] What is the proper way to "customize/extend" your model
Goto Forum:
  


Current Time: Thu Aug 22 18:27:30 GMT 2019

Powered by FUDForum. Page generated in 0.01443 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top