Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » SysML Drag&Drop is not possible for associations
SysML Drag&Drop is not possible for associations [message #1219309] Tue, 03 December 2013 09:33 Go to next message
Furkan Eke is currently offline Furkan EkeFriend
Messages: 31
Registered: June 2012
Member
Hello,

the drag and drop from model explorer into the Block Description Diagram does not function.

I have noticed this, as i was refactoring the model with another package layout and was moving the model elements from package to package inside the model explorer.

After that refactoring, the associations were removed from the diagram (which was placed in the top most level). I added new diagrams in the new packages to reorganise the subsets of the original diagram contents in particular packages. There the drag&drop was functioning correctly for blocks, but for the associations the drap&drop from model explorer into the diagram did not function.

I needed to re-add those associations.

Kind regards,
Furkan

[Updated on: Tue, 03 December 2013 10:03]

Report message to a moderator

Re: BUG: SysML Drag&Drop is not possible for associations [message #1219316 is a reply to message #1219309] Tue, 03 December 2013 10:02 Go to previous messageGo to next message
Furkan Eke is currently offline Furkan EkeFriend
Messages: 31
Registered: June 2012
Member
A further note. Drap and drop for associations did probably not function because the diagram was a child of the block from which the associations are going out.

If the block description diagram (as a model element) is placed as a sibling of the incorporated blocks, then the drag&drop has no problem.
Re: BUG: SysML Drag&Drop is not possible for associations [message #1219728 is a reply to message #1219316] Thu, 05 December 2013 15:15 Go to previous message
Furkan Eke is currently offline Furkan EkeFriend
Messages: 31
Registered: June 2012
Member
The problem exists, if you have carried out the following steps

1) prepare a block description diagram
2) add some blocks through the diagram editor,
3) add some packages in the model explorer where these blocks are
4) move the blocks into the package using the model explorer
5) drag and drop the package from model explorer into the diagram

Now, you have:

a) @ Model Explorer :
a package + some blocks inside the package

b) @ Block description diagram :
a package + some blocks outside the package


Now try this:
In the diagram try to move the blocks into the package. It does not work.

Previous Topic:Model Validation with Papyrus
Next Topic:Diagram in standalone application
Goto Forum:
  


Current Time: Thu Nov 26 10:43:38 GMT 2020

Powered by FUDForum. Page generated in 0.01422 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top