Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF » [CDO] Could not activate TCPClientConnector on CDO Hibernate Client/server example
[CDO] Could not activate TCPClientConnector on CDO Hibernate Client/server example [message #1216712] Thu, 28 November 2013 15:49 Go to next message
Thomas Gerlitz is currently offline Thomas GerlitzFriend
Messages: 9
Registered: November 2013
Junior Member
Hello,

I recently discovered the CDO project and did like the idea of a emf model repository. I first downloaded the Hibernate Store examples from the git repository (http://git.eclipse.org/gitroot/cdo/cdo.git/). The server in the project org.eclipse.emf.cdo.examples.hibernate.server started without any problems. I only changed the underlying database from hsqldb to an existing mysql database running on my computer in the cdo-server.xml. Tables are created in this database by the server when it is started.

Unfortunately I ran into some trouble when I tried to execute the test cases included in org.eclipse.emf.cdo.examples.hibernate.client. When executing the QuickStartTest or any other test in this project the following exception occures:

org.eclipse.net4j.util.lifecycle.LifecycleException: Could not activate TCPClientConnector[localhost:2.036]
	at org.eclipse.net4j.util.container.ManagedContainer.activateElement(ManagedContainer.java:355)
	at org.eclipse.net4j.util.container.ManagedContainer.getElement(ManagedContainer.java:325)
	at org.eclipse.net4j.util.container.ManagedContainer.getElement(ManagedContainer.java:301)
	at org.eclipse.net4j.tcp.TCPUtil.getConnector(TCPUtil.java:65)
	at org.eclipse.emf.cdo.examples.hibernate.client.BaseTest.initialize(BaseTest.java:78)
	at org.eclipse.emf.cdo.examples.hibernate.client.BaseTest.openSession(BaseTest.java:51)
	at org.eclipse.emf.cdo.examples.hibernate.client.QuickStartTest.testCreatePersist(QuickStartTest.java:39)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
	at java.lang.reflect.Method.invoke(Unknown Source)
	at junit.framework.TestCase.runTest(TestCase.java:176)
	at junit.framework.TestCase.runBare(TestCase.java:141)
	at junit.framework.TestResult$1.protect(TestResult.java:122)
	at junit.framework.TestResult.runProtected(TestResult.java:142)
	at junit.framework.TestResult.run(TestResult.java:125)
	at junit.framework.TestCase.run(TestCase.java:129)
	at junit.framework.TestSuite.runTest(TestSuite.java:255)
	at junit.framework.TestSuite.run(TestSuite.java:250)
	at org.junit.internal.runners.JUnit38ClassRunner.run(JUnit38ClassRunner.java:84)
	at org.eclipse.jdt.internal.junit4.runner.JUnit4TestReference.run(JUnit4TestReference.java:50)
	at org.eclipse.jdt.internal.junit.runner.TestExecution.run(TestExecution.java:38)
	at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTests(RemoteTestRunner.java:467)
	at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTests(RemoteTestRunner.java:683)
	at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.run(RemoteTestRunner.java:390)
	at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.main(RemoteTestRunner.java:197)


No error message is printed by the server when connecting is attempted.

Can someone point out a mistake that I might have made? I am using Eclipse 4.3 and installed the most recent version of the CDO plugin and all required plugins as described at http://wiki.eclipse.org/CDO/Hibernate_Store/Download_and_Install.

Thanks in advance,
Thomas

[Updated on: Thu, 28 November 2013 18:24]

Report message to a moderator

Re: [CDO] Could not activate TCPClientConnector on CDO Hibernate Client/server example [message #1218529 is a reply to message #1216712] Fri, 29 November 2013 10:06 Go to previous messageGo to next message
Christophe Bouhier is currently offline Christophe BouhierFriend
Messages: 937
Registered: July 2009
Senior Member
On 28-11-13 17:47, Thomas Gerlitz wrote:
> Hello,
>
> I recently discovered the CDO project and did like the idea of a emf
> model repository. I first downloaded the Hibernate Store examples from
> the git repository (http://git.eclipse.org/gitroot/cdo/cdo.git/). The
> server in the project org.eclipse.emf.cdo.examples.hibernate.server
> started without any problems. I only changed the underlying database
> from hsqldb to an existing mysql database running on my computer in the
> cdo-server.xml. Tables are created in this database by the server when
> it is started.

> Unfortunately I ran into some trouble when I tried to execute the test
> cases included in org.eclipse.emf.cdo.examples.hibernate.client. When
> executing the QuickStartTest or any other test in this project the
> following exception occures:
>
>
> org.eclipse.net4j.util.lifecycle.LifecycleException: Could not activate
> TCPClientConnector[localhost:2.036]
> at
Hi Thomas,

Can you post a bit more info, like the log of the server start and your
cdo-server.xml file?

Thanks Christophe


> org.eclipse.net4j.util.container.ManagedContainer.activateElement(ManagedContainer.java:355)
>
> at
> org.eclipse.net4j.util.container.ManagedContainer.getElement(ManagedContainer.java:325)
>
> at
> org.eclipse.net4j.util.container.ManagedContainer.getElement(ManagedContainer.java:301)
>
> at org.eclipse.net4j.tcp.TCPUtil.getConnector(TCPUtil.java:65)
> at
> org.eclipse.emf.cdo.examples.hibernate.client.BaseTest.initialize(BaseTest.java:78)
>
> at
> org.eclipse.emf.cdo.examples.hibernate.client.BaseTest.openSession(BaseTest.java:51)
>
> at
> org.eclipse.emf.cdo.examples.hibernate.client.QuickStartTest.testCreatePersist(QuickStartTest.java:39)
>
> at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
> at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
> at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
> at java.lang.reflect.Method.invoke(Unknown Source)
> at junit.framework.TestCase.runTest(TestCase.java:176)
> at junit.framework.TestCase.runBare(TestCase.java:141)
> at junit.framework.TestResult$1.protect(TestResult.java:122)
> at junit.framework.TestResult.runProtected(TestResult.java:142)
> at junit.framework.TestResult.run(TestResult.java:125)
> at junit.framework.TestCase.run(TestCase.java:129)
> at junit.framework.TestSuite.runTest(TestSuite.java:255)
> at junit.framework.TestSuite.run(TestSuite.java:250)
> at
> org.junit.internal.runners.JUnit38ClassRunner.run(JUnit38ClassRunner.java:84)
>
> at
> org.eclipse.jdt.internal.junit4.runner.JUnit4TestReference.run(JUnit4TestReference.java:50)
>
> at
> org.eclipse.jdt.internal.junit.runner.TestExecution.run(TestExecution.java:38)
>
> at
> org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTests(RemoteTestRunner.java:467)
>
> at
> org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTests(RemoteTestRunner.java:683)
>
> at
> org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.run(RemoteTestRunner.java:390)
>
> at
> org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.main(RemoteTestRunner.java:197)
>
>
>
> Can someone point out a mistake that I might have made? I am using
> Eclipse 4.3 and installed the most recent version of the CDO plugin and
> all required plugins as described at
> http://wiki.eclipse.org/CDO/Hibernate_Store/Download_and_Install.
>
> Thanks in advance,
> Thomas
>
Re: [CDO] Could not activate TCPClientConnector on CDO Hibernate Client/server example [message #1218682 is a reply to message #1218529] Fri, 29 November 2013 11:37 Go to previous messageGo to next message
Thomas Gerlitz is currently offline Thomas GerlitzFriend
Messages: 9
Registered: November 2013
Junior Member
Hello Christophe,

I attached the log of the server start and my cdo-server.xml.

Thanks in advance,
Thomas
Re: [CDO] Could not activate TCPClientConnector on CDO Hibernate Client/server example [message #1219054 is a reply to message #1218682] Sat, 30 November 2013 12:53 Go to previous messageGo to next message
Eike Stepper is currently offline Eike StepperFriend
Messages: 6458
Registered: July 2009
Senior Member
Am 29.11.2013 12:37, schrieb Thomas Gerlitz:
> Hello Christophe,
>
> I attached the log of the server start and my cdo-server.xml.
From your server log it seems that the Net4j extension is not deployed/started. It should look like:

Time to load bundles: 781
Starting application: 2174
osgi> [INFO] CDO server starting
[INFO] Net4j extension starting
[INFO] Net4j acceptor starting: tcp://0.0.0.0:2036
[INFO] Net4j extension started
[INFO] Repository configuration manager extension starting.
[INFO] Repository configuration manager extension started.
[INFO] Security extension starting
[INFO] Security extension started
[INFO] CDO server started
Application Started: 5791


Please deploy the following bundles, too:

org.eclipse.emf.cdo.server.net4j
org.eclipse.net4j
org.eclipse.net4j.tcp

Cheers
/Eike

----
http://www.esc-net.de
http://thegordian.blogspot.com
http://twitter.com/eikestepper


Re: [CDO] Could not activate TCPClientConnector on CDO Hibernate Client/server example [message #1219180 is a reply to message #1219054] Mon, 02 December 2013 13:53 Go to previous messageGo to next message
Thomas Gerlitz is currently offline Thomas GerlitzFriend
Messages: 9
Registered: November 2013
Junior Member
Hello Eike,

thank you for your help! Now the example is working.

Best regards,
Thomas
Re: [CDO] Could not activate TCPClientConnector on CDO Hibernate Client/server example [message #1250238 is a reply to message #1219054] Wed, 19 February 2014 03:33 Go to previous messageGo to next message
Roza Ghamari is currently offline Roza GhamariFriend
Messages: 82
Registered: January 2013
Member
I have the exact same issue with the same output. I deployed the plugins you mentioned as well but I still don't get the net4j server started. I also attached the server log and the lunch file. I am using the hibernate server example.

I'll really appreciate your help.

Thanks,
Roza
Re: [CDO] Could not activate TCPClientConnector on CDO Hibernate Client/server example [message #1250315 is a reply to message #1250238] Wed, 19 February 2014 05:39 Go to previous messageGo to next message
Eike Stepper is currently offline Eike StepperFriend
Messages: 6458
Registered: July 2009
Senior Member
Am 19.02.2014 04:33, schrieb Roza Ghamari:
> I have the exact same issue with the same output. I deployed the plugins you mentioned as well but I still don't get the net4j server started. I also attached the server log and the lunch file. I am using the hibernate server example.

Your server.log clearly indicates that org.eclipse.emf.cdo.server.net4j is not deployed/started.

I'm a little confused by the existance of two different launches:

/org.eclipse.emf.cdo.tests.hibernate/HibernateServer.launch
/org.eclipse.emf.cdo.examples.hibernate.server/CDOHibernateServer.launch

The example plugin seems to have subtle dependencies on the test project, which doesn't seem right.
I've cc'ed Martin who developed the Hibernate store and examples to comment on this and possibly fix it.

Cheers
/Eike

----
http://www.esc-net.de
http://thegordian.blogspot.com
http://twitter.com/eikestepper


Re: [CDO] Could not activate TCPClientConnector on CDO Hibernate Client/server example [message #1250924 is a reply to message #1250315] Wed, 19 February 2014 18:42 Go to previous message
Roza Ghamari is currently offline Roza GhamariFriend
Messages: 82
Registered: January 2013
Member
That is true I was deploying org.eclipse.emf.cdo.net4j in stead of org.eclipse.emf.cdo.server.net4j. My bad. Thanks for your help.
Previous Topic:[Transaction] Trigger timeout while waiting for transaction
Next Topic:[TENEO] Unable to save a clob type attribute during merge
Goto Forum:
  


Current Time: Sat Dec 14 18:49:16 GMT 2019

Powered by FUDForum. Page generated in 0.02980 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top