Skip to main content

Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » ServerTools (WTP) » Dali: Not correctly mapping column name 'class'
Dali: Not correctly mapping column name 'class' [message #194200] Fri, 08 June 2007 21:53
Eclipse UserFriend
Originally posted by:


Today I tried Eclipse 3.3 RC3 with recent JPA/Dali Plugins.
Furthermore I used MySQL 4.1.

When I used Dali's 'Generate entities...' function all worked fine
except that table columns named 'class' where automatically mapped to
variable name 'class' and 'getClass' method.

This is not suitable for Java as it causes compile errors due incorrect
syntax and overriding getClass method.

Stefan Teitge
Previous Topic:WTP 1.5.4 Problem
Next Topic:JPA Enhancer problem
Goto Forum:

Current Time: Mon Jun 18 17:47:46 GMT 2018

Powered by FUDForum. Page generated in 0.02473 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top