Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Rich Client Platform (RCP) » Can't reproduce application launch on command-line
Can't reproduce application launch on command-line [message #1186431] Thu, 14 November 2013 18:00 Go to next message
Jeff Johnston is currently offline Jeff JohnstonFriend
Messages: 205
Registered: July 2009
Senior Member
I have an Eclipse UI application that brings up the CDT debugger and limits the set of plugins to only what is needed. I have set up an Eclipse Application launch and have it working as I want.

The problem is that I can't reproduce this behaviour using a command-line. I want to use an existing repository of plugins plus my application plugin and simply specify which plugins to use (i.e. I don't want to create another repo or version of Eclipse for the user to install). I started by exporting my application plug-in and placing it in the dropins folder. It is loaded successfully when I restart Eclipse.

I created a shell script that calls the eclipse executable, specifies my application as well as using the osgi.bundles option to limit the plugin set. I wrote my own eclipse.ini file. Unfortunately, I keep getting all plugins dragged in and this causes problems for my application as I get RSE failures during resource notifications when I link some local files. I tried creating my own product but that didn't help.

The Eclipse application launch created an area under .metadata/.plugins/org.eclipse.pde.core/LAUNCH_NAME. I notice there is a config.ini file there which has the osgi.bundles list as I have specified in my script. There is also some directories present but I don't know how they were created and what they do. I tried running eclipse and specifying the osgi.configuration.area as that directory. Again, I still get the entire world dragged in.

Can anyone spell out which options I need to set, how to set them (some of them are vague in the docs (use file:??, specify a dir??) and is there some other way I need to launch other than using the eclipse executable?
Re: Can't reproduce application launch on command-line [message #1186903 is a reply to message #1186431] Thu, 14 November 2013 23:18 Go to previous message
Jeff Johnston is currently offline Jeff JohnstonFriend
Messages: 205
Registered: July 2009
Senior Member
I seem to have solved the problem.

The key seems to be specifying the dev properties file properly.

Files need to be specified as "file:xxxx" for the -dev and -configuration options. For the -data option, this is just a normal file path. This wasn't clear to me in the docs that filepath had to be prefixed with "file:".

The dev.properties file has a set of org.eclipse.xxxxxx.plugin=bin statements for the various plugins I intend to use. Without the dev.properties file specified, I get exceptions in start up (no idea why).

In the end, I was able to copy just the config.ini and dev.properties files from the org.eclipse.pde.core launch area and start up the application successfully with only the plugins I specified.
Previous Topic:Application plug-in strategy?
Next Topic:Dynamically starting bundles UI in e4 application
Goto Forum:
  


Current Time: Wed Sep 19 18:14:54 GMT 2018

Powered by FUDForum. Page generated in 0.01564 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top