Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » Maximo birt 232: export to DOC loses formatting
Maximo birt 232: export to DOC loses formatting [message #1081980] Thu, 08 August 2013 00:01 Go to next message
j k is currently offline j kFriend
Messages: 436
Registered: September 2012
Senior Member
Hi All,

I need to write a set of simple 'mail merge' type letters that are generated out of maximo using their built in BIRT engine

But i'm losing formatting when I export to DOC. It's there when viewing the report.

The two i've noticed are unordered list (indent is gone) and using span background-color to change the background color of text to yellow.

Here's an example of what I need to create
http://img541.imageshack.us/img541/8205/iuzn.png

Here's what it looks like previewed in BIRT
http://img16.imageshack.us/img16/6686/wh1k.png

and here's what I get as a doc
http://img18.imageshack.us/img18/5681/hhzy.png

My initial attempt has used a text box set to HTML but that hasn't worked

What do i need to do to retain this formatting when exporting to doc?
Re: Maximo birt 232: export to DOC loses formatting [message #1086309 is a reply to message #1081980] Wed, 14 August 2013 04:23 Go to previous messageGo to next message
Michael Williams is currently offline Michael WilliamsFriend
Messages: 1925
Registered: July 2009
Senior Member

Sorry for the delayed response. Can you attach your simple example so I can test it in 2.3.2 and in newer versions as well to see what I get? I don't have Maximo, so I can't test in it, unfortunately.

Michael

Developer Evangelist, Silanis
Re: Maximo birt 232: export to DOC loses formatting [message #1087074 is a reply to message #1086309] Thu, 15 August 2013 05:06 Go to previous messageGo to next message
j k is currently offline j kFriend
Messages: 436
Registered: September 2012
Senior Member
Hi Michael,

There's no difference between running a report in maximo and running it using Run|View Report|In Web Viewer

I've attached a 2 page report with a simple master page where the header has 'show on first page' unticked

when exporting to doc the following is lost

text background color
list 'dot' indents
2nd page header

Thanks
Re: Maximo birt 232: export to DOC loses formatting [message #1087117 is a reply to message #1087074] Thu, 15 August 2013 06:40 Go to previous messageGo to next message
Michael Williams is currently offline Michael WilliamsFriend
Messages: 1925
Registered: July 2009
Senior Member

I see what you're talking about with 2.3.2. I also checked in the latest version and it works properly. So, this appears to be a bug that was fixed sometime after 2.3.2. Besides changing the DOC emitter, your only option is probably to deploy BIRT separately from Maximo and call your reports from the external web viewer so you can use the latest version.

Michael

Developer Evangelist, Silanis
Re: Maximo birt 232: export to DOC loses formatting [message #1087748 is a reply to message #1087117] Fri, 16 August 2013 03:47 Go to previous messageGo to next message
j k is currently offline j kFriend
Messages: 436
Registered: September 2012
Senior Member
ok cheers for the info!
Re: Maximo birt 232: export to DOC loses formatting [message #1087751 is a reply to message #1087748] Fri, 16 August 2013 03:53 Go to previous message
Michael Williams is currently offline Michael WilliamsFriend
Messages: 1925
Registered: July 2009
Senior Member

Not a problem!

Michael

Developer Evangelist, Silanis
Previous Topic: Multi-value cascading parameters in Custom Parameter Page by birt tag
Next Topic:Refresh Dataset using BIRT API
Goto Forum:
  


Current Time: Sat Dec 14 10:22:53 GMT 2019

Powered by FUDForum. Page generated in 0.02703 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top