Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » Data in Mongo DB are not displaying correctly in BIRT tool.(Data in Mongo DB are not displaying correctly in BIRT tool.)
Data in Mongo DB are not displaying correctly in BIRT tool. [message #1060906] Wed, 29 May 2013 06:11 Go to next message
Balveer singh is currently offline Balveer singhFriend
Messages: 1
Registered: May 2013
Junior Member
index.php/fa/15079/0/Data in Mongo DB are not displaying correctly in BIRT tool.

Kindly find screen shot in which we have NETVAL and QTY Column that display 0 on BIRT tool, but its not actually in MongoDB.
  • Attachment: Untitled.png
    (Size: 99.14KB, Downloaded 659 times)
Re: Data in Mongo DB are not displaying correctly in BIRT tool. [message #1061055 is a reply to message #1060906] Wed, 29 May 2013 17:02 Go to previous messageGo to next message
Michael Williams is currently offline Michael WilliamsFriend
Messages: 1925
Registered: July 2009
Senior Member

Is this with the new MongoDB ODA in 4.3?

Michael

Developer Evangelist, Silanis
Re: Data in Mongo DB are not displaying correctly in BIRT tool. [message #1101258 is a reply to message #1061055] Wed, 04 September 2013 08:06 Go to previous messageGo to next message
Ludovic PAQUET is currently offline Ludovic PAQUETFriend
Messages: 3
Registered: September 2013
Junior Member
Hello,

I have exactly the same issue with mongodb Number field and Birt 4.3.

The problem is that the field is stored sometimes as an Integer sometimes as a Float in mongo. Consequently Birt does not know how to parse the field.
Let say that the output column is in float in Birt, when we have for instance 53 birt renders 0, when we have 53.23 birt renders the correct value. If the output column is integer, 53 is rendered correctly and 53.23 is rendered by 0.

Someone knows how to avoid such a behaviour ?

Thanks,

Ludovic
Re: Data in Mongo DB are not displaying correctly in BIRT tool. [message #1102240 is a reply to message #1101258] Thu, 05 September 2013 14:59 Go to previous messageGo to next message
Michael Williams is currently offline Michael WilliamsFriend
Messages: 1925
Registered: July 2009
Senior Member

Can you log a bug for this in the bugzilla and put the bug info in here for future reference? Thanks!

Michael

Developer Evangelist, Silanis
Re: Data in Mongo DB are not displaying correctly in BIRT tool. [message #1103001 is a reply to message #1102240] Fri, 06 September 2013 09:31 Go to previous messageGo to next message
Ludovic PAQUET is currently offline Ludovic PAQUETFriend
Messages: 3
Registered: September 2013
Junior Member
Sure : 416703

Here : https://bugs.eclipse.org/bugs/show_bug.cgi?id=416703
Re: Data in Mongo DB are not displaying correctly in BIRT tool. [message #1103345 is a reply to message #1103001] Fri, 06 September 2013 16:48 Go to previous messageGo to next message
Michael Williams is currently offline Michael WilliamsFriend
Messages: 1925
Registered: July 2009
Senior Member

Thanks!

Michael

Developer Evangelist, Silanis
Re: Data in Mongo DB are not displaying correctly in BIRT tool. [message #1111531 is a reply to message #1103345] Wed, 18 September 2013 10:46 Go to previous messageGo to next message
Ludovic PAQUET is currently offline Ludovic PAQUETFriend
Messages: 3
Registered: September 2013
Junior Member
Thanks to Linda, I've attached a binary patch for 4.3.0 release :
https://bugs.eclipse.org/bugs/attachment.cgi?id=235595
Re: Data in Mongo DB are not displaying correctly in BIRT tool. [message #1111819 is a reply to message #1111531] Wed, 18 September 2013 19:37 Go to previous message
Michael Williams is currently offline Michael WilliamsFriend
Messages: 1925
Registered: July 2009
Senior Member

Great! Thanks for the update!

Michael

Developer Evangelist, Silanis
Previous Topic:Does BIRT 2.6.1 support IE 9
Next Topic:how do I write an expression for binding that meets this criteria?
Goto Forum:
  


Current Time: Sat Sep 18 05:49:43 GMT 2021

Powered by FUDForum. Page generated in 0.02568 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top