Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » TMF (Xtext) » Updating completely hosed my environment
Updating completely hosed my environment [message #1023062] Sat, 23 March 2013 05:56
Steve Kallestad is currently offline Steve KallestadFriend
Messages: 62
Registered: March 2013
Member
I went to update to xtext 2.4 and doing so caused my eclipse to just about die.

The environment would start up, but every pane was empty.

And on top of that, no menu bar, so I couldn't even try to re-import a project.

This was happening across all workspaces.

When I went into "Check for Updates" there were several updates available along with the xtext one. My first instinct was to check all of them and get everything current. Was that ever a bad idea.

Searching around for other people experiencing the same problem was fruitless, which is why I'm posting this here.

I reverted my installation and started installing updates one by one.

When I got to the DSL Tools update, my eclipse went blank again.

I reverted, and walked through all of the other updates and everything worked fine.

I reinstalled the DSL Tools update to grab a copy of the error message that was showing up in my .metadata/.log file but oddly enough it worked once all of the other updates were in place.

So... if you run into the same situation I did, don't freak out.

Step 1)

The menus are gone, but Quick Access is still there. Use quick access to open up the installation dialog. Just type "install" and it's the first option.

Step 2)

Go to the installation history tab and revert to the previous working installation.

Step 3)

Close Eclipse and restart with the "-clean" option.

Step 4)

Hopefully you are back to normal here. At this point, I started working one by one with the various updates I had available. I checked for updates again and selected the various updates and installed them one-by-one, restarting eclipse and verifying that it worked after each one. Throughout this process, I had the "-clean" option enabled.

Step 5)

After all of the other desired updates are installed, update DSL Tools

Step 6)

Remove the "-clean" option from your startup script or shortcut.

I hope this helps out at least one other person.
Previous Topic:JvmModelInferrer and InferredTypes
Next Topic:Logical containers for expressions (again)
Goto Forum:
  


Current Time: Tue Jan 28 06:33:23 GMT 2020

Powered by FUDForum. Page generated in 0.01271 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top