Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EGit / JGit » BUG with Jgit and amazon-s3 using specific secretkey(secretkey containing a /)
BUG with Jgit and amazon-s3 using specific secretkey [message #1014894] Tue, 26 February 2013 17:00 Go to next message
Robert Glen is currently offline Robert GlenFriend
Messages: 1
Registered: February 2013
Junior Member
Simple... any time I generate an accesskey and secretkey pair whereby the secretkey contains a forward slash '/' then Jgit cannot successfully authenticate with S3.

Example:

rglen@ws-rglenlnx git.local $ jgit clone amazon-s3://.jgit@sample-bucket-name/a-git-repo.git
Initialized empty Git repository in /usr/local/home/rglen/git.local/a-git-repo.git
fatal: Reading of 'a-git-repo.git/packed-refs' failed: 403 Forbidden
fatal: amazon-s3://sample-bucket-name/a-git-repo.git/objects: error in packed-refs



When I swap out my .jgit file with an accesskey and secretkey pair where the secretkey does NOT contain a /, I can repeat the above command without issue and the repository is cloned successfully.

I've tried putting single and double quotes around the secretkey in the .jgit file, and it makes no difference.

I've tried this with the following versions, both behave the same:
rglen@ws-rglenlnx ~ $ jgit version
jgit version 2.2.0.201212191850-r

rglen@ws-rglenlnx ~ $ jgit version
jgit version 2.3.0.201302130906
Re: BUG with Jgit and amazon-s3 using specific secretkey [message #1834408 is a reply to message #1014894] Mon, 09 November 2020 21:52 Go to previous messageGo to next message
Steve Iribarne is currently offline Steve IribarneFriend
Messages: 3
Registered: September 2017
Junior Member
Hey guys. I just ran into this bug. Is this a known thing? Because it was pretty frustrating thinking I was doing something else stupid and come to find out it was just because I had a secret of

5BeBojWJe/eaEFcwd24wMoI/TIUTTO97z+J1msBZ


Literally spent an hour trying to figure this out.. thinking my remote was setup wrong blah blah blah...

I don't care if it's not fixed, but did I miss this in a readme somewhere? If someone knows I'd love to have it pointed out to me.

Yours humbly :)
-stv
Re: BUG with Jgit and amazon-s3 using specific secretkey [message #1834442 is a reply to message #1834408] Tue, 10 November 2020 12:39 Go to previous message
Thomas Wolf is currently offline Thomas WolfFriend
Messages: 363
Registered: August 2016
Senior Member
Looks to me that the code in JGit for this is rather old and only supports an old authentication mechanism (AWS signature version 2). This should probably be changed to use AWS signature version 4.

Not sure if this has anything to do with this problem. (I don't use S3 myself.) But Amazon states that V2 is deprecated for S3, and that buckets created after June 24, 2020 don't support it anymore.

Contributions welcome.
Previous Topic:Label Decoration/Text Decoration
Next Topic:Default Branch Name
Goto Forum:
  


Current Time: Tue Jun 15 08:00:13 GMT 2021

Powered by FUDForum. Page generated in 0.01447 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top