Skip to main content

Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » SimpleDB plugin not working right
SimpleDB plugin not working right [message #984319] Wed, 14 November 2012 15:45 Go to next message
Jon Gilbert is currently offline Jon GilbertFriend
Messages: 1
Registered: November 2012
Junior Member
I have been using AWS Toolkit for Eclipse to work with my SimpleDB tables. However I run into a weird issue: there are some attributes that do not appear in the table, no matter what I do. I tried creating a new workspace and it still has the same problem.

If I use RazorSQL (commercial software, for which I have an expiring 30-day trial license), then I can see all my attributes just fine. So I know they're there.

So, there seems to be a bug in the SimpleDB profile for Eclipse. The bug is causing some attributes not to show up in the table. Right clicking my domain and selecting, "View Domain Metadata" shows "Distinct attribute names: 19," but there are only 13 appearing in the table! Why? (I believe the ones that are not appearing are ones that were more recently added, but I'm not 100% sure on this.)

Does anyone know a work-around for this issue, or a way to fix it? Am I missing something here? I thought maybe it's just an issue where some cached data in my Eclipse directory was not being overwritten correctly so I made a new workspace, but that did not fix it. Is there anywhere else on the drive that Eclipse might store data that could interfere with proper operation if it became corrupted? (I'm using OS X 10.8.2).

Thanks for any advice, I know this is a general forum but I did not see a sub-forum for AWS on Eclipse and posting at Amazon's SimpleDB site did not yield any results so far. As the problem seems to be more with the Eclipse plug-in than with the actual database itself, I thought I should try here. Shot in the dark.


Re: SimpleDB plugin not working right [message #987748 is a reply to message #984319] Tue, 27 November 2012 21:40 Go to previous message
Brian Fitzpatrick is currently offline Brian FitzpatrickFriend
Messages: 500
Registered: July 2009
Senior Member
You could try posting in the Data Tools forum to see if the AWS folks are watching that, but that's all I can suggest. We didn't have much to do with the AWS plugins for SimpleDB - that was all in house at Amazon.
Previous Topic:Default Button problems on a Composite in Juno
Next Topic:How to disable socks proxy ?
Goto Forum:

Current Time: Fri Oct 23 09:30:39 GMT 2020

Powered by FUDForum. Page generated in 0.01993 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top