Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » RAP Templates not working?
RAP Templates not working? [message #124836] Mon, 16 March 2009 16:03 Go to next message
Eclipse UserFriend
Originally posted by: amchavan.eso.org

All,

I'm trying to evaluate the Eclipse RAP platform for an ESO project, but
I can't get the sample templates to generate code for me -- I'm
referring to templates like "RAP application with a view", etc.

I've been doing some development with Eclipse RCP, so I am relatively
familiar with the basic concepts.
Here is what I am doing:

(1) Download and install Eclipse for RCP/Plug-in Developers

(2) Start it with a fresh workspace, then select Help > Software Updates

(3) On the Avaliable Software tab, click on Add Site... and add
http://download.eclipse.org/rt/rap/update-site -- I'm going for Service
Release 1.1.2 here, but things don't change when choosing the 1.2 M5
Milestone Build instead.

(4) First odd thing: in addition to that update site, I see
http://download.eclipse.org/technology/rap/update-site appearing as
well, offering release 1.1.1.

I ignore that, select 1.1.2.20090218.1359 and click on Install... I go
through all the steps (which takes forever, some server is extremely
slow today), and eventually restart Eclipse.

(5) I then install the Target Platform, following the link from the
Welcome page. The platform gets installed in its default location;
again, choosing a different location doesn't seem to change anything much.

(6) Fine -- so now I choose File > New > Project..., then Plugin
Project. I give the project a name, tick the checkbox next to "This
plugin will make contributions to the UI" and choose No for "Create a
rich client application?". If I then click on Next I am presented with a
list of available templates, including three RAP ones. I choose one of
them, say "RAP application with a view", click on Finish, and the
application is created for me.

BUT: the only class I can find under the source directory is
Activator.java -- Application.java, Perspective.java etc. are missing.

Note that if answer Yes to the "Create a rich client application?"
question, and choose a similar RCP template, a total of 7 Java source
files are generated.

Does anyone know why those files are missing from my RAP project?
Thank you very much,

Maurizio Chavan, European Southern Observatory
Re: RAP Templates not working? [message #124935 is a reply to message #124836] Mon, 16 March 2009 19:17 Go to previous message
Rüdiger Herrmann is currently offline Rüdiger HerrmannFriend
Messages: 581
Registered: July 2009
Senior Member
Muarizio,

did you maybe run into bug #264613 ([Tooling] Templates are broken
on PDE 3.5 stream)? This is fixed meanwhile and will be published
with the 1.2 M6 build.
Otherwise, please feel free to file a bug report.

Cheers,
Rüdiger

Muarizio Chavan wrote:
> All,
>
> I'm trying to evaluate the Eclipse RAP platform for an ESO project, but
> I can't get the sample templates to generate code for me -- I'm
> referring to templates like "RAP application with a view", etc.
>
> I've been doing some development with Eclipse RCP, so I am relatively
> familiar with the basic concepts.
> Here is what I am doing:
>
> (1) Download and install Eclipse for RCP/Plug-in Developers
>
> (2) Start it with a fresh workspace, then select Help > Software Updates
>
> (3) On the Avaliable Software tab, click on Add Site... and add
> http://download.eclipse.org/rt/rap/update-site -- I'm going for Service
> Release 1.1.2 here, but things don't change when choosing the 1.2 M5
> Milestone Build instead.
>
> (4) First odd thing: in addition to that update site, I see
> http://download.eclipse.org/technology/rap/update-site appearing as
> well, offering release 1.1.1.
>
> I ignore that, select 1.1.2.20090218.1359 and click on Install... I go
> through all the steps (which takes forever, some server is extremely
> slow today), and eventually restart Eclipse.
>
> (5) I then install the Target Platform, following the link from the
> Welcome page. The platform gets installed in its default location;
> again, choosing a different location doesn't seem to change anything much.
>
> (6) Fine -- so now I choose File > New > Project..., then Plugin
> Project. I give the project a name, tick the checkbox next to "This
> plugin will make contributions to the UI" and choose No for "Create a
> rich client application?". If I then click on Next I am presented with a
> list of available templates, including three RAP ones. I choose one of
> them, say "RAP application with a view", click on Finish, and the
> application is created for me.
>
> BUT: the only class I can find under the source directory is
> Activator.java -- Application.java, Perspective.java etc. are missing.
>
> Note that if answer Yes to the "Create a rich client application?"
> question, and choose a similar RCP template, a total of 7 Java source
> files are generated.
>
> Does anyone know why those files are missing from my RAP project?
> Thank you very much,
>
> Maurizio Chavan, European Southern Observatory
Previous Topic:FormEditor not painted correctly after minimize
Next Topic:activeMenuSelection Expression Language
Goto Forum:
  


Current Time: Fri Feb 03 04:08:52 GMT 2023

Powered by FUDForum. Page generated in 0.31645 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top