Skip to main content

Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » eclipse won't launch(I've tried the obvious)
eclipse won't launch [message #915460] Mon, 17 September 2012 10:15 Go to next message
Simon Orr is currently offline Simon OrrFriend
Messages: 2
Registered: September 2012
Junior Member

I wonder if anyone can help me,

I've had eclipse [Helios build 20100507] installed on my machine [Win7 x64] and running quite happily for quite some time now. For a long time, the only Java I had installed was the JRE1.6

I haven't touched eclipse in about a month as I've been working on a different project, which incidentally required that I install the JDK [jdk1.6.0_33] and set the JAVA_HOME environment variable. I can't think of any other changes which could be relevant.

When I came back to eclipse today, it wouldn't start (specifically, the splash screen showed for under a second then the process exited).

Having done some reading, it seems likely that the "default" JVM has changed and that eclipse may be having issues with this. So, I've tried the following:

edit the eclipse.ini file and added:
C:\Program Files\Java\jre6\bin\javaw.exe

I also set the vmargs' Xmx to 1024m

When launching eclipse now, the process stays alive for longer (2-3 seconds) but I see no splash screen at all.

Next, I tried explicitly setting it to the javaw.exe in the JDK (just in case). This had exactly the same effect as no ini setting (quick flicker of splash).

In an attempt to unwind back to where I was when I started I uninstalled the JDK, unset the JAVA_HOME environment variable, uninstalled the JRE and then reinstalled the latest JRE (1.7 update 7).

Now, launching eclipse with/without a VM specified in the ini results in no splash screen and a process that dies after 2-3 seconds.

If I attempt to run the launcher from the command line explicitly...

C:\Users\X>"C:\Program Files\Java\jre7\bin\javaw.exe" -jar "c:\Program Files (x86)\eclipse\plugins\org.eclipse.equinox.launcher_1.1.0.v20100507.jar"

The command line returns immediately and the javaw.exe process terminates less than a second later.

Can someone please point me at how I can diagnose this further? Are there any log files that I can access to see what's actually going on? (Note, I've checked Workspace\.metadata\.log and it hasn't been modified in over a month)

Needless to say, I've only switched back to eclipse because I need to use it so a workaround or quick-fix would be greatly appreciated

Many thanks


Running the command-line java.exe with the -verbose option gives a lot of output but the final few lines are...

[Loaded org.eclipse.core.internal.runtime.PrintStackUtil from file:/C:/Program Files (x86)/eclipse/plugins/org.eclipse.equinox.common_3.6.0.v20100503.jar]
[Loaded org.eclipse.osgi.internal.resolver.ComputeNodeOrder from file:/c:/Program Files (x86)/eclipse/plugins/org.eclipse.osgi_3.6.0.v20100517.jar]
[Loaded org.eclipse.osgi.internal.resolver.ComputeNodeOrder$Digraph from file:/c:/Program Files (x86)/eclipse/plugins/org.eclipse.osgi_3.6.0.v20100517.jar]
[Loaded org.eclipse.osgi.internal.resolver.ComputeNodeOrder$Digraph$Vertex from file:/c:/Program Files (x86)/eclipse/plugins/org.eclipse.osgi_3.6.0.v20100517.jar]
[Loaded org.eclipse.osgi.framework.internal.core.BundleContextImpl$2 from file:/c:/Program Files (x86)/eclipse/plugins/org.eclipse.osgi_3.6.0.v20100517.jar]
[Loaded org.eclipse.osgi.internal.serviceregistry.ServiceUse$2 from file:/c:/Program Files (x86)/eclipse/plugins/org.eclipse.osgi_3.6.0.v20100517.jar]
[Loaded org.eclipse.osgi.internal.serviceregistry.ServiceUse$3 from file:/c:/Program Files (x86)/eclipse/plugins/org.eclipse.osgi_3.6.0.v20100517.jar]
[Loaded org.eclipse.core.runtime.internal.adaptor.IModel from file:/c:/Program Files (x86)/eclipse/plugins/org.eclipse.osgi_3.6.0.v20100517.jar]
[Loaded org.xml.sax.EntityResolver from C:\Program Files\Java\jre7\lib\rt.jar]
[Loaded org.xml.sax.DTDHandler from C:\Program Files\Java\jre7\lib\rt.jar]
[Loaded org.xml.sax.ContentHandler from C:\Program Files\Java\jre7\lib\rt.jar]
[Loaded org.xml.sax.ErrorHandler from C:\Program Files\Java\jre7\lib\rt.jar]
[Loaded org.xml.sax.helpers.DefaultHandler from C:\Program Files\Java\jre7\lib\rt.jar]
[Loaded org.eclipse.core.runtime.internal.adaptor.PluginParser from file:/c:/Program Files (x86)/eclipse/plugins/org.eclipse.osgi_3.6.0.v20100517.jar]
[Loaded org.xml.sax.SAXParseException from C:\Program Files\Java\jre7\lib\rt.jar]
[Loaded from C:\Program Files\Java\jre7\lib\rt.jar]

None of which seems to indicate a problem?

[Updated on: Mon, 17 September 2012 10:40]

Report message to a moderator

Re: eclipse won't launch [message #915547 is a reply to message #915460] Mon, 17 September 2012 14:04 Go to previous messageGo to next message
David Wegener is currently offline David WegenerFriend
Messages: 1441
Registered: July 2009
Senior Member
One guess would be that you are trying to run a 32 bit Eclipse on a 64 bit JVM. The C:/Program Files (x86) entry indicates that some application (possibly a 32 bit JDK) was installed on your system. This is where Windows installs 32 bit programs on 64 bit systems.

My guess would be that you initially installed a 32 bit JDK and put Eclipse in the C:\Program Files (x86) directory. Your subsequent JDK installs were 64 bit. Look in the C:\Program Files (x86) directory for a Java folder to see if you can find the 32 bit JDK.

To get things working, you would need to either run Eclipse against the 32 bit JDK, or download the 64 bit Eclipse version and run that against a 64 bit JDK.
Re: eclipse won't launch [message #915551 is a reply to message #915547] Mon, 17 September 2012 14:14 Go to previous message
Simon Orr is currently offline Simon OrrFriend
Messages: 2
Registered: September 2012
Junior Member
Hi David,

Thanks for the response. It hadn't even occurred to me that the 64-bit JVM wouldn't be able to run 32-bit apps. That seems to have been the problem. Picking the 32-bit executable to run eclipse did the trick

Thank you very much for your help
Previous Topic:How do I install eclipse?
Next Topic:run configuration variables
Goto Forum:

Current Time: Sat Jan 22 18:42:31 GMT 2022

Powered by FUDForum. Page generated in 0.02454 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top