Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF "Technology" (Ecore Tools, EMFatic, etc)  » [CDO 0.8.0M7] server problem
[CDO 0.8.0M7] server problem [message #122375] Tue, 13 May 2008 18:30 Go to next message
Mark Geib is currently offline Mark GeibFriend
Messages: 432
Registered: July 2009
Senior Member
Eike,

I just updated to M7 from M6. I dropped my db, and created empty one, now
the server will not start. I get...

Any ideas.?

osgi> [INFO] CDO Server starting
[ERROR] Unknown column 'parent' in 'field list'
org.eclipse.net4j.db.DBException: Unknown column 'parent' in 'field list'
at
org.eclipse.net4j.internal.db.DBAdapter.validateTable(DBAdap ter.java:360)
at org.eclipse.net4j.internal.db.DBAdapter.createTable(DBAdapte r.java:141)
at
org.eclipse.net4j.internal.db.DBAdapter.createTables(DBAdapt er.java:106)
at org.eclipse.net4j.internal.db.ddl.DBSchema.create(DBSchema.j ava:93)
at org.eclipse.net4j.internal.db.ddl.DBSchema.create(DBSchema.j ava:103)
at
org.eclipse.emf.cdo.server.internal.db.DBStore.doActivate(DB Store.java:203)
at
org.eclipse.net4j.internal.util.lifecycle.Lifecycle.activate (Lifecycle.java:57)
at
org.eclipse.net4j.util.lifecycle.LifecycleUtil.activate(Life cycleUtil.java:71)
at
org.eclipse.net4j.util.lifecycle.LifecycleUtil.activate(Life cycleUtil.java:61)
at
org.eclipse.emf.cdo.internal.server.Repository.activateRepos itory(Repository.java:262)
at
org.eclipse.emf.cdo.internal.server.Repository.doActivate(Re pository.java:250)
at
org.eclipse.net4j.internal.util.lifecycle.Lifecycle.activate (Lifecycle.java:57)
at
org.eclipse.net4j.util.lifecycle.LifecycleUtil.activate(Life cycleUtil.java:71)
at
org.eclipse.net4j.util.lifecycle.LifecycleUtil.activate(Life cycleUtil.java:61)
at
org.eclipse.emf.cdo.server.CDOServerUtil.addRepository(CDOSe rverUtil.java:68)
at
org.eclipse.emf.cdo.internal.server.RepositoryConfigurator.c onfigure(RepositoryConfigurator.java:82)
at
org.eclipse.emf.cdo.internal.server.bundle.CDOServerApplicat ion.doStart(CDOServerApplication.java:51)
at
org.eclipse.net4j.util.om.OSGiApplication.start(OSGiApplicat ion.java:61)
at
org.eclipse.equinox.internal.app.EclipseAppHandle.run(Eclips eAppHandle.java:193)
at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .runApplication(EclipseAppLauncher.java:110)
at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .start(EclipseAppLauncher.java:79)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:362)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:175)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAcce ssorImpl.java:39)
at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMe thodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java: 549)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:504)
at org.eclipse.equinox.launcher.Main.run(Main.java:1236)
Re: [CDO 0.8.0M7] server problem [message #122388 is a reply to message #122375] Tue, 13 May 2008 20:17 Go to previous messageGo to next message
Mark Geib is currently offline Mark GeibFriend
Messages: 432
Registered: July 2009
Senior Member
Ignore please. No problem.
Re: [CDO 0.8.0M7] server problem [message #122431 is a reply to message #122388] Wed, 14 May 2008 06:48 Go to previous message
Eike Stepper is currently offline Eike StepperFriend
Messages: 6487
Registered: July 2009
Senior Member
geib wrote:

> Ignore please. No problem.

I love this sort of issue ;-)

Cheers
/Eike


Re: [CDO 0.8.0M7] server problem [message #618035 is a reply to message #122375] Tue, 13 May 2008 20:17 Go to previous message
Mark Geib is currently offline Mark GeibFriend
Messages: 432
Registered: July 2009
Senior Member
Ignore please. No problem.
Re: [CDO 0.8.0M7] server problem [message #618039 is a reply to message #122388] Wed, 14 May 2008 06:48 Go to previous message
Eike Stepper is currently offline Eike StepperFriend
Messages: 6487
Registered: July 2009
Senior Member
geib wrote:

> Ignore please. No problem.

I love this sort of issue ;-)

Cheers
/Eike


Previous Topic:[CDO 0.8.0 M7] problem retreiving collection
Next Topic:[EMF Compare]icons for remote changes not implemented?
Goto Forum:
  


Current Time: Mon Apr 06 07:43:45 GMT 2020

Powered by FUDForum. Page generated in 0.07539 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top