Skip to main content

Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » Java Development Tools (JDT) » Ctrl Shift G not working
Ctrl Shift G not working [message #892914] Sun, 01 July 2012 20:39 Go to next message
Sam Kerba is currently offline Sam KerbaFriend
Messages: 2
Registered: July 2012
Junior Member
I have been using eclipse Indigo until recently. Suddenly find references function stopped working across workspace and instead gave a limited list of results within the same project.
I have done some research online and tried few solutions such deleting the indexes, remapping the key, rebuilding the indexes,deleteting the whole meta core directory to no avail.
Finally I installed the latest Juno version afresh in a new location a couple of days ago, but I was not happy the same problem persisted, indicating it could be a problem outside of Eclipse.
Find references is the single most useful function in my opinion for evaluating the impact of making changes to existing code. I really need to get this working given that I have been up untill now happy with eclipse and don't wish to switch to Intellij, and have to learn a new IDE because of some potentially solvable problem.

Has anyone had the same problem? or perhaps any idea on how I can investigate this problem at OS and indexer plugin level? am I missing some configuration (this used to work btw)
One thing my project referenced libraries are jars inside the referencing project, and each has a corresponding eclipse project. It used to magically search those projects and go there instead of the jar for found references when I do ctrl shift g.

Thanks a lot for your time in advance
Re: Ctrl Shift G not working [message #893010 is a reply to message #892914] Mon, 02 July 2012 09:33 Go to previous messageGo to next message
Sam Kerba is currently offline Sam KerbaFriend
Messages: 2
Registered: July 2012
Junior Member
Apologies, this is a non issue. It looks like the jar dependencies do not get associated automatically with workspace projects.
In fact there is a way to do the association in the jar dependency (by clicking it on it and adding source location) which did not work for me.
For now I am happy to just add As project in the properties and make it lower priority than the actual jar.

Re: Ctrl Shift G not working [message #986748 is a reply to message #892914] Wed, 21 November 2012 14:25 Go to previous message
Scott Kurz is currently offline Scott KurzFriend
Messages: 1
Registered: November 2012
Junior Member
For anyone else stuck on this...

Check if your classpath is set up with a project->JAR dependency when it should be using a project->project dependency.

Some more detail:

I'm using a Java-based framework which is smart enough to import your Java project either with the project->project dependency if possible or with a dependency on the associated JAR if not.

(I'm actually not using Maven but I imagine there's a way to get confused with Maven's Eclipse integration and end up with the same result.)

Anyway usually it leaves me with a project->project dependency, but I messed something up on my disk and it found the JAR instead of the other project.


An interesting, related note.. the way I messed up my disk was doing a rename of a particular folder to "dir1.bak". I thought I was hiding it from Eclipse but the refactoring picked up the changed location which threw everything off.

Hope that helps someone.

Previous Topic:Analyzing Compilation Unit through a java application
Next Topic:Build Error
Goto Forum:

Current Time: Wed Dec 02 12:30:45 GMT 2020

Powered by FUDForum. Page generated in 0.01215 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top