Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF » [CDO] FileNotFoundException when using object.eGet()
[CDO] FileNotFoundException when using object.eGet() [message #885614] Wed, 13 June 2012 10:23 Go to next message
Christophe Bouhier is currently offline Christophe BouhierFriend
Messages: 937
Registered: July 2009
Senior Member
Hi,


I had this before, but never paid much attention to it, now it's actually a reproducable problem, so I am investigating.

So, somehow CDO tries to resolve a reference, which ends up in a ResourceSet demand loading
an object. The resource holding this object is really a CDOResource, so I am puzzled how this can happen?
Any idea on how to trouble shoot? (Could my code accidently put a referenced object in a non-CDO resource?)

I am going to try by trapping the exception, and see what the resource URI is...

thanx Christophe


java.io.FileNotFoundException: temp (No such file or directory)
at org.eclipse.emf.ecore.resource.impl.ResourceSetImpl.handleDemandLoadException(ResourceSetImpl.java:315)
at org.eclipse.emf.ecore.resource.impl.ResourceSetImpl.demandLoadHelper(ResourceSetImpl.java:274)
at org.eclipse.emf.ecore.resource.impl.ResourceSetImpl.getResource(ResourceSetImpl.java:397)
at org.eclipse.emf.ecore.resource.impl.ResourceSetImpl.getEObject(ResourceSetImpl.java:216)
at org.eclipse.emf.internal.cdo.view.AbstractCDOView.convertIDToObject(AbstractCDOView.java:1001)
at org.eclipse.emf.internal.cdo.view.CDOStoreImpl.convertIDToObject(CDOStoreImpl.java:668)
at org.eclipse.emf.internal.cdo.view.CDOStoreImpl.convertToEMF(CDOStoreImpl.java:636)
at org.eclipse.emf.internal.cdo.view.CDOStoreImpl.get(CDOStoreImpl.java:187)
at org.eclipse.emf.internal.cdo.CDOObjectImpl.dynamicGet(CDOObjectImpl.java:492)
at org.eclipse.emf.ecore.impl.EStructuralFeatureImpl$InternalSettingDelegateSingleEObject.dynamicGet(EStructuralFeatureImpl.java:2330)
at org.eclipse.emf.ecore.impl.BasicEObjectImpl.eGet(BasicEObjectImpl.java:1037)
at org.eclipse.emf.ecore.impl.BasicEObjectImpl.eGet(BasicEObjectImpl.java:1021)
at org.eclipse.emf.ecore.impl.BasicEObjectImpl.eGet(BasicEObjectImpl.java:1013)
at org.eclipse.emf.ecore.impl.BasicEObjectImpl.eGet(BasicEObjectImpl.java:1008)
at com.netxforge.netxstudio.models.export.MasterDataExporterRevenge.processAttributeData(MasterDataExporterRevenge.java:320)
at com.netxforge.netxstudio.models.export.MasterDataExporterRevenge.processAttributesClass(MasterDataExporterRevenge.java:261)
at com.netxforge.netxstudio.models.export.MasterDataExporterRevenge.processAttributeClassifier(MasterDataExporterRevenge.java:222)
at com.netxforge.netxstudio.models.export.MasterDataExporterRevenge.processPackages(MasterDataExporterRevenge.java:95)
at com.netxforge.netxstudio.models.export.MasterDataExporterRevenge.process(MasterDataExporterRevenge.java:70)
... 3 more
Caused by: java.io.FileNotFoundException: temp (No such file or directory)
at java.io.FileInputStream.open(Native Method)
at java.io.FileInputStream.<init>(FileInputStream.java:120)
at org.eclipse.emf.ecore.resource.impl.FileURIHandlerImpl.createInputStream(FileURIHandlerImpl.java:105)
at org.eclipse.emf.ecore.resource.impl.ExtensibleURIConverterImpl.createInputStream(ExtensibleURIConverterImpl.java:350)
at org.eclipse.emf.ecore.resource.impl.ResourceImpl.load(ResourceImpl.java:1262)
at org.eclipse.emf.ecore.resource.impl.ResourceSetImpl.demandLoad(ResourceSetImpl.java:255)
at org.eclipse.emf.ecore.resource.impl.ResourceSetImpl.demandLoadHelper(ResourceSetImpl.java:270)
... 20 more
Re: [CDO] FileNotFoundException when using object.eGet() [message #885682 is a reply to message #885614] Wed, 13 June 2012 12:35 Go to previous messageGo to next message
Eike Stepper is currently offline Eike StepperFriend
Messages: 6441
Registered: July 2009
Senior Member
Hi Christophe,

Is it possible for you to write a small test case that reproduces this issue? Please have a look at our other test cases
and see how simple it is ;-)

Cheers
/Eike

----
http://www.esc-net.de
http://thegordian.blogspot.com
http://twitter.com/eikestepper



Am 13.06.2012 12:23, schrieb Christophe Bouhier:
> Hi,
>
> I had this before, but never paid much attention to it, now it's actually a reproducable problem, so I am investigating.
> So, somehow CDO tries to resolve a reference, which ends up in a ResourceSet demand loading
> an object. The resource holding this object is really a CDOResource, so I am puzzled how this can happen? Any idea on
> how to trouble shoot? (Could my code accidently put a referenced object in a non-CDO resource?)
>
> I am going to try by trapping the exception, and see what the resource URI is...
>
> thanx Christophe
>
>
> java.io.FileNotFoundException: temp (No such file or directory)
> at org.eclipse.emf.ecore.resource.impl.ResourceSetImpl.handleDemandLoadException(ResourceSetImpl.java:315)
> at org.eclipse.emf.ecore.resource.impl.ResourceSetImpl.demandLoadHelper(ResourceSetImpl.java:274)
> at org.eclipse.emf.ecore.resource.impl.ResourceSetImpl.getResource(ResourceSetImpl.java:397)
> at org.eclipse.emf.ecore.resource.impl.ResourceSetImpl.getEObject(ResourceSetImpl.java:216)
> at org.eclipse.emf.internal.cdo.view.AbstractCDOView.convertIDToObject(AbstractCDOView.java:1001)
> at org.eclipse.emf.internal.cdo.view.CDOStoreImpl.convertIDToObject(CDOStoreImpl.java:668)
> at org.eclipse.emf.internal.cdo.view.CDOStoreImpl.convertToEMF(CDOStoreImpl.java:636)
> at org.eclipse.emf.internal.cdo.view.CDOStoreImpl.get(CDOStoreImpl.java:187)
> at org.eclipse.emf.internal.cdo.CDOObjectImpl.dynamicGet(CDOObjectImpl.java:492)
> at
> org.eclipse.emf.ecore.impl.EStructuralFeatureImpl$InternalSettingDelegateSingleEObject.dynamicGet(EStructuralFeatureImpl.java:2330)
> at org.eclipse.emf.ecore.impl.BasicEObjectImpl.eGet(BasicEObjectImpl.java:1037)
> at org.eclipse.emf.ecore.impl.BasicEObjectImpl.eGet(BasicEObjectImpl.java:1021)
> at org.eclipse.emf.ecore.impl.BasicEObjectImpl.eGet(BasicEObjectImpl.java:1013)
> at org.eclipse.emf.ecore.impl.BasicEObjectImpl.eGet(BasicEObjectImpl.java:1008)
> at
> com.netxforge.netxstudio.models.export.MasterDataExporterRevenge.processAttributeData(MasterDataExporterRevenge.java:320)
> at
> com.netxforge.netxstudio.models.export.MasterDataExporterRevenge.processAttributesClass(MasterDataExporterRevenge.java:261)
> at
> com.netxforge.netxstudio.models.export.MasterDataExporterRevenge.processAttributeClassifier(MasterDataExporterRevenge.java:222)
> at com.netxforge.netxstudio.models.export.MasterDataExporterRevenge.processPackages(MasterDataExporterRevenge.java:95)
> at com.netxforge.netxstudio.models.export.MasterDataExporterRevenge.process(MasterDataExporterRevenge.java:70)
> ... 3 more
> Caused by: java.io.FileNotFoundException: temp (No such file or directory)
> at java.io.FileInputStream.open(Native Method)
> at java.io.FileInputStream.<init>(FileInputStream.java:120)
> at org.eclipse.emf.ecore.resource.impl.FileURIHandlerImpl.createInputStream(FileURIHandlerImpl.java:105)
> at
> org.eclipse.emf.ecore.resource.impl.ExtensibleURIConverterImpl.createInputStream(ExtensibleURIConverterImpl.java:350)
> at org.eclipse.emf.ecore.resource.impl.ResourceImpl.load(ResourceImpl.java:1262)
> at org.eclipse.emf.ecore.resource.impl.ResourceSetImpl.demandLoad(ResourceSetImpl.java:255)
> at org.eclipse.emf.ecore.resource.impl.ResourceSetImpl.demandLoadHelper(ResourceSetImpl.java:270)
> ... 20 more
>


Re: [CDO] FileNotFoundException when using object.eGet() [message #886161 is a reply to message #885682] Thu, 14 June 2012 11:04 Go to previous message
Christophe Bouhier is currently offline Christophe BouhierFriend
Messages: 937
Registered: July 2009
Senior Member
Hi Eike,

As you know, I have frequently these similar type of issues which seem to relate to database issues.... actually to be honest I don't know why this happens. (The root cause).
What I do know is that, it doesn't show up in unit test and usage of the system in an early phase. These things tend to occure after while, so reproducing them
is very challenging. I am in the process to setup a test environment which mimics the customer set up, where I want to do load/stress testing the system, hopefully this will
produce better insight in what is going on my (unfortunately) unstable system.

Cheers Christophe
Previous Topic:Reading XMI error?
Next Topic:[Net4j.util 4.0.0] Set driver type in cdo-server.xml throws ClassCastException
Goto Forum:
  


Current Time: Thu Aug 22 01:11:17 GMT 2019

Powered by FUDForum. Page generated in 0.02522 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top