Skip to main content

Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » Test and Performance Tools Platform (TPTP) » TPTP - Regression - NullPointerException raised when "fetching children of host" (
TPTP - Regression - NullPointerException raised when "fetching children of host" ( [message #117019] Fri, 02 November 2007 21:01
Alessandro Tucci is currently offline Alessandro TucciFriend
Messages: 33
Registered: July 2009
OS: Linux SuSE 10.1
ECLIPSE: 3.3 upgraded to 3.3.1
TPTP: upgraded to
JVM: jdk 1.5.0_12

Hi everybody,
I upgraded Eclipse and its components via Update Manager. In particular,
TPTP was updated from version to Every upgrade was
successful, except for DTP (it is a known issue, see: g00881.html):
this problem was solved in the same way the article suggests.
Now, though, when I launch a Java application:

java ... '-agentlib:JPIBootLoader=JPIAgent:server=controlled;CGProf' ...

as I try to attach to the agent from TPTP workbench, the following
exception is raised:

An internal error occurred during: "Fetching children of host".

The same error appears everytime I click on the "Refresh" button, even
when there is no agent launched. I point out that the profiler cannot be
launched from TPTP workbench, because of the problem explained in
another message of mine, whose subject is:

Profiling Axis/Xerces - Raised java.lang.ArrayIndexOutOfBoundsException: -1

Ask me for any information you need, in case my description is not
detailed enough. Thanks for your attention,
Alessandro Tucci
Previous Topic:Profiling Axis/Xerces - Raised java.lang.ArrayIndexOutOfBoundsException: -1
Next Topic:Nondeterministic Profiler Trace import
Goto Forum:

Current Time: Fri Aug 23 10:47:15 GMT 2019

Powered by FUDForum. Page generated in 0.02100 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top