Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » TMF (Xtext) » weird bundle dependencies generated
weird bundle dependencies generated [message #875143] Tue, 22 May 2012 08:06 Go to next message
Vlad Dumitrescu is currently offline Vlad DumitrescuFriend
Messages: 430
Registered: July 2009
Location: Gothenburg
Senior Member
Hi,

Nowadays, when regenerating my language code, the manifest gets added a couple of dependencies to bundles that don't exist. The names are matching package names in my code.

It's annoying to have to remove them every time. Does anyone know what might be the problem?

regards,
Vlad
Re: weird bundle dependencies generated [message #875146 is a reply to message #875143] Tue, 22 May 2012 08:16 Go to previous messageGo to next message
Vlad Dumitrescu is currently offline Vlad DumitrescuFriend
Messages: 430
Registered: July 2009
Location: Gothenburg
Senior Member
Oh, an important detail: these bundles are added to the test project's manifest.
/Vlad
Re: weird bundle dependencies generated [message #875169 is a reply to message #875146] Tue, 22 May 2012 09:05 Go to previous messageGo to next message
Sebastian Zarnekow is currently offline Sebastian ZarnekowFriend
Messages: 3108
Registered: July 2009
Senior Member
Please file a ticket and provide information about your Xtext version.

Thanks,
Sebastian
--
Need professional support for Eclipse Modeling?
Go visit: http://xtext.itemis.com

Am 22.05.12 10:16, schrieb Vlad Dumitrescu:
> Oh, an important detail: these bundles are added to the test project's
> manifest.
> /Vlad
>
Re: weird bundle dependencies generated [message #875307 is a reply to message #875169] Tue, 22 May 2012 13:54 Go to previous messageGo to next message
Vlad Dumitrescu is currently offline Vlad DumitrescuFriend
Messages: 430
Registered: July 2009
Location: Gothenburg
Senior Member
Ok, I will create a bug report, but I am trying to reproduce it with another project than mine, so that there's a chance for someone to see what is going on. So far without success...

/Vlad
Re: weird bundle dependencies generated [message #875484 is a reply to message #875169] Tue, 22 May 2012 20:32 Go to previous message
Vlad Dumitrescu is currently offline Vlad DumitrescuFriend
Messages: 430
Registered: July 2009
Location: Gothenburg
Senior Member
I found the problem, see https://bugs.eclipse.org/bugs/show_bug.cgi?id=380327 for details.

The short story is that the language plugin name doesn't necessarily match the package where the grammar is located.

regards,
Vlad
Previous Topic:Templates for Xtext
Next Topic:Problem running Mwe2 worflow
Goto Forum:
  


Current Time: Sat Dec 05 00:22:05 GMT 2020

Powered by FUDForum. Page generated in 0.02136 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top