Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » HelpSystem in Tomcat + WAR
HelpSystem in Tomcat + WAR [message #114384] Thu, 04 December 2008 14:34 Go to next message
No real name is currently offline No real nameFriend
Messages: 3
Registered: July 2009
Junior Member
Hi all,

with the tips from this newsgroup it's easy to get the Eclipse Help System
running - in the IDE and Jetty as container. Unfortunately a deployement
in a self-fulfilling WAR under Tomcat seems to require some additional
steps that are not so obvious ... (for me!)

I've tried to deploy the demo of RÃŒdiger from
http://www.eclipse.org/newsportal/article.php?id=4912&gr oup=eclipse.technology.rap#4912.
In the Eclipse-IDE it works fine and under (a stand-alone) Tomcat the
application itself starts too.

The problem arises when the application triggers the help sytem with the
url String helpURL = "http://{0}:{1}/index.jsp". Even though the
webapp-bundle with the servlet registrations is active (and the extension
elements are available at runtime - I did a dump) the index.jsp is taken
from the webapp/ROOT directory, i.e. I see the start page of Tomcat.

Changing the name of the jsp to a unique name (unknown to Tomcat) hoping
that the registration
<servlet
alias="/*.jsp"
class="org.eclipse.equinox.jsp.jasper.registry.JSPFactory:/ "
httpcontextId="help">
</servlet>
of the webapp extension would take care for the servlet only leads to a
"resource not available" HTTP message.

Seems that I haven't found the operative point yet!?! Can anyone give a
tip what's the missing link?

Many thanks & best regards
Rainer

Ps: my deployment consists of a WAR with the servletbridge and the
following bundles where org.eclipse.rap.help.integration_1.0.0 is the demo
application mentioned above.

osgi> ss

Framework is launched.

id State Bundle
0 ACTIVE org.eclipse.osgi_3.5.0.v20080916-2300
Fragments=42
1 ACTIVE org.eclipse.equinox.common_3.4.0.v20080421-2006
2 ACTIVE org.eclipse.update.configurator_3.2.101.R33x_v20070810
3 ACTIVE
org.eclipse.equinox.http.servletbridge_1.0.0.v20080427-0830
4 ACTIVE
org.eclipse.equinox.http.registry_1.0.100.v20080427-0830
5 ACTIVE org.eclipse.rap.help.integration_1.0.0
6 ACTIVE javax.servlet.jsp_2.0.0.v200806031607
7 ACTIVE javax.servlet_2.4.0.v200806031604
8 ACTIVE org.eclipse.equinox.http.servlet_1.0.100.v20080427-0830
9 ACTIVE org.apache.jasper_5.5.17.v200806031609
10 ACTIVE
org.eclipse.equinox.jsp.jasper.registry_1.0.0.v20080427-0830
11 ACTIVE org.eclipse.equinox.jsp.jasper_1.0.100.v20080427-0830
12 ACTIVE org.apache.lucene.analysis_1.9.1.v200706181610
13 ACTIVE org.apache.lucene_1.9.1.v200706111724
14 ACTIVE org.eclipse.help.appserver_3.1.200.v20070510
15 ACTIVE org.eclipse.help.base_3.3.1.v20070813_33x
16 ACTIVE org.eclipse.help.webapp_3.3.2.v20071102_33x
17 ACTIVE org.eclipse.help_3.3.2.v20071126_33x
18 <<LAZY>> com.ibm.icu_3.8.1.v20080530
21 RESOLVED org.apache.commons.el_1.0.0.v200806031608
25 RESOLVED org.eclipse.core.commands_3.4.0.I20080509-2000
26 <<LAZY>> org.eclipse.core.contenttype_3.3.0.v20080604-1400
27 RESOLVED org.eclipse.core.databinding.beans_1.2.0.I20080915-1800
28 ACTIVE org.eclipse.core.databinding_1.2.0.I20080917-1800
29 ACTIVE org.eclipse.core.expressions_3.4.100.v20080915-0800
30 ACTIVE org.eclipse.core.jobs_3.4.100.v20080825
31 ACTIVE org.eclipse.core.runtime_3.4.100.v20080714
32 ACTIVE org.eclipse.equinox.app_1.2.0.v20080901
34 <<LAZY>> org.eclipse.equinox.http.jetty_1.1.0.v20080425
40 ACTIVE org.eclipse.equinox.preferences_3.2.300.v20080722-0430
41 ACTIVE org.eclipse.equinox.registry_3.4.100.v20080722-0430
42 RESOLVED org.eclipse.equinox.servletbridge.extensionbundle_1.0.0
Master=0
47 RESOLVED org.eclipse.osgi.services_3.1.200.v20071203
50 RESOLVED org.eclipse.rap.jface.databinding_1.2.0.20081118-1809
51 ACTIVE org.eclipse.rap.jface_1.2.0.200811271636
52 RESOLVED org.eclipse.rap.rwt.q07_1.2.0.200811271636
Master=53
53 RESOLVED org.eclipse.rap.rwt_1.2.0.200811271636
Fragments=52
54 ACTIVE org.eclipse.rap.ui.forms_1.2.0.20081118-1809
55 <<LAZY>> org.eclipse.rap.ui.views_1.2.0.20081118-1809
56 ACTIVE org.eclipse.rap.ui.workbench_1.2.0.20081118-1809
57 ACTIVE org.eclipse.rap.ui_1.2.0.20081118-1809
59 RESOLVED org.mortbay.jetty_5.1.14.v200806031611
60 RESOLVED org.ops4j.pax.logging.pax-logging-api_1.1.1

(The effect is the same when I start all of the bundles.)
Re: HelpSystem in Tomcat + WAR [message #114741 is a reply to message #114384] Mon, 08 December 2008 08:43 Go to previous messageGo to next message
Stefan   is currently offline Stefan Friend
Messages: 316
Registered: July 2009
Senior Member
Hi Rainer,

regarding your bundle states: javax.servlet must not be contained in
your war file but is imported from the web app container by the
ServletBridge. This is a common mistake and leads to numerous problems.

To your problem: When you app is running inside Tomcat you have two JSP
handler running: one from tomcat and another one inside you WAR file.
This is OK, but you must take care that each one only handles the JSP
requests it is responsible for.

I'm not familiar with the help system but maybe it is possible to put
all help JSPs in a subdirectory ("help_jsp" below). If so, your JSP
registry could look like this:

<servlet
alias="/help_jsp/*.jsp"
class="org.eclipse.equinox.jsp.jasper.registry.JSPFactory:/jsp "
load-on-startup="true">
</servlet>

I don't know if setting the httpContextId is necessary.

Hope this helps,
Stefan.



Rainer schrieb:
> Hi all,
>
> with the tips from this newsgroup it's easy to get the Eclipse Help
> System running - in the IDE and Jetty as container. Unfortunately a
> deployement in a self-fulfilling WAR under Tomcat seems to require some
> additional steps that are not so obvious ... (for me!)
>
> I've tried to deploy the demo of RÃŒdiger from
> http://www.eclipse.org/newsportal/article.php?id=4912&gr oup=eclipse.technology.rap#4912.
> In the Eclipse-IDE it works fine and under (a stand-alone) Tomcat the
> application itself starts too.
> The problem arises when the application triggers the help sytem with the
> url String helpURL = "http://{0}:{1}/index.jsp". Even though the
> webapp-bundle with the servlet registrations is active (and the
> extension elements are available at runtime - I did a dump) the
> index.jsp is taken from the webapp/ROOT directory, i.e. I see the start
> page of Tomcat.
> Changing the name of the jsp to a unique name (unknown to Tomcat) hoping
> that the registration <servlet
> alias="/*.jsp"
> class="org.eclipse.equinox.jsp.jasper.registry.JSPFactory:/ "
> httpcontextId="help">
> </servlet>
> of the webapp extension would take care for the servlet only leads to a
> "resource not available" HTTP message.
>
> Seems that I haven't found the operative point yet!?! Can anyone give a
> tip what's the missing link?
>
> Many thanks & best regards
> Rainer
>
> Ps: my deployment consists of a WAR with the servletbridge and the
> following bundles where org.eclipse.rap.help.integration_1.0.0 is the
> demo application mentioned above.
>
> osgi> ss
>
> Framework is launched.
>
> id State Bundle
> 0 ACTIVE org.eclipse.osgi_3.5.0.v20080916-2300
> Fragments=42
> 1 ACTIVE org.eclipse.equinox.common_3.4.0.v20080421-2006
> 2 ACTIVE org.eclipse.update.configurator_3.2.101.R33x_v20070810
> 3 ACTIVE
> org.eclipse.equinox.http.servletbridge_1.0.0.v20080427-0830
> 4 ACTIVE
> org.eclipse.equinox.http.registry_1.0.100.v20080427-0830
> 5 ACTIVE org.eclipse.rap.help.integration_1.0.0
> 6 ACTIVE javax.servlet.jsp_2.0.0.v200806031607
> 7 ACTIVE javax.servlet_2.4.0.v200806031604
> 8 ACTIVE org.eclipse.equinox.http.servlet_1.0.100.v20080427-0830
> 9 ACTIVE org.apache.jasper_5.5.17.v200806031609
> 10 ACTIVE
> org.eclipse.equinox.jsp.jasper.registry_1.0.0.v20080427-0830
> 11 ACTIVE org.eclipse.equinox.jsp.jasper_1.0.100.v20080427-0830
> 12 ACTIVE org.apache.lucene.analysis_1.9.1.v200706181610
> 13 ACTIVE org.apache.lucene_1.9.1.v200706111724
> 14 ACTIVE org.eclipse.help.appserver_3.1.200.v20070510
> 15 ACTIVE org.eclipse.help.base_3.3.1.v20070813_33x
> 16 ACTIVE org.eclipse.help.webapp_3.3.2.v20071102_33x
> 17 ACTIVE org.eclipse.help_3.3.2.v20071126_33x
> 18 <<LAZY>> com.ibm.icu_3.8.1.v20080530
> 21 RESOLVED org.apache.commons.el_1.0.0.v200806031608
> 25 RESOLVED org.eclipse.core.commands_3.4.0.I20080509-2000
> 26 <<LAZY>> org.eclipse.core.contenttype_3.3.0.v20080604-1400
> 27 RESOLVED org.eclipse.core.databinding.beans_1.2.0.I20080915-1800
> 28 ACTIVE org.eclipse.core.databinding_1.2.0.I20080917-1800
> 29 ACTIVE org.eclipse.core.expressions_3.4.100.v20080915-0800
> 30 ACTIVE org.eclipse.core.jobs_3.4.100.v20080825
> 31 ACTIVE org.eclipse.core.runtime_3.4.100.v20080714
> 32 ACTIVE org.eclipse.equinox.app_1.2.0.v20080901
> 34 <<LAZY>> org.eclipse.equinox.http.jetty_1.1.0.v20080425
> 40 ACTIVE org.eclipse.equinox.preferences_3.2.300.v20080722-0430
> 41 ACTIVE org.eclipse.equinox.registry_3.4.100.v20080722-0430
> 42 RESOLVED org.eclipse.equinox.servletbridge.extensionbundle_1.0.0
> Master=0
> 47 RESOLVED org.eclipse.osgi.services_3.1.200.v20071203
> 50 RESOLVED org.eclipse.rap.jface.databinding_1.2.0.20081118-1809
> 51 ACTIVE org.eclipse.rap.jface_1.2.0.200811271636
> 52 RESOLVED org.eclipse.rap.rwt.q07_1.2.0.200811271636
> Master=53
> 53 RESOLVED org.eclipse.rap.rwt_1.2.0.200811271636
> Fragments=52
> 54 ACTIVE org.eclipse.rap.ui.forms_1.2.0.20081118-1809
> 55 <<LAZY>> org.eclipse.rap.ui.views_1.2.0.20081118-1809
> 56 ACTIVE org.eclipse.rap.ui.workbench_1.2.0.20081118-1809
> 57 ACTIVE org.eclipse.rap.ui_1.2.0.20081118-1809
> 59 RESOLVED org.mortbay.jetty_5.1.14.v200806031611
> 60 RESOLVED org.ops4j.pax.logging.pax-logging-api_1.1.1
>
> (The effect is the same when I start all of the bundles.)
>
>
Re: HelpSystem in Tomcat + WAR [message #135152 is a reply to message #114384] Fri, 05 June 2009 14:56 Go to previous messageGo to next message
Markus  rüger is currently offline Markus rügerFriend
Messages: 369
Registered: July 2009
Senior Member
Hi,
is there a solution to this? The problem is, that the servlet is defined in
"org.eclipse.help.webapp", so I can not change the registered servlets :-)

Did you solve this Rainer?

Any Ideas?


" Rainer" <rbaumx@googlemail.com> schrieb im Newsbeitrag
news:38d131d02f5199d4363ffd27a061b733$1@www.eclipse.org...
> Hi all,
>
> with the tips from this newsgroup it's easy to get the Eclipse Help System
> running - in the IDE and Jetty as container. Unfortunately a deployement
> in a self-fulfilling WAR under Tomcat seems to require some additional
> steps that are not so obvious ... (for me!)
>
> I've tried to deploy the demo of Rüdiger from
> http://www.eclipse.org/newsportal/article.php?id=4912&gr oup=eclipse.technology.rap#4912.
> In the Eclipse-IDE it works fine and under (a stand-alone) Tomcat the
> application itself starts too.
> The problem arises when the application triggers the help sytem with the
> url String helpURL = "http://{0}:{1}/index.jsp". Even though the
> webapp-bundle with the servlet registrations is active (and the extension
> elements are available at runtime - I did a dump) the index.jsp is taken
> from the webapp/ROOT directory, i.e. I see the start page of Tomcat.
> Changing the name of the jsp to a unique name (unknown to Tomcat) hoping
> that the registration <servlet
> alias="/*.jsp"
> class="org.eclipse.equinox.jsp.jasper.registry.JSPFactory:/ "
> httpcontextId="help">
> </servlet>
> of the webapp extension would take care for the servlet only leads to a
> "resource not available" HTTP message.
>
> Seems that I haven't found the operative point yet!?! Can anyone give a
> tip what's the missing link?
>
> Many thanks & best regards
> Rainer
>
> Ps: my deployment consists of a WAR with the servletbridge and the
> following bundles where org.eclipse.rap.help.integration_1.0.0 is the demo
> application mentioned above.
>
> osgi> ss
>
> Framework is launched.
>
> id State Bundle
> 0 ACTIVE org.eclipse.osgi_3.5.0.v20080916-2300
> Fragments=42
> 1 ACTIVE org.eclipse.equinox.common_3.4.0.v20080421-2006
> 2 ACTIVE org.eclipse.update.configurator_3.2.101.R33x_v20070810
> 3 ACTIVE
> org.eclipse.equinox.http.servletbridge_1.0.0.v20080427-0830
> 4 ACTIVE
> org.eclipse.equinox.http.registry_1.0.100.v20080427-0830
> 5 ACTIVE org.eclipse.rap.help.integration_1.0.0
> 6 ACTIVE javax.servlet.jsp_2.0.0.v200806031607
> 7 ACTIVE javax.servlet_2.4.0.v200806031604
> 8 ACTIVE
> org.eclipse.equinox.http.servlet_1.0.100.v20080427-0830
> 9 ACTIVE org.apache.jasper_5.5.17.v200806031609
> 10 ACTIVE
> org.eclipse.equinox.jsp.jasper.registry_1.0.0.v20080427-0830
> 11 ACTIVE org.eclipse.equinox.jsp.jasper_1.0.100.v20080427-0830
> 12 ACTIVE org.apache.lucene.analysis_1.9.1.v200706181610
> 13 ACTIVE org.apache.lucene_1.9.1.v200706111724
> 14 ACTIVE org.eclipse.help.appserver_3.1.200.v20070510
> 15 ACTIVE org.eclipse.help.base_3.3.1.v20070813_33x
> 16 ACTIVE org.eclipse.help.webapp_3.3.2.v20071102_33x
> 17 ACTIVE org.eclipse.help_3.3.2.v20071126_33x
> 18 <<LAZY>> com.ibm.icu_3.8.1.v20080530
> 21 RESOLVED org.apache.commons.el_1.0.0.v200806031608
> 25 RESOLVED org.eclipse.core.commands_3.4.0.I20080509-2000
> 26 <<LAZY>> org.eclipse.core.contenttype_3.3.0.v20080604-1400
> 27 RESOLVED
> org.eclipse.core.databinding.beans_1.2.0.I20080915-1800
> 28 ACTIVE org.eclipse.core.databinding_1.2.0.I20080917-1800
> 29 ACTIVE org.eclipse.core.expressions_3.4.100.v20080915-0800
> 30 ACTIVE org.eclipse.core.jobs_3.4.100.v20080825
> 31 ACTIVE org.eclipse.core.runtime_3.4.100.v20080714
> 32 ACTIVE org.eclipse.equinox.app_1.2.0.v20080901
> 34 <<LAZY>> org.eclipse.equinox.http.jetty_1.1.0.v20080425
> 40 ACTIVE org.eclipse.equinox.preferences_3.2.300.v20080722-0430
> 41 ACTIVE org.eclipse.equinox.registry_3.4.100.v20080722-0430
> 42 RESOLVED
> org.eclipse.equinox.servletbridge.extensionbundle_1.0.0
> Master=0
> 47 RESOLVED org.eclipse.osgi.services_3.1.200.v20071203
> 50 RESOLVED org.eclipse.rap.jface.databinding_1.2.0.20081118-1809
> 51 ACTIVE org.eclipse.rap.jface_1.2.0.200811271636
> 52 RESOLVED org.eclipse.rap.rwt.q07_1.2.0.200811271636
> Master=53
> 53 RESOLVED org.eclipse.rap.rwt_1.2.0.200811271636
> Fragments=52
> 54 ACTIVE org.eclipse.rap.ui.forms_1.2.0.20081118-1809
> 55 <<LAZY>> org.eclipse.rap.ui.views_1.2.0.20081118-1809
> 56 ACTIVE org.eclipse.rap.ui.workbench_1.2.0.20081118-1809
> 57 ACTIVE org.eclipse.rap.ui_1.2.0.20081118-1809
> 59 RESOLVED org.mortbay.jetty_5.1.14.v200806031611
> 60 RESOLVED org.ops4j.pax.logging.pax-logging-api_1.1.1
>
> (The effect is the same when I start all of the bundles.)
>
>
Re: HelpSystem in Tomcat + WAR [message #135418 is a reply to message #135152] Mon, 08 June 2009 09:32 Go to previous messageGo to next message
Markus  rüger is currently offline Markus rügerFriend
Messages: 369
Registered: July 2009
Senior Member
Anyone can help me? it is pretty urgent... :-(

"Markus Kr
Re: HelpSystem in Tomcat + WAR [message #135824 is a reply to message #135152] Fri, 12 June 2009 08:21 Go to previous messageGo to next message
Rüdiger Herrmann is currently offline Rüdiger HerrmannFriend
Messages: 581
Registered: July 2009
Senior Member
Markus,

I think this has been discussed here before. Please search this
newsgroup for "help in rap", "help system", "help webapp", ...

One note though, I think in the aforementioned example, the URL to
open the help browser is missing the servlet name.

Cheers,
Rüdiger

Markus Krüger wrote:
> Hi,
> is there a solution to this? The problem is, that the servlet is defined in
> "org.eclipse.help.webapp", so I can not change the registered servlets :-)
>
> Did you solve this Rainer?
>
> Any Ideas?
>
>
> " Rainer" <rbaumx@googlemail.com> schrieb im Newsbeitrag
> news:38d131d02f5199d4363ffd27a061b733$1@www.eclipse.org...
>> Hi all,
>>
>> with the tips from this newsgroup it's easy to get the Eclipse Help System
>> running - in the IDE and Jetty as container. Unfortunately a deployement
>> in a self-fulfilling WAR under Tomcat seems to require some additional
>> steps that are not so obvious ... (for me!)
>>
>> I've tried to deploy the demo of Rüdiger from
>> http://www.eclipse.org/newsportal/article.php?id=4912&gr oup=eclipse.technology.rap#4912.
>> In the Eclipse-IDE it works fine and under (a stand-alone) Tomcat the
>> application itself starts too.
>> The problem arises when the application triggers the help sytem with the
>> url String helpURL = "http://{0}:{1}/index.jsp". Even though the
>> webapp-bundle with the servlet registrations is active (and the extension
>> elements are available at runtime - I did a dump) the index.jsp is taken
>> from the webapp/ROOT directory, i.e. I see the start page of Tomcat.
>> Changing the name of the jsp to a unique name (unknown to Tomcat) hoping
>> that the registration <servlet
>> alias="/*.jsp"
>> class="org.eclipse.equinox.jsp.jasper.registry.JSPFactory:/ "
>> httpcontextId="help">
>> </servlet>
>> of the webapp extension would take care for the servlet only leads to a
>> "resource not available" HTTP message.
>>
>> Seems that I haven't found the operative point yet!?! Can anyone give a
>> tip what's the missing link?
>>
>> Many thanks & best regards
>> Rainer
>>
>> Ps: my deployment consists of a WAR with the servletbridge and the
>> following bundles where org.eclipse.rap.help.integration_1.0.0 is the demo
>> application mentioned above.
>>
>> osgi> ss
>>
>> Framework is launched.
>>
>> id State Bundle
>> 0 ACTIVE org.eclipse.osgi_3.5.0.v20080916-2300
>> Fragments=42
>> 1 ACTIVE org.eclipse.equinox.common_3.4.0.v20080421-2006
>> 2 ACTIVE org.eclipse.update.configurator_3.2.101.R33x_v20070810
>> 3 ACTIVE
>> org.eclipse.equinox.http.servletbridge_1.0.0.v20080427-0830
>> 4 ACTIVE
>> org.eclipse.equinox.http.registry_1.0.100.v20080427-0830
>> 5 ACTIVE org.eclipse.rap.help.integration_1.0.0
>> 6 ACTIVE javax.servlet.jsp_2.0.0.v200806031607
>> 7 ACTIVE javax.servlet_2.4.0.v200806031604
>> 8 ACTIVE
>> org.eclipse.equinox.http.servlet_1.0.100.v20080427-0830
>> 9 ACTIVE org.apache.jasper_5.5.17.v200806031609
>> 10 ACTIVE
>> org.eclipse.equinox.jsp.jasper.registry_1.0.0.v20080427-0830
>> 11 ACTIVE org.eclipse.equinox.jsp.jasper_1.0.100.v20080427-0830
>> 12 ACTIVE org.apache.lucene.analysis_1.9.1.v200706181610
>> 13 ACTIVE org.apache.lucene_1.9.1.v200706111724
>> 14 ACTIVE org.eclipse.help.appserver_3.1.200.v20070510
>> 15 ACTIVE org.eclipse.help.base_3.3.1.v20070813_33x
>> 16 ACTIVE org.eclipse.help.webapp_3.3.2.v20071102_33x
>> 17 ACTIVE org.eclipse.help_3.3.2.v20071126_33x
>> 18 <<LAZY>> com.ibm.icu_3.8.1.v20080530
>> 21 RESOLVED org.apache.commons.el_1.0.0.v200806031608
>> 25 RESOLVED org.eclipse.core.commands_3.4.0.I20080509-2000
>> 26 <<LAZY>> org.eclipse.core.contenttype_3.3.0.v20080604-1400
>> 27 RESOLVED
>> org.eclipse.core.databinding.beans_1.2.0.I20080915-1800
>> 28 ACTIVE org.eclipse.core.databinding_1.2.0.I20080917-1800
>> 29 ACTIVE org.eclipse.core.expressions_3.4.100.v20080915-0800
>> 30 ACTIVE org.eclipse.core.jobs_3.4.100.v20080825
>> 31 ACTIVE org.eclipse.core.runtime_3.4.100.v20080714
>> 32 ACTIVE org.eclipse.equinox.app_1.2.0.v20080901
>> 34 <<LAZY>> org.eclipse.equinox.http.jetty_1.1.0.v20080425
>> 40 ACTIVE org.eclipse.equinox.preferences_3.2.300.v20080722-0430
>> 41 ACTIVE org.eclipse.equinox.registry_3.4.100.v20080722-0430
>> 42 RESOLVED
>> org.eclipse.equinox.servletbridge.extensionbundle_1.0.0
>> Master=0
>> 47 RESOLVED org.eclipse.osgi.services_3.1.200.v20071203
>> 50 RESOLVED org.eclipse.rap.jface.databinding_1.2.0.20081118-1809
>> 51 ACTIVE org.eclipse.rap.jface_1.2.0.200811271636
>> 52 RESOLVED org.eclipse.rap.rwt.q07_1.2.0.200811271636
>> Master=53
>> 53 RESOLVED org.eclipse.rap.rwt_1.2.0.200811271636
>> Fragments=52
>> 54 ACTIVE org.eclipse.rap.ui.forms_1.2.0.20081118-1809
>> 55 <<LAZY>> org.eclipse.rap.ui.views_1.2.0.20081118-1809
>> 56 ACTIVE org.eclipse.rap.ui.workbench_1.2.0.20081118-1809
>> 57 ACTIVE org.eclipse.rap.ui_1.2.0.20081118-1809
>> 59 RESOLVED org.mortbay.jetty_5.1.14.v200806031611
>> 60 RESOLVED org.ops4j.pax.logging.pax-logging-api_1.1.1
>>
>> (The effect is the same when I start all of the bundles.)
>>
>>
>
>
Re: HelpSystem in Tomcat + WAR [message #138034 is a reply to message #135824] Thu, 25 June 2009 22:24 Go to previous message
Jorge is currently offline JorgeFriend
Messages: 13
Registered: July 2009
Junior Member
Hi,

Any solution?
I could not find anything useful to resolve this.

Rüdiger Herrmann wrote:

> Markus,

> I think this has been discussed here before. Please search this
> newsgroup for "help in rap", "help system", "help webapp", ...

> One note though, I think in the aforementioned example, the URL to
> open the help browser is missing the servlet name.

> Cheers,
> Rüdiger

> Markus Krüger wrote:
>> Hi,
>> is there a solution to this? The problem is, that the servlet is defined in
>> "org.eclipse.help.webapp", so I can not change the registered servlets :-)
>>
>> Did you solve this Rainer?
>>
>> Any Ideas?
>>
>>
>> " Rainer" <rbaumx@googlemail.com> schrieb im Newsbeitrag
>> news:38d131d02f5199d4363ffd27a061b733$1@www.eclipse.org...
>>> Hi all,
>>>
>>> with the tips from this newsgroup it's easy to get the Eclipse Help System
>>> running - in the IDE and Jetty as container. Unfortunately a deployement
>>> in a self-fulfilling WAR under Tomcat seems to require some additional
>>> steps that are not so obvious ... (for me!)
>>>
>>> I've tried to deploy the demo of RÃŒdiger from
>>>
http://www.eclipse.org/newsportal/article.php?id=4912&gr oup=eclipse.technology.rap#4912.
>>> In the Eclipse-IDE it works fine and under (a stand-alone) Tomcat the
>>> application itself starts too.
>>> The problem arises when the application triggers the help sytem with the
>>> url String helpURL = "http://{0}:{1}/index.jsp". Even though the
>>> webapp-bundle with the servlet registrations is active (and the extension
>>> elements are available at runtime - I did a dump) the index.jsp is taken
>>> from the webapp/ROOT directory, i.e. I see the start page of Tomcat.
>>> Changing the name of the jsp to a unique name (unknown to Tomcat) hoping
>>> that the registration <servlet
>>> alias="/*.jsp"
>>> class="org.eclipse.equinox.jsp.jasper.registry.JSPFactory:/ "
>>> httpcontextId="help">
>>> </servlet>
>>> of the webapp extension would take care for the servlet only leads to a
>>> "resource not available" HTTP message.
>>>
>>> Seems that I haven't found the operative point yet!?! Can anyone give a
>>> tip what's the missing link?
>>>
>>> Many thanks & best regards
>>> Rainer
>>>
>>> Ps: my deployment consists of a WAR with the servletbridge and the
>>> following bundles where org.eclipse.rap.help.integration_1.0.0 is the demo
>>> application mentioned above.
>>>
>>> osgi> ss
>>>
>>> Framework is launched.
>>>
>>> id State Bundle
>>> 0 ACTIVE org.eclipse.osgi_3.5.0.v20080916-2300
>>> Fragments=42
>>> 1 ACTIVE org.eclipse.equinox.common_3.4.0.v20080421-2006
>>> 2 ACTIVE org.eclipse.update.configurator_3.2.101.R33x_v20070810
>>> 3 ACTIVE
>>> org.eclipse.equinox.http.servletbridge_1.0.0.v20080427-0830
>>> 4 ACTIVE
>>> org.eclipse.equinox.http.registry_1.0.100.v20080427-0830
>>> 5 ACTIVE org.eclipse.rap.help.integration_1.0.0
>>> 6 ACTIVE javax.servlet.jsp_2.0.0.v200806031607
>>> 7 ACTIVE javax.servlet_2.4.0.v200806031604
>>> 8 ACTIVE
>>> org.eclipse.equinox.http.servlet_1.0.100.v20080427-0830
>>> 9 ACTIVE org.apache.jasper_5.5.17.v200806031609
>>> 10 ACTIVE
>>> org.eclipse.equinox.jsp.jasper.registry_1.0.0.v20080427-0830
>>> 11 ACTIVE org.eclipse.equinox.jsp.jasper_1.0.100.v20080427-0830
>>> 12 ACTIVE org.apache.lucene.analysis_1.9.1.v200706181610
>>> 13 ACTIVE org.apache.lucene_1.9.1.v200706111724
>>> 14 ACTIVE org.eclipse.help.appserver_3.1.200.v20070510
>>> 15 ACTIVE org.eclipse.help.base_3.3.1.v20070813_33x
>>> 16 ACTIVE org.eclipse.help.webapp_3.3.2.v20071102_33x
>>> 17 ACTIVE org.eclipse.help_3.3.2.v20071126_33x
>>> 18 <<LAZY>> com.ibm.icu_3.8.1.v20080530
>>> 21 RESOLVED org.apache.commons.el_1.0.0.v200806031608
>>> 25 RESOLVED org.eclipse.core.commands_3.4.0.I20080509-2000
>>> 26 <<LAZY>> org.eclipse.core.contenttype_3.3.0.v20080604-1400
>>> 27 RESOLVED
>>> org.eclipse.core.databinding.beans_1.2.0.I20080915-1800
>>> 28 ACTIVE org.eclipse.core.databinding_1.2.0.I20080917-1800
>>> 29 ACTIVE org.eclipse.core.expressions_3.4.100.v20080915-0800
>>> 30 ACTIVE org.eclipse.core.jobs_3.4.100.v20080825
>>> 31 ACTIVE org.eclipse.core.runtime_3.4.100.v20080714
>>> 32 ACTIVE org.eclipse.equinox.app_1.2.0.v20080901
>>> 34 <<LAZY>> org.eclipse.equinox.http.jetty_1.1.0.v20080425
>>> 40 ACTIVE org.eclipse.equinox.preferences_3.2.300.v20080722-0430
>>> 41 ACTIVE org.eclipse.equinox.registry_3.4.100.v20080722-0430
>>> 42 RESOLVED
>>> org.eclipse.equinox.servletbridge.extensionbundle_1.0.0
>>> Master=0
>>> 47 RESOLVED org.eclipse.osgi.services_3.1.200.v20071203
>>> 50 RESOLVED org.eclipse.rap.jface.databinding_1.2.0.20081118-1809
>>> 51 ACTIVE org.eclipse.rap.jface_1.2.0.200811271636
>>> 52 RESOLVED org.eclipse.rap.rwt.q07_1.2.0.200811271636
>>> Master=53
>>> 53 RESOLVED org.eclipse.rap.rwt_1.2.0.200811271636
>>> Fragments=52
>>> 54 ACTIVE org.eclipse.rap.ui.forms_1.2.0.20081118-1809
>>> 55 <<LAZY>> org.eclipse.rap.ui.views_1.2.0.20081118-1809
>>> 56 ACTIVE org.eclipse.rap.ui.workbench_1.2.0.20081118-1809
>>> 57 ACTIVE org.eclipse.rap.ui_1.2.0.20081118-1809
>>> 59 RESOLVED org.mortbay.jetty_5.1.14.v200806031611
>>> 60 RESOLVED org.ops4j.pax.logging.pax-logging-api_1.1.1
>>>
>>> (The effect is the same when I start all of the bundles.)
>>>
>>>
>>
>>
Hi,

Any Solution?
I could not find nothing that can be usefull to solve this in this group.

Regards
Previous Topic:Saving preference for each user
Next Topic:Use DataBinding APIs to update model when contents of Table change
Goto Forum:
  


Current Time: Mon Feb 06 21:04:38 GMT 2023

Powered by FUDForum. Page generated in 0.01582 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top