Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » Test and Performance Tools Platform (TPTP) » EXCEPTION_ACCESS_VIOLATION when running
EXCEPTION_ACCESS_VIOLATION when running [message #110568] Tue, 28 August 2007 20:22 Go to next message
Eclipse UserFriend
Originally posted by: cabaal.yahoo.com

I have searched the web and found no clues. When I attempt to Profile a
local application I get the following error.
Additional Info:
Eclipse Europa
TPTP 4.4.0
JVM 1.5.0_03

Any help would be greatly appreciated. I have used the TPTP before with no
problems. The update to Europa (Clean install) seems to have changed some
things.

#
# An unexpected error has been detected by HotSpot Virtual Machine:
#
# EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x030a6ed9, pid=10160,
tid=11100
#
# Java VM: Java HotSpot(TM) Client VM (1.5.0_03-b07 mixed mode)
# Problematic frame:
# C
#

--------------- T H R E A D ---------------

Current thread (0x007cbbd0): JavaThread "main"

siginfo: ExceptionCode=0xc0000005, reading address 0x00000000

Registers:
EAX=0x03122d50, EBX=0x0311a5e0, ECX=0x00000000, EDX=0x00000002
ESP=0x0006e150, EBP=0x03106a10, ESI=0x00000003, EDI=0x0000000e
EIP=0x030a6ed9, EFLAGS=0x00010206

Top of Stack: (sp=0x0006e150)
0x0006e150: 0000000e 0315f5b0 0000008a 0311a5e0
0x0006e160: 0315f5b0 030bd6e8 00000010 030bbdf3
0x0006e170: 00000010 030aa84e 03122d50 00000002
0x0006e180: 00000000 0315f564 03106a10 0315f570
0x0006e190: 0311e060 03106a10 0315f650 03114dac
0x0006e1a0: 00000000 00000003 0311e088 030aa133
0x0006e1b0: 031065a0 0310b6b4 03107ad0 03130001
0x0006e1c0: 030ddb38 00000035 00000035 03119a30

Instructions: (pc=0x030a6ed9)
0x030a6ec9: 24 1c 53 55 8b e9 56 8b 48 08 8b 30 57 8b 78 04
0x030a6ed9: 8b 19 8b 4d 44 52 50 e8 db 0a 00 00 8d 44 24 18


Stack:

Java frames: (J=compiled Java code, j=interpreted, Vv=VM code)
j
java.lang.ClassLoader.defineClass1(Ljava/lang/String;
0x366d4b08 JavaThread "CompilerThread0" daemon
0x00829b98 JavaThread "Signal Dispatcher" daemon
0x008bfd30 JavaThread "Finalizer" daemon
0x00814868 JavaThread "Reference Handler" daemon
=>0x007cbbd0 JavaThread "main"

Other Threads:
0x0082f768 VMThread [id=10796]
0x366d7c20 WatcherThread [id=10444]

VM state:not at safepoint (normal execution)

VM Mutex/Monitor currently owned by a thread: None

Heap
def new generation total 36288K, used 3226K [0x12250000, 0x149b0000,
0x149b0000)
eden space 32256K, 10% used [0x12250000, 0x12576898, 0x141d0000)
from space 4032K, 0% used [0x141d0000, 0x141d0000, 0x145c0000)
to space 4032K, 0% used [0x145c0000, 0x145c0000, 0x149b0000)
tenured generation total 483968K, used 0K [0x149b0000, 0x32250000,
0x32250000)
the space 483968K, 0% used [0x149b0000, 0x149b0000, 0x149b0200,
0x32250000)
compacting perm gen total 8192K, used 3504K [0x32250000, 0x32a50000,
0x36250000)
the space 8192K, 42% used [0x32250000, 0x325bc0b0, 0x325bc200,
0x32a50000)
No shared spaces configured.

Dynamic libraries:
0x00400000 - 0x0040c000 D:\Java\jdk1.5.0_03\jre\bin\java.exe
0x77f80000 - 0x77ffc000 C:\WINNT\system32\ntdll.dll
0x7c2d0000 - 0x7c335000 C:\WINNT\system32\ADVAPI32.dll
0x7c570000 - 0x7c624000 C:\WINNT\system32\KERNEL32.dll
0x77d30000 - 0x77d9f000 C:\WINNT\system32\RPCRT4.dll
0x78000000 - 0x78045000 C:\WINNT\system32\MSVCRT.dll
0x6d6b0000 - 0x6d836000 D:\Java\jdk1.5.0_03\jre\bin\client\jvm.dll
0x77e10000 - 0x77e6f000 C:\WINNT\system32\USER32.dll
0x77f40000 - 0x77f7c000 C:\WINNT\system32\GDI32.dll
0x77570000 - 0x775a0000 C:\WINNT\system32\WINMM.dll
0x10000000 - 0x10011000 C:\WINNT\system32\AMINIT.dll
0x6d2f0000 - 0x6d2f8000 D:\Java\jdk1.5.0_03\jre\bin\hpi.dll
0x690a0000 - 0x690ab000 C:\WINNT\system32\PSAPI.DLL
0x008e0000 - 0x008f9000
D:\eclipse\plugins\org.eclipse.tptp.platform.jvmti.runtime_4 .4.0.v200708010927\agent_files\win_ia32\JPIBootLoader.dll
0x00900000 - 0x0090b000
D:\eclipse\plugins\org.eclipse.tptp.platform.jvmti.runtime_4 .4.0.v200708010927\agent_files\win_ia32\MartiniOSA.dll
0x00b30000 - 0x00b6d000
D:\eclipse\plugins\org.eclipse.tptp.platform.jvmti.runtime_4 .4.0.v200708010927\agent_files\win_ia32\JPI.dll
0x01b40000 - 0x01b61000
D:\eclipse\plugins\org.eclipse.tptp.platform.jvmti.runtime_4 .4.0.v200708010927\agent_files\win_ia32\JPIAgent.dll
0x01d80000 - 0x01da2000
D:\eclipse\plugins\org.eclipse.tptp.platform.jvmti.runtime_4 .4.0.v200708010927\agent_files\win_ia32\CGProf.dll
0x01ec0000 - 0x01ed9000
D:\eclipse\plugins\org.eclipse.tptp.platform.jvmti.runtime_4 .4.0.v200708010927\agent_files\win_ia32\ACCollector.dll
0x01ee0000 - 0x01efe000
D:\eclipse\plugins\org.eclipse.tptp.platform.ac.win_ia32_4.4 .0.v200706020100\agent_controller\bin\AgentBase.dll
0x01f00000 - 0x01f0d000
D:\eclipse\plugins\org.eclipse.tptp.platform.ac.win_ia32_4.4 .0.v200706020100\agent_controller\bin\transportSupport.dll
0x75030000 - 0x75044000 C:\WINNT\system32\WS2_32.dll
0x75020000 - 0x75028000 C:\WINNT\system32\WS2HELP.DLL
0x01f10000 - 0x01f37000
D:\eclipse\plugins\org.eclipse.tptp.platform.ac.win_ia32_4.4 .0.v200706020100\agent_controller\bin\tptpUtils.dll
0x12000000 - 0x12241000
D:\eclipse\plugins\org.eclipse.tptp.platform.ac.win_ia32_4.4 .0.v200706020100\agent_controller\bin\xerces-c_2_6.dll
0x01f40000 - 0x01f50000
D:\eclipse\plugins\org.eclipse.tptp.platform.ac.win_ia32_4.4 .0.v200706020100\agent_controller\bin\hcclco.dll
0x01f50000 - 0x01f60000
D:\eclipse\plugins\org.eclipse.tptp.platform.ac.win_ia32_4.4 .0.v200706020100\agent_controller\bin\hcclsm.dll
0x01f60000 - 0x01f77000
D:\eclipse\plugins\org.eclipse.tptp.platform.ac.win_ia32_4.4 .0.v200706020100\agent_controller\bin\tptpConfig.dll
0x01f80000 - 0x01f8c000
D:\eclipse\plugins\org.eclipse.tptp.platform.ac.win_ia32_4.4 .0.v200706020100\agent_controller\bin\processControlUtil.dll
0x01f90000 - 0x01f9c000
D:\eclipse\plugins\org.eclipse.tptp.platform.ac.win_ia32_4.4 .0.v200706020100\agent_controller\bin\tptpLogUtils.dll
0x02f60000 - 0x02f6e000
D:\eclipse\plugins\org.eclipse.tptp.platform.jvmti.runtime_4 .4.0.v200708010927\agent_files\win_ia32\CGAdaptor.dll
0x03080000 - 0x030e6000
D:\eclipse\plugins\org.eclipse.tptp.platform.jvmti.runtime_4 .4.0.v200708010927\agent_files\win_ia32\JIE.dll
0x6d680000 - 0x6d68c000 D:\Java\jdk1.5.0_03\jre\bin\verify.dll
0x6d370000 - 0x6d38d000 D:\Java\jdk1.5.0_03\jre\bin\java.dll
0x6d6a0000 - 0x6d6af000 D:\Java\jdk1.5.0_03\jre\bin\zip.dll

VM Arguments:
jvm_args: -Xms512m -Xmx512m
-agentlib:JPIBootLoader=JPIAgent:server=controlled;CGProf
java_command: com.ngc.aks.esi.process.agent.ProcessLauncher
PROCESS_CONTROL_SERVICE Process Control Service -1

Environment Variables:
JAVA_HOME=d:\Java\jdk1.5.0_03\
PATH=D:\eclipse\plugins\org.eclipse.tptp.platform.ac.win_ia3 2_4.4.0.v200706020100\agent_controller\bin;D:\Java\jdk1.5.0_ 03\jre\bin\java.exe;D:\eclipse\plugins\org.eclipse.tptp.plat form.jvmti.runtime_4.4.0.v200708010927\agent_files\win_ia32; D:\eclipse\plugins\org.eclipse.tptp.platform.ac.win_ia32_4.4 .0.v200706020100\agent_controller\bin;D:\eclipse\plugins\org .eclipse.hyades.probekit_4.2.200.v200705210100\os\win32\x86; D:\eclipse\plugins\org.eclipse.tptp.platform.ac.win_ia32_4.4 .0.v200706020100\agent_controller\bin;D:\eclipse\plugins\org .eclipse.tptp.platform.ac.win_ia32_4.4.0.v200706020100\agent _controller\bin;d:\Java\jdk1.5.0_03\bin\..\jre\bin\client;d: \Java\jdk1.5.0_03\bin\..\jre\bin;C:\Perl\site\bin;C:\Perl\bi n;.;d:\Java\jdk1.5.0_03\bin;d:\oracle\ora92\bin;D:\Cygwin\bi n;C:\WINNT\SYSTEM32;C:\WINNT;C:\WINNT\SYSTEM32\WBEM;C:\DMI\W IN32\BIN;D:\apache-ant-1.7.0\bin;C:\Program
Files\PGP;D:\XMLEDI~1\XRay;D:\XMLBeans\xmlbeans-2.0.0-beta1\ bin;C:\Program
Files\ActivIdentity\ActivClient
Mini\;D:\xmlbeans-2.2.0\bin;D:\maven-2.0.5\bin;MULE_HOME\bin ;C:\Program
Files\QuickTime\QTSystem\;d:\Sun\jwsdp-2.0\jwsdp-shared\bin
USERNAME=administrator
OS=Windows_NT
PROCESSOR_IDENTIFIER=x86 Family 15 Model 2 Stepping 7, GenuineIntel


--------------- S Y S T E M ---------------

OS: Windows 2000 Build 2195 Service Pack 4

CPU:total 1 family 15, cmov, cx8, fxsr, mmx, sse, sse2, ht

Memory: 4k page, physical 2096120k(651988k free), swap 3506040k(1668768k
free)

vm_info: Java HotSpot(TM) Client VM (1.5.0_03-b07) for windows-x86, built
on Apr 13 2005 02:07:01 by "java_re" with MS VC++ 6.0
Re: EXCEPTION_ACCESS_VIOLATION when running [message #110642 is a reply to message #110568] Wed, 29 August 2007 07:16 Go to previous messageGo to next message
Asaf Yaffe is currently offline Asaf YaffeFriend
Messages: 333
Registered: July 2009
Senior Member
Brad,

Is this problem fully reproducible (e.g, happens all the time)?

Can you please enable the JVMTI Profiler logging (see instructions here:
http://dev.eclipse.org/newslists/news.eclipse.tptp/msg03235. html) and
post the generated log file?

Note that the pluginconfig.xml file you need to edit is located in
D:\eclipse\plugins\org.eclipse.tptp.platform.jvmti.runtime_4 .4.0.v200708010927\agent_files\win_ia32\config
on your machine.

Thanks,
Asaf

--
Asaf Yaffe
Eclipse TPTP Committer, JVMTI Profiler
Re: EXCEPTION_ACCESS_VIOLATION when running [message #110694 is a reply to message #110642] Wed, 29 August 2007 18:23 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: cabaal.yahoo.com

A few pieces of information I forgot to include:
1) I am using the IAC
2) The problem is fully reproducible. It occurs every time I attempt to
profile my application.


I tried to enable the logging per your message, but nothing seems to work.
Here is the pluginconfig.xml from the win_ia32/config directory you
specified:


<PluginConfiguration>
<AgentControllerEnvironment configuration="default">
<Variable name="JAVA_PROFILER_HOME" position="replace"
value="%PLUGINS_HOME%\org.eclipse.tptp.javaprofiler" />
<Variable name="MARTINI_LOGGER_DIRECTORY" position="replace"
value="%JAVA_PROFILER_HOME%\log" />
<Variable name="MARTINI_LOGGER_LOG_LEVEL" position="replace" value="5" />
<Variable name="PATH" position="prepend" value="%RASERVER_HOME%\bin"
/>
<Variable name="PATH" position="prepend" value="%JAVA_PROFILER_HOME%"
/>
<Variable name="PATH" position="prepend" value="%JAVA_PATH%" />
<Variable name="CLASSPATH" position="prepend"
value="%JAVA_PROFILER_HOME%" />
</AgentControllerEnvironment>
<Option name="org.eclipse.tptp.javaprofiler" type="version"
value="4.2.0" />
</PluginConfiguration>


I tried restarting the IAC, Eclipse, and finaly Eclipse with a -clean
specified. Nothing seems to generate a log file.
Updated the JRE, same problem [message #110704 is a reply to message #110642] Wed, 29 August 2007 19:57 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: cabaal.yahoo.com

Because I am at a loss as to what to do I updated the JRE. The same error
occurs.


#
# An unexpected error has been detected by HotSpot Virtual Machine:
#
# EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x02f96ed9, pid=11240,
tid=11732
#
# Java VM: Java HotSpot(TM) Client VM (1.5.0_12-b04 mixed mode)
# Problematic frame:
# C [JIE.dll+0x26ed9]
A different error [message #110717 is a reply to message #110642] Wed, 29 August 2007 20:15 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: cabaal.yahoo.com

Yet more info.
I attempted to Profile a different application. One that only has one
class and a simple Main to read in some XML.
When I run the eclipse log, located in the workspace/.metadata folder has
the following error:

--------------------------------------------------
!ENTRY org.eclipse.hyades.trace.ui 4 4 2007-08-29 13:09:23.912
!MESSAGE A time-out occurred while attempting to launch the process
!STACK 1
org.eclipse.core.runtime.CoreException: A time-out occurred while
attempting to launch the process
at
org.eclipse.tptp.trace.ui.internal.launcher.core.LauncherUti lity.createCoreException(LauncherUtility.java:123)
at
org.eclipse.tptp.trace.ui.internal.launcher.core.LauncherUti lity.createCoreException(LauncherUtility.java:131)
at
org.eclipse.tptp.platform.jvmti.client.internal.launcher.TID elegateHelper.handleError(TIDelegateHelper.java:596)
at
org.eclipse.tptp.platform.jvmti.client.internal.launcher.TID elegateHelper.launchProcess(TIDelegateHelper.java:512)
at
org.eclipse.tptp.platform.jvmti.client.internal.launcher.TID elegateHelper.launch(TIDelegateHelper.java:312)
at
org.eclipse.tptp.platform.jvmti.client.internal.launcher.TIJ avaLauncherDelegate.launch(TIJavaLauncherDelegate.java:37)
at
org.eclipse.tptp.trace.ui.internal.launcher.core.LauncherUti lity.delegateInit(LauncherUtility.java:1153)
at
org.eclipse.tptp.trace.ui.provisional.launcher.PrimaryLaunch Delegate.run(PrimaryLaunchDelegate.java:196)
at java.lang.Thread.run(Thread.java:595)
!SUBENTRY 1 org.eclipse.hyades.trace.ui 4 0 2007-08-29 13:09:23.912
!MESSAGE A time-out occurred while attempting to launch the process
---------------------------------------------------

I thought it might be that the IAC wasn't running, but I tested the
connection in the preferences for Profiling and Logging. The connection
was successful. In addition I checked the processes on my system and sure
enough the AC is running as a child of Eclipse.

Just trying to give you as much as possible to work with since I couldn't
figure out the log.
Re: EXCEPTION_ACCESS_VIOLATION when running [message #110775 is a reply to message #110694] Thu, 30 August 2007 13:26 Go to previous messageGo to next message
Asaf Yaffe is currently offline Asaf YaffeFriend
Messages: 333
Registered: July 2009
Senior Member
Hi Brad,

Have you created the "log" directory in the location specified by the
MARTINI_LOGGER_DIRECTORY variable?

Would it be possible for you to share your Java application so we can
investigate this crash?

Thanks,
Asaf

Brad wrote:
> A few pieces of information I forgot to include:
> 1) I am using the IAC
> 2) The problem is fully reproducible. It occurs every time I attempt to
> profile my application.
>
> I tried to enable the logging per your message, but nothing seems to
> work. Here is the pluginconfig.xml from the win_ia32/config directory
> you specified:
>
>
> <PluginConfiguration>
> <AgentControllerEnvironment configuration="default">
> <Variable name="JAVA_PROFILER_HOME" position="replace"
> value="%PLUGINS_HOME%\org.eclipse.tptp.javaprofiler" />
> <Variable name="MARTINI_LOGGER_DIRECTORY" position="replace"
> value="%JAVA_PROFILER_HOME%\log" />
> <Variable name="MARTINI_LOGGER_LOG_LEVEL" position="replace"
> value="5" />
> <Variable name="PATH" position="prepend"
> value="%RASERVER_HOME%\bin" /> <Variable name="PATH"
> position="prepend" value="%JAVA_PROFILER_HOME%" /> <Variable
> name="PATH" position="prepend" value="%JAVA_PATH%" /> <Variable
> name="CLASSPATH" position="prepend" value="%JAVA_PROFILER_HOME%" />
> </AgentControllerEnvironment>
> <Option name="org.eclipse.tptp.javaprofiler" type="version"
> value="4.2.0" /> </PluginConfiguration>
>
>
> I tried restarting the IAC, Eclipse, and finaly Eclipse with a -clean
> specified. Nothing seems to generate a log file.
>


--
Asaf Yaffe
Eclipse TPTP Committer, JVMTI Profiler
Re: A different error [message #110786 is a reply to message #110717] Thu, 30 August 2007 13:31 Go to previous messageGo to next message
Asaf Yaffe is currently offline Asaf YaffeFriend
Messages: 333
Registered: July 2009
Senior Member
Brad,

This is a different issue. The newsgroup is filled with questions about
this (and sadly not too many answers). I think there is a Bugzilla open
for this.

Thanks,
Asaf

--
Asaf Yaffe
Eclipse TPTP Committer, JVMTI Profiler
Re: A different error [message #110841 is a reply to message #110786] Thu, 30 August 2007 21:54 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: cabaal.yahoo.com

This problem went away when I switched machines. I haven't been able to
figure out why.
Re: EXCEPTION_ACCESS_VIOLATION when running [message #110851 is a reply to message #110775] Thu, 30 August 2007 21:58 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: cabaal.yahoo.com

Yes, I created the directory in my eclipse install folder under
eclipse/plugins/org.eclipse.tptp.javaprofiler/log

I also created the log folder under various other places that I thought
may work (I was at a loss). Nothing seems to work.

Unfortunately I cannot post my application. It is proprietary company
info. I wish I could.
Re: A different error [message #110863 is a reply to message #110841] Fri, 31 August 2007 07:26 Go to previous messageGo to next message
Igor Alelekov is currently offline Igor AlelekovFriend
Messages: 139
Registered: July 2009
Senior Member
Hi Brad,
Hope this problem will be solved with the
https://bugs.eclipse.org/bugs/show_bug.cgi?id=201443 fix.
Regards,
Igor
Re: EXCEPTION_ACCESS_VIOLATION when running [message #112022 is a reply to message #110851] Sun, 09 September 2007 12:14 Go to previous message
Asaf Yaffe is currently offline Asaf YaffeFriend
Messages: 333
Registered: July 2009
Senior Member
Brad wrote:
> Yes, I created the directory in my eclipse install folder under
> eclipse/plugins/org.eclipse.tptp.javaprofiler/log
>
> I also created the log folder under various other places that I thought
> may work (I was at a loss). Nothing seems to work.
> Unfortunately I cannot post my application. It is proprietary company
> info. I wish I could.

Can you please try to define the MARTINI_LOGGER* variables as "global"
system variables in Windows (using the option in the Computer Properties
screen) and then reproduce the problem? Make sure that
MARTINI_LOGGER_DIRECTORY points to an existing directory on your local
hard drive.

Thanks,
Asaf

--
Asaf Yaffe
Eclipse TPTP Committer, JVMTI Profiler
Previous Topic:'recorder' tptp distibutive/pack?
Next Topic:Profiler Crashes w/ no error msg
Goto Forum:
  


Current Time: Thu Jun 27 08:06:06 GMT 2019

Powered by FUDForum. Page generated in 0.02062 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top