Skip to main content

Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Gemini » Gemini, JMS, Spring, Weblogic(Problem in sending message from a bundle to queue on Weblogic 92)
icon9.gif  Gemini, JMS, Spring, Weblogic [message #856718] Wed, 25 April 2012 23:27 Go to next message
Pouyan Vatan. is currently offline Pouyan Vatan.Friend
Messages: 2
Registered: April 2012
Junior Member
I have developed an OSGI application using the following technology
- Embedding OSGi in Tomcat(Gemini)
- Spring (NOT SpringDM)
- Vaadin
- Hibernate
One of the Bundle that I have is JMS client which is supposed to send an a message to a JMS queue which it is on Weblogic 9.2 server.
The main application (which is a WAR file) is installed/deployed as bundle on OSGI framework (Gemini) as well.
There is no issue in installing the bundles and running the application but, in application, when i tired to send mms message to WL server, I get the following error:

weblogic.utils.AssertionError: ***** ASSERTION FAILED *****
at weblogic.rjvm.ConnectionManager.readPeerInfo(
at weblogic.rjvm.ConnectionManagerClient.handleIdentifyResponse(
at weblogic.rjvm.ConnectionManager.dispatch(
at weblogic.rjvm.MsgAbbrevJVMConnection.dispatch(
at weblogic.rjvm.t3.MuxableSocketT3.dispatch(
at weblogic.socket.BaseAbstractMuxableSocket.dispatch(
at weblogic.socket.SocketMuxer.readReadySocketOnce(
at weblogic.socket.SocketMuxer.readReadySocket(
at weblogic.socket.JavaSocketMuxer.processSockets(
at weblogic.kernel.ExecuteThread.execute(
Caused by: java.lang.ClassNotFoundException: Failed to load class weblogic.common.internal.PeerInfo
at weblogic.rmi.utils.WLRMIClassLoaderDelegate.loadClass(
at weblogic.rmi.utils.WLRMIClassLoaderDelegate.loadClass(
at weblogic.rmi.utils.Utilities.loadClass(
at weblogic.rjvm.MsgAbbrevInputStream.resolveClass(
at weblogic.rjvm.ConnectionManager.readPeerInfo(
... 12 more

javax.naming.CommunicationException [Root exception is t3:// Bootstrap to localhost/ failed. It is likely that the remote side declared peer gone on this JVM]
at weblogic.jndi.internal.ExceptionTranslator.toNamingException(
at weblogic.jndi.WLInitialContextFactoryDelegate.toNamingException(
at weblogic.jndi.WLInitialContextFactoryDelegate.getInitialContext(
at weblogic.jndi.Environment.getContext(
at weblogic.jndi.Environment.getContext(
at weblogic.jndi.Environment.createInitialContext(
at weblogic.jndi.Environment.getInitialContext(
at weblogic.jndi.Environment.getInitialContext(
at com.zenithss.together.modules.jms.helper.JmsSender.sendMessage(
at com.zenithss.together.modules.jms.views.JmsCommandView$RunListener.buttonClick(
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(
at sun.reflect.DelegatingMethodAccessorImpl.invoke(
at java.lang.reflect.Method.invoke(
at com.vaadin.event.ListenerMethod.receiveEvent(
at com.vaadin.event.EventRouter.fireEvent(
at com.vaadin.ui.AbstractComponent.fireEvent(
at com.vaadin.ui.Button.fireClick(
at com.vaadin.ui.Button.changeVariables(
at com.vaadin.terminal.gwt.server.AbstractCommunicationManager.changeVariables(
at com.vaadin.terminal.gwt.server.AbstractCommunicationManager.handleVariableBurst(
at com.vaadin.terminal.gwt.server.AbstractCommunicationManager.handleVariables(
at com.vaadin.terminal.gwt.server.AbstractCommunicationManager.doHandleUidlRequest(
at com.vaadin.terminal.gwt.server.CommunicationManager.handleUidlRequest(
at com.vaadin.terminal.gwt.server.AbstractApplicationServlet.service(
at javax.servlet.http.HttpServlet.service(
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(
at org.apache.catalina.core.ApplicationFilterChain.doFilter(
at org.apache.catalina.core.StandardWrapperValve.invoke(
at org.apache.catalina.core.StandardContextValve.invoke(
at org.apache.catalina.authenticator.AuthenticatorBase.invoke(
at org.apache.catalina.core.StandardHostValve.invoke(
at org.apache.catalina.valves.ErrorReportValve.invoke(
at org.apache.catalina.core.StandardEngineValve.invoke(
at org.apache.catalina.connector.CoyoteAdapter.service(
at org.apache.coyote.http11.Http11Processor.process(
at org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process(
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(
at java.util.concurrent.ThreadPoolExecutor$
Caused by: t3:// Bootstrap to localhost/ failed. It is likely that the remote side declared peer gone on this JVM
at weblogic.rjvm.RJVMFinder.findOrCreateInternal(
at weblogic.rjvm.RJVMFinder.findOrCreate(
at weblogic.rjvm.ServerURL.findOrCreateRJVM(
at weblogic.jndi.WLInitialContextFactoryDelegate.getInitialContext(
... 38 more
Caused by: java.rmi.ConnectException: Bootstrap to localhost/ failed. It is likely that the remote side declared peer gone on this JVM
at weblogic.rjvm.ConnectionManager.bootstrap(
at weblogic.rjvm.RJVMManager.findOrCreateRemoteInternal(
at weblogic.rjvm.RJVMManager.findOrCreate(
at weblogic.rjvm.RJVMFinder.findOrCreateRemoteServer(
at weblogic.rjvm.RJVMFinder.findOrCreateInternal(
... 41 more

NOTE1: I have a same version of JDK on both servers. As you can see the application and WL9.2 server are on the same machine (localhost) so JDK is the same
NOTE2: I have " localhost" in my /etc/hosts
NOTE3: I have "localhost" as Listen Address on Weblogic
It's been one month that I am stocked in this issue. any help would be appreciated !

Re: Gemini, JMS, Spring, Weblogic [message #857499 is a reply to message #856718] Thu, 26 April 2012 15:39 Go to previous messageGo to next message
Pouyan Vatan. is currently offline Pouyan Vatan.Friend
Messages: 2
Registered: April 2012
Junior Member
Hi Again,

Also I want to mention that , I developed a Simple Java Application to send a message to the queue on the sever. When I run it, everything works fine and I am able to send the message, but when run the OSGI App. and my JMS module/bundle, i get that exception.
The code in JMS module/bundle is almost exactly the same as my the sample (java application).


[Updated on: Thu, 26 April 2012 15:39]

Report message to a moderator

Re: Gemini, JMS, Spring, Weblogic [message #857557 is a reply to message #857499] Thu, 26 April 2012 16:52 Go to previous messageGo to next message
Violeta Georgieva is currently offline Violeta GeorgievaFriend
Messages: 278
Registered: October 2010
Senior Member

- Embedding OSGi in Tomcat(Gemini)

Actually Gemini Web is Tomcat embedded in OSGi environment and not OSGi embedded in Tomcat.

I found posts for similar problems

May be you should play a bit with the "Listen Address" value.

Re: Gemini, JMS, Spring, Weblogic [message #1015946 is a reply to message #857499] Mon, 04 March 2013 11:36 Go to previous message
pree srini is currently offline pree sriniFriend
Messages: 4
Registered: March 2013
Junior Member
I am also facing the same issue.Is it resolved now?
Previous Topic:LocalBundleContextAdvice not serializable exception
Next Topic:[Solved]Proxy could not create EMF....
Goto Forum:

Current Time: Fri Dec 01 17:36:11 GMT 2023

Powered by FUDForum. Page generated in 0.02105 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top