Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » Using joined Dataset twice
Using joined Dataset twice [message #856221] Wed, 25 April 2012 13:32 Go to next message
Thomas P. is currently offline Thomas P.Friend
Messages: 25
Registered: April 2012
Junior Member
Hello,

I want to use a joined dataset for two tables in one report. I have two datasets joined together. Than I have added two tables to the report. I assigned the joined dataset to both tables, but if i ran the report it only shows the data in the first table, the second ist empty.
There is no "resultsetclosed-error" in the console.
If I delete the first table, the data in the second table will be allright.

So, couldn't I use one Dataset for two Tables? Is there a way to do it?
I use Birt 3.7.1.v20110905

Thomas


Thomas
Re: Using joined Dataset twice [message #856446 is a reply to message #856221] Wed, 25 April 2012 17:07 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason WeathersbyFriend
Messages: 9167
Registered: July 2009
Senior Member

What is your data source? Attached is an example that works with the
sample db.

Jason

On 4/25/2012 9:32 AM, Thomas Plorin wrote:
> Hello,
>
> I want to use a joined dataset for two tables in one report. I have two
> datasets joined together. Than I have added two tables to the report. I
> assigned the joined dataset to both tables, but if i ran the report it
> only shows the data in the first table, the second ist empty. There is
> no "resultsetclosed-error" in the console. If I delete the first table,
> the data in the second table will be allright.
>
> So, couldn't I use one Dataset for two Tables? Is there a way to do it?
> I use Birt 3.7.1.v20110905
>
> Thomas
  • Attachment: jointds.zip
    (Size: 4.20KB, Downloaded 126 times)
Re: Using joined Dataset twice [message #856997 is a reply to message #856446] Thu, 26 April 2012 06:42 Go to previous message
Thomas P. is currently offline Thomas P.Friend
Messages: 25
Registered: April 2012
Junior Member
thats right, i checked it with csv datasource and it works.
I use an own database driver which uses POJOs as "tables". I think
there must be an error in this code.
Thank you

Thomas


Thomas
Previous Topic:Converting BIRT reports or Upgrade
Next Topic:Concatenating logfiles as datasource based on report parameters
Goto Forum:
  


Current Time: Fri Jan 24 16:34:57 GMT 2020

Powered by FUDForum. Page generated in 0.01294 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top