Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Equinox » Replacing a bundle from an installed feature
Replacing a bundle from an installed feature [message #109204] Tue, 06 May 2008 21:18 Go to next message
Stephan Herrmann is currently offline Stephan HerrmannFriend
Messages: 1837
Registered: July 2009
Senior Member
Hi,

We have a feature that provides a replacement for org.eclipse.jdt.core.
For doing so we use a version number that adds 1000 to the minor version
of the original jdt.core and count our own version from there.

This approach worked in 3.0 through 3.3.

However, in 3.4M7, installing our features fails with the following message:

Can't find a solution where both: Match[requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.jdt.core/[3.1024.0.OTD T,3.1024.0.OTDT]] and Match[requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.jdt.core/[3.4.0.v_858, 3.4.0.v_858]] would be satisfied.
Can't find a solution where both: Match[requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.jdt.core/[3.1024.0.OTD T,3.1024.0.OTDT]] and Match[requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.jdt.core/[3.4.0.v_858, 3.4.0.v_858]] would be satisfied.
Can't find a solution where both: Match[requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.jdt.core/[3.1024.0.OTD T,3.1024.0.OTDT]] and Match[requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.jdt.core/[3.4.0.v_858, 3.4.0.v_858]] would be satisfied.
Can't find a solution where both: Match[requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.jdt.core/[3.1024.0.OTD T,3.1024.0.OTDT]] and Match[requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.jdt.core/[3.4.0.v_858, 3.4.0.v_858]] would be satisfied.
Unsatisfied dependency: [org.eclipse.sdk.ide 3.4.0.I20080502-0100] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.sdk.feature.group/[3.4 .0.v20080430a-7M7S-BIAlsaTyJM3wfC1lyDjSJz07kSz0bllKuz-Nm_i7, 3.4.0.v20080430a-7M7S-BIAlsaTyJM3wfC1lyDjSJz07kSz0bllKuz-Nm_ i7]
Unsatisfied dependency: [org.eclipse.sdk.feature.group 3.4.0.v20080430a-7M7S-BIAlsaTyJM3wfC1lyDjSJz07kSz0bllKuz-Nm_ i7] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.pde.feature.group/[3.4 .0.v20080430a-7U7U-E_HlNXnS9jCEl2YL3322,3.4.0.v20080430a-7U7 U-E_HlNXnS9jCEl2YL3322]
Unsatisfied dependency: [org.eclipse.sdk.feature.group 3.4.0.v20080430a-7M7S-BIAlsaTyJM3wfC1lyDjSJz07kSz0bllKuz-Nm_ i7] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.jdt.feature.group/[3.4 .0.v20080430-0100-7o7tEAXEFpPqmwXZ67BUqkd,3.4.0.v20080430-01 00-7o7tEAXEFpPqmwXZ67BUqkd]
Unsatisfied dependency: [org.eclipse.pde.feature.group 3.4.0.v20080430a-7U7U-E_HlNXnS9jCEl2YL3322] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.jdt.feature.group/[3.0 .0,4.0.0)
Unsatisfied dependency: [org.eclipse.jdt.feature.group 3.4.0.v20080430-0100-7o7tEAXEFpPqmwXZ67BUqkd] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.jdt.core/[3.4.0.v_858, 3.4.0.v_858]

In this situation org.eclipse.jdt.core_3.1024.0.OTDT is the
updated version that is (supposedly) fully compatible with 3.4.0.v_858.

The above is when using p2 for installation. Using the classic update manager,
the feature is partially installed (thus not usable), i.e., the files are put
into the features and plugins directories but "About Eclipse SDK Plug-ins"
does not show the replacement nor plugins depending on it.

What is the proper way in Eclipse 3.4 to replace a single bundle that is
referenced by an installed feature by a newer version??

thanks

--
Stephan Herrmann
Re: Replacing a bundle from an installed feature [message #109670 is a reply to message #109204] Wed, 14 May 2008 02:43 Go to previous message
Pascal Rapicault is currently offline Pascal RapicaultFriend
Messages: 333
Registered: July 2009
Location: Ottawa
Senior Member
This issue is being tracked in
https://bugs.eclipse.org/bugs/show_bug.cgi?id=222945

"Stephan Herrmann" <stephan@cs.tu-berlin.de> wrote in message
news:fvqhs6$i2t$1@build.eclipse.org...
> Hi,
>
> We have a feature that provides a replacement for org.eclipse.jdt.core.
> For doing so we use a version number that adds 1000 to the minor version
> of the original jdt.core and count our own version from there.
>
> This approach worked in 3.0 through 3.3.
>
> However, in 3.4M7, installing our features fails with the following
> message:
>
> Can't find a solution where both: Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.jdt.core/[3.1024.0.OTD T,3.1024.0.OTDT]]
> and Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.jdt.core/[3.4.0.v_858, 3.4.0.v_858]]
> would be satisfied.
> Can't find a solution where both: Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.jdt.core/[3.1024.0.OTD T,3.1024.0.OTDT]]
> and Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.jdt.core/[3.4.0.v_858, 3.4.0.v_858]]
> would be satisfied.
> Can't find a solution where both: Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.jdt.core/[3.1024.0.OTD T,3.1024.0.OTDT]]
> and Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.jdt.core/[3.4.0.v_858, 3.4.0.v_858]]
> would be satisfied.
> Can't find a solution where both: Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.jdt.core/[3.1024.0.OTD T,3.1024.0.OTDT]]
> and Match[requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.jdt.core/[3.4.0.v_858, 3.4.0.v_858]]
> would be satisfied.
> Unsatisfied dependency: [org.eclipse.sdk.ide 3.4.0.I20080502-0100]
> requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.sdk.feature.group/[3.4 .0.v20080430a-7M7S-BIAlsaTyJM3wfC1lyDjSJz07kSz0bllKuz-Nm_i7, 3.4.0.v20080430a-7M7S-BIAlsaTyJM3wfC1lyDjSJz07kSz0bllKuz-Nm_ i7]
> Unsatisfied dependency: [org.eclipse.sdk.feature.group
> 3.4.0.v20080430a-7M7S-BIAlsaTyJM3wfC1lyDjSJz07kSz0bllKuz-Nm_ i7]
> requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.pde.feature.group/[3.4 .0.v20080430a-7U7U-E_HlNXnS9jCEl2YL3322,3.4.0.v20080430a-7U7 U-E_HlNXnS9jCEl2YL3322]
> Unsatisfied dependency: [org.eclipse.sdk.feature.group
> 3.4.0.v20080430a-7M7S-BIAlsaTyJM3wfC1lyDjSJz07kSz0bllKuz-Nm_ i7]
> requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.jdt.feature.group/[3.4 .0.v20080430-0100-7o7tEAXEFpPqmwXZ67BUqkd,3.4.0.v20080430-01 00-7o7tEAXEFpPqmwXZ67BUqkd]
> Unsatisfied dependency: [org.eclipse.pde.feature.group
> 3.4.0.v20080430a-7U7U-E_HlNXnS9jCEl2YL3322] requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.jdt.feature.group/[3.0 .0,4.0.0)
> Unsatisfied dependency: [org.eclipse.jdt.feature.group
> 3.4.0.v20080430-0100-7o7tEAXEFpPqmwXZ67BUqkd] requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.jdt.core/[3.4.0.v_858, 3.4.0.v_858]
>
> In this situation org.eclipse.jdt.core_3.1024.0.OTDT is the
> updated version that is (supposedly) fully compatible with 3.4.0.v_858.
>
> The above is when using p2 for installation. Using the classic update
> manager,
> the feature is partially installed (thus not usable), i.e., the files are
> put
> into the features and plugins directories but "About Eclipse SDK Plug-ins"
> does not show the replacement nor plugins depending on it.
>
> What is the proper way in Eclipse 3.4 to replace a single bundle that is
> referenced by an installed feature by a newer version??
>
> thanks
>
> --
> Stephan Herrmann
Previous Topic:self-provisioning
Next Topic:Class loading issues with RCP app
Goto Forum:
  


Current Time: Sat Oct 23 01:24:20 GMT 2021

Powered by FUDForum. Page generated in 0.01724 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top