Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » GMF (Graphical Modeling Framework) » drag and drop with link and attributes(i can't find how to drag and drop a class with links and attributes)
drag and drop with link and attributes [message #849765] Thu, 19 April 2012 12:35 Go to next message
maxime r is currently offline maxime rFriend
Messages: 6
Registered: April 2012
Junior Member
Hello,
I have some problems with drag and drop, I followed this article jevon.org/wiki/GMF_Drag_Drop
it work but when I drag and drop 2 class with a link between them, the link and attributes not appear.

Does someone have a solution? I read a lot about this but I did not get the solution.
I'm quiet new and at this moment I just had to use the dashboard and the GUI provided.

Thanks a lot,
Maxime
Re: drag and drop with link and attributes [message #853731 is a reply to message #849765] Mon, 23 April 2012 09:31 Go to previous message
maxime r is currently offline maxime rFriend
Messages: 6
Registered: April 2012
Junior Member
Hi,
Perhaps it's not very clear I will try to explain more.
What I want to do is, with one model, have many diagrams and after drag and drop object from my model into a diagram file. I succeed to do this, when I did that:

1. Set .gmfgen > Editor > Diagram > Contains Shortcuts To to all of the file extensions that contain the elements you want to be able to create shortcuts to.
2. Set .gmfgen > Editor > Diagram > Shortcuts Provided For to all the Model IDs (.gmfgen > Editor > Editor > Model ID) that you'd like this component to provide shortcut functionality to.

And I set gmfgen-> editor -> diagram editpart -> synchronized : to false.

But now when I drag and drop an object which has link with other object and attributes, I just see the object... without link and attributes.


I tried to find differences between my project and the org.eclipse.emf.ecoretools project.
To begin, I don't understand why in the org.eclipse.emf.ecoretools project in the file gmfgen-> editor -> diagram editpart -> synchronized is set to true, how is it possible to have many diagrams and just one model in emftools?

There are so many changes between projects, can somebody tell me where should I begin to look to solve my problem?
Thanks in advance!
Maxime
Previous Topic:The relationship between EditParts and DiagramGlobalActionHandler?
Next Topic:GMF deploying problems --Please help--
Goto Forum:
  


Current Time: Sun Oct 25 00:37:19 GMT 2020

Powered by FUDForum. Page generated in 0.02026 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top