Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF "Technology" (Ecore Tools, EMFatic, etc)  » [Ecore Tools] Error by EMFT
[Ecore Tools] Error by EMFT [message #107479] Thu, 17 January 2008 14:45 Go to next message
Thomas Roland is currently offline Thomas RolandFriend
Messages: 36
Registered: July 2009
Member
According to Ed Merks suggestion, I put the prefix to my question and put
my question here again:

I create an Ecore project first. Then I create an ecorediag file. Further,
after I've created some classes on the diagram and as I using the mouse to
organize their locations, all the class box junp to the top-left corner
and I can't more them anymore.

P.S.: Ho wcan I attach a screenshot?
Re: [Ecore Tools] Error by EMFT [message #107492 is a reply to message #107479] Thu, 17 January 2008 14:54 Go to previous messageGo to next message
Thomas Roland is currently offline Thomas RolandFriend
Messages: 36
Registered: July 2009
Member
More details to my question:

I do as follow:
1.
Create an Ecore Project by going to "File -> New -> Other -> Ecore Project"
2.
Create an Ecore Diagram by going to "File -> New -> Other -> Ecore Diagram"
3.
Clcik the EClass on the Toolbar and click on the Editor Area, a class box
is placed there
4.
Then I try to move this class box anywhere but it jumps to the top-left
corner and can not be moved anymore.

There is nothing to see in the Error Log View.
Re: [Ecore Tools] Error by EMFT [message #107756 is a reply to message #107492] Mon, 21 January 2008 17:29 Go to previous messageGo to next message
Jacques LESCOT is currently offline Jacques LESCOTFriend
Messages: 247
Registered: July 2009
Senior Member
Thomas,

Did you solve your problem ? We tried this on a MacOSX computer and did
not get such a weird behavior. Any further information is welcomed.

Regards,
Jacques

thomas2004 a écrit :
> More details to my question:
>
> I do as follow:
> 1.
> Create an Ecore Project by going to "File -> New -> Other -> Ecore Project"
> 2.
> Create an Ecore Diagram by going to "File -> New -> Other -> Ecore Diagram"
> 3.
> Clcik the EClass on the Toolbar and click on the Editor Area, a class
> box is placed there
> 4.
> Then I try to move this class box anywhere but it jumps to the top-left
> corner and can not be moved anymore.
>
> There is nothing to see in the Error Log View.
>
>
>
Re: [Ecore Tools] Error by EMFT [message #108292 is a reply to message #107756] Fri, 25 January 2008 17:17 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: tom.eiswind.de

HI,

I see the same problem. Have it on win32, whenever I try to move a class
it snaps to the upper left corner and cannot be moved from there. Also
the Package snaps to a small rectangle and cant be moved or resized.
Theres nothing on the error log, nothing in the eclipse log. I really
would like to use the editor, but so far I dont have a chance.

Regards Thomas

Jacques LESCOT schrieb:
> Thomas,
>
> Did you solve your problem ? We tried this on a MacOSX computer and did
> not get such a weird behavior. Any further information is welcomed.
>
> Regards,
> Jacques
>
> thomas2004 a écrit :
>> More details to my question:
>>
>> I do as follow:
>> 1.
>> Create an Ecore Project by going to "File -> New -> Other -> Ecore
>> Project"
>> 2.
>> Create an Ecore Diagram by going to "File -> New -> Other -> Ecore
>> Diagram"
>> 3.
>> Clcik the EClass on the Toolbar and click on the Editor Area, a class
>> box is placed there
>> 4.
>> Then I try to move this class box anywhere but it jumps to the
>> top-left corner and can not be moved anymore.
>>
>> There is nothing to see in the Error Log View.
>>
>>
>>
Re: [Ecore Tools] Error by EMFT [message #108575 is a reply to message #108292] Mon, 28 January 2008 08:27 Go to previous messageGo to next message
Jacques LESCOT is currently offline Jacques LESCOTFriend
Messages: 247
Registered: July 2009
Senior Member
We really need more informations :

1. Is it possible to send us your erroneous files ?
2. Which EcoreTools version are you using ? What about dependencies
(EMF, GMF ?)

Bests,
Jacques

Thomas a écrit :
> HI,
>
> I see the same problem. Have it on win32, whenever I try to move a class
> it snaps to the upper left corner and cannot be moved from there. Also
> the Package snaps to a small rectangle and cant be moved or resized.
> Theres nothing on the error log, nothing in the eclipse log. I really
> would like to use the editor, but so far I dont have a chance.
>
> Regards Thomas
>
> Jacques LESCOT schrieb:
>> Thomas,
>>
>> Did you solve your problem ? We tried this on a MacOSX computer and
>> did not get such a weird behavior. Any further information is welcomed.
>>
>> Regards,
>> Jacques
>>
>> thomas2004 a écrit :
>>> More details to my question:
>>>
>>> I do as follow:
>>> 1.
>>> Create an Ecore Project by going to "File -> New -> Other -> Ecore
>>> Project"
>>> 2.
>>> Create an Ecore Diagram by going to "File -> New -> Other -> Ecore
>>> Diagram"
>>> 3.
>>> Clcik the EClass on the Toolbar and click on the Editor Area, a class
>>> box is placed there
>>> 4.
>>> Then I try to move this class box anywhere but it jumps to the
>>> top-left corner and can not be moved anymore.
>>>
>>> There is nothing to see in the Error Log View.
>>>
>>>
>>>
Re: [Ecore Tools] Error by EMFT [message #109229 is a reply to message #108575] Tue, 29 January 2008 18:05 Go to previous message
Eclipse UserFriend
Originally posted by: tom.eiswind.de

Hi Jacques,

I have the same issue when I try to use the ediagram editor from the emf
examples, all the same behaviour. I will file a bug on this.

https://bugs.eclipse.org/bugs/show_bug.cgi?id=216942

I guess its a gmf bug.

Thomas


Jacques LESCOT schrieb:
> We really need more informations :
>
> 1. Is it possible to send us your erroneous files ?
> 2. Which EcoreTools version are you using ? What about dependencies
> (EMF, GMF ?)
>
> Bests,
> Jacques
>
> Thomas a écrit :
>> HI,
>>
>> I see the same problem. Have it on win32, whenever I try to move a
>> class it snaps to the upper left corner and cannot be moved from
>> there. Also the Package snaps to a small rectangle and cant be moved
>> or resized. Theres nothing on the error log, nothing in the eclipse
>> log. I really would like to use the editor, but so far I dont have a
>> chance.
>>
>> Regards Thomas
>>
>> Jacques LESCOT schrieb:
>>> Thomas,
>>>
>>> Did you solve your problem ? We tried this on a MacOSX computer and
>>> did not get such a weird behavior. Any further information is welcomed.
>>>
>>> Regards,
>>> Jacques
>>>
>>> thomas2004 a écrit :
>>>> More details to my question:
>>>>
>>>> I do as follow:
>>>> 1.
>>>> Create an Ecore Project by going to "File -> New -> Other -> Ecore
>>>> Project"
>>>> 2.
>>>> Create an Ecore Diagram by going to "File -> New -> Other -> Ecore
>>>> Diagram"
>>>> 3.
>>>> Clcik the EClass on the Toolbar and click on the Editor Area, a
>>>> class box is placed there
>>>> 4.
>>>> Then I try to move this class box anywhere but it jumps to the
>>>> top-left corner and can not be moved anymore.
>>>>
>>>> There is nothing to see in the Error Log View.
>>>>
>>>>
>>>>
Re: [Ecore Tools] Error by EMFT [message #614033 is a reply to message #107479] Thu, 17 January 2008 14:54 Go to previous message
Thomas Roland is currently offline Thomas RolandFriend
Messages: 36
Registered: July 2009
Member
More details to my question:

I do as follow:
1.
Create an Ecore Project by going to "File -> New -> Other -> Ecore Project"
2.
Create an Ecore Diagram by going to "File -> New -> Other -> Ecore Diagram"
3.
Clcik the EClass on the Toolbar and click on the Editor Area, a class box
is placed there
4.
Then I try to move this class box anywhere but it jumps to the top-left
corner and can not be moved anymore.

There is nothing to see in the Error Log View.
Re: [Ecore Tools] Error by EMFT [message #614053 is a reply to message #107492] Mon, 21 January 2008 17:29 Go to previous message
Jacques LESCOT is currently offline Jacques LESCOTFriend
Messages: 247
Registered: July 2009
Senior Member
Thomas,

Did you solve your problem ? We tried this on a MacOSX computer and did
not get such a weird behavior. Any further information is welcomed.

Regards,
Jacques

thomas2004 a écrit :
> More details to my question:
>
> I do as follow:
> 1.
> Create an Ecore Project by going to "File -> New -> Other -> Ecore Project"
> 2.
> Create an Ecore Diagram by going to "File -> New -> Other -> Ecore Diagram"
> 3.
> Clcik the EClass on the Toolbar and click on the Editor Area, a class
> box is placed there
> 4.
> Then I try to move this class box anywhere but it jumps to the top-left
> corner and can not be moved anymore.
>
> There is nothing to see in the Error Log View.
>
>
>
Re: [Ecore Tools] Error by EMFT [message #614090 is a reply to message #107756] Fri, 25 January 2008 17:17 Go to previous message
Thomas is currently offline ThomasFriend
Messages: 151
Registered: July 2009
Senior Member
HI,

I see the same problem. Have it on win32, whenever I try to move a class
it snaps to the upper left corner and cannot be moved from there. Also
the Package snaps to a small rectangle and cant be moved or resized.
Theres nothing on the error log, nothing in the eclipse log. I really
would like to use the editor, but so far I dont have a chance.

Regards Thomas

Jacques LESCOT schrieb:
> Thomas,
>
> Did you solve your problem ? We tried this on a MacOSX computer and did
> not get such a weird behavior. Any further information is welcomed.
>
> Regards,
> Jacques
>
> thomas2004 a écrit :
>> More details to my question:
>>
>> I do as follow:
>> 1.
>> Create an Ecore Project by going to "File -> New -> Other -> Ecore
>> Project"
>> 2.
>> Create an Ecore Diagram by going to "File -> New -> Other -> Ecore
>> Diagram"
>> 3.
>> Clcik the EClass on the Toolbar and click on the Editor Area, a class
>> box is placed there
>> 4.
>> Then I try to move this class box anywhere but it jumps to the
>> top-left corner and can not be moved anymore.
>>
>> There is nothing to see in the Error Log View.
>>
>>
>>
Re: [Ecore Tools] Error by EMFT [message #614109 is a reply to message #108292] Mon, 28 January 2008 08:27 Go to previous message
Jacques LESCOT is currently offline Jacques LESCOTFriend
Messages: 247
Registered: July 2009
Senior Member
We really need more informations :

1. Is it possible to send us your erroneous files ?
2. Which EcoreTools version are you using ? What about dependencies
(EMF, GMF ?)

Bests,
Jacques

Thomas a écrit :
> HI,
>
> I see the same problem. Have it on win32, whenever I try to move a class
> it snaps to the upper left corner and cannot be moved from there. Also
> the Package snaps to a small rectangle and cant be moved or resized.
> Theres nothing on the error log, nothing in the eclipse log. I really
> would like to use the editor, but so far I dont have a chance.
>
> Regards Thomas
>
> Jacques LESCOT schrieb:
>> Thomas,
>>
>> Did you solve your problem ? We tried this on a MacOSX computer and
>> did not get such a weird behavior. Any further information is welcomed.
>>
>> Regards,
>> Jacques
>>
>> thomas2004 a écrit :
>>> More details to my question:
>>>
>>> I do as follow:
>>> 1.
>>> Create an Ecore Project by going to "File -> New -> Other -> Ecore
>>> Project"
>>> 2.
>>> Create an Ecore Diagram by going to "File -> New -> Other -> Ecore
>>> Diagram"
>>> 3.
>>> Clcik the EClass on the Toolbar and click on the Editor Area, a class
>>> box is placed there
>>> 4.
>>> Then I try to move this class box anywhere but it jumps to the
>>> top-left corner and can not be moved anymore.
>>>
>>> There is nothing to see in the Error Log View.
>>>
>>>
>>>
Re: [Ecore Tools] Error by EMFT [message #614159 is a reply to message #108575] Tue, 29 January 2008 18:05 Go to previous message
Thomas is currently offline ThomasFriend
Messages: 151
Registered: July 2009
Senior Member
Hi Jacques,

I have the same issue when I try to use the ediagram editor from the emf
examples, all the same behaviour. I will file a bug on this.

https://bugs.eclipse.org/bugs/show_bug.cgi?id=216942

I guess its a gmf bug.

Thomas


Jacques LESCOT schrieb:
> We really need more informations :
>
> 1. Is it possible to send us your erroneous files ?
> 2. Which EcoreTools version are you using ? What about dependencies
> (EMF, GMF ?)
>
> Bests,
> Jacques
>
> Thomas a écrit :
>> HI,
>>
>> I see the same problem. Have it on win32, whenever I try to move a
>> class it snaps to the upper left corner and cannot be moved from
>> there. Also the Package snaps to a small rectangle and cant be moved
>> or resized. Theres nothing on the error log, nothing in the eclipse
>> log. I really would like to use the editor, but so far I dont have a
>> chance.
>>
>> Regards Thomas
>>
>> Jacques LESCOT schrieb:
>>> Thomas,
>>>
>>> Did you solve your problem ? We tried this on a MacOSX computer and
>>> did not get such a weird behavior. Any further information is welcomed.
>>>
>>> Regards,
>>> Jacques
>>>
>>> thomas2004 a écrit :
>>>> More details to my question:
>>>>
>>>> I do as follow:
>>>> 1.
>>>> Create an Ecore Project by going to "File -> New -> Other -> Ecore
>>>> Project"
>>>> 2.
>>>> Create an Ecore Diagram by going to "File -> New -> Other -> Ecore
>>>> Diagram"
>>>> 3.
>>>> Clcik the EClass on the Toolbar and click on the Editor Area, a
>>>> class box is placed there
>>>> 4.
>>>> Then I try to move this class box anywhere but it jumps to the
>>>> top-left corner and can not be moved anymore.
>>>>
>>>> There is nothing to see in the Error Log View.
>>>>
>>>>
>>>>
Previous Topic:[CDO] java.lang.NoClassDefFoundError: org/eclipse/emf/cdo/client/internal/ClientActivator
Next Topic:[Compare] How to compare ecore models, content types
Goto Forum:
  


Current Time: Sun Sep 20 05:02:09 GMT 2020

Powered by FUDForum. Page generated in 0.02485 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top