Skip to main content

Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EGit / JGit » egit ssh failure
egit ssh failure [message #830558] Tue, 27 March 2012 19:56 Go to next message
J Cantara is currently offline J CantaraFriend
Messages: 1
Registered: March 2012
Junior Member

I just downloaded Eclipse yesterday, and installed the Egit plugin (or add-on, not sure the terminology yet). I set it up what I believe is correctly (using git over ssh), but I get disconnected upon trying to connect to my git server. I don't have the exact error in front of me; but it was very simple and nondescript, something like "exception when executing ls-remote". The error I have on the server side of things is as follows:

Accepted publickey for git from ip.addr.addr.addr port 1024 ssh2
pam_unix(sshd:session): session opened for user git by (uid=0)
channel_by_id: 0: bad id: channel free
Disconnecting: Received data for nonexistent channel 0.
pam_unix(sshd:session): session closed for user git

So it looks like it is accepting the ssh key, and making the connection properly; but then the "nonexistent channel" error, I don't know what to do about. There's very little on google about it as well. It looks like eclipse uses Jsch for ssh internally - but I can't find a way to update that specifically, it doesn't appear to be a plugin or anything. I tried the "stable" Egit, and then the "bleeding edge" one as well; both with the same result.

I don't know what other information would be useful for me to provide - I am an eclipse newbie, so please be gentle Smile The version of eclipse is "classic" and whatever was available yesterday (2012-03-26) on the website.

More notes: client machine where eclipse is installed is Win7-64. Git server is Ubuntu 10.04 with openssh.

Further notes: this git repo is known-working otherwise.

[Updated on: Tue, 27 March 2012 20:19]

Report message to a moderator

Re: egit ssh failure [message #878506 is a reply to message #830558] Tue, 29 May 2012 13:04 Go to previous messageGo to next message
Andy Fletcher is currently offline Andy FletcherFriend
Messages: 1
Registered: May 2012
Junior Member
Did you get anywhere with this? I'm seeing the exact same problem.
Re: egit ssh failure [message #892465 is a reply to message #878506] Thu, 28 June 2012 10:20 Go to previous messageGo to next message
Matthias Sohn is currently offline Matthias SohnFriend
Messages: 1138
Registered: July 2009
Senior Member
If you suspect your problem is caused by a bug in JSch you may try to update it
to the latest version available from the latest Orbit repository
EGit's repository doesn't include JSch but relies on the version installed
with the platform.
Re: egit ssh failure [message #1595056 is a reply to message #892465] Sat, 31 January 2015 18:56 Go to previous message
Fabio Almeida is currently offline Fabio AlmeidaFriend
Messages: 1
Registered: January 2015
Junior Member
I know this is a very old thread, but I'll reply anyway, since people coming from search engines may arrive at this page looking for answers. In my case, the problem was being caused by the account not having a valid system shell specified in /etc/passwd.
Previous Topic:is there any way to pull a subdirectory from a git repo using jGit
Next Topic:See the git commands that are executed by the EGit GUI?
Goto Forum:

Current Time: Sat May 30 05:44:31 GMT 2020

Powered by FUDForum. Page generated in 0.01781 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top