Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » charts in BIRT reports
charts in BIRT reports [message #824313] Mon, 19 March 2012 14:23 Go to next message
Chris Houben is currently offline Chris HoubenFriend
Messages: 15
Registered: November 2011
Junior Member
Hi,

I'm new with birt (using v2.6.2). I'm trying to deploy a simple project to a WASCE 3.0.
My data is getting loaded correctly but my charts are giving errors.

What is missing in my project? Can somebody push me in the right direction to find the problem?

WARNING: Exception
Throwable occurred: org.eclipse.emf.ecore.resource.Resource$IOWrappedException: Package with uri siteOfEclipse/Char tModel' not found. (file:///C:/IBM/SDP/test.chart, 1, 314)
	at org.eclipse.emf.ecore.xmi.impl.XMLLoadImpl.handleErrors(XMLLoadImpl.java:83)
	at org.eclipse.emf.ecore.xmi.impl.XMLLoadImpl.load(XMLLoadImpl.java:191)
	at org.eclipse.emf.ecore.xmi.impl.XMLResourceImpl.doLoad(XMLResourceImpl.java:180)
	at org.eclipse.emf.ecore.resource.impl.ResourceImpl.load(ResourceImpl.java:1494)
	at org.eclipse.birt.chart.model.impl.SerializerImpl.fromXml(SerializerImpl.java:465)
	at org.eclipse.birt.chart.reportitem.ChartReportItemImpl.deserialize(ChartReportItemImpl.java:293)
	at org.eclipse.birt.report.model.extension.PeerExtensibilityProvider.initializeReportItem(PeerExtensibilityProvider.java:580)
	at org.eclipse.birt.report.model.elements.ExtendedItem.initializeReportItem(ExtendedItem.java:307)
	at org.eclipse.birt.report.model.elements.ExtendedItem.doCheck(ExtendedItem.java:642)
	at org.eclipse.birt.report.model.elements.ExtendedItem.checkCompatibility(ExtendedItem.java:604)
	at org.eclipse.birt.report.model.parser.ModuleParserHandler.handleExtendedItemCompatibility(ModuleParserHandler.java:455)
	at org.eclipse.birt.report.model.parser.ModuleParserHandler.endDocument(ModuleParserHandler.java:417)
	at org.apache.xerces.parsers.AbstractSAXParser.endDocument(Unknown Source)
	at org.apache.xerces.impl.XMLDocumentScannerImpl.endEntity(Unknown Source)
	at org.apache.xerces.impl.XMLEntityManager.endEntity(Unknown Source)
	at org.apache.xerces.impl.XMLEntityScanner.load(Unknown Source)
	at org.apache.xerces.impl.XMLEntityScanner.skipSpaces(Unknown Source)
	at org.apache.xerces.impl.XMLDocumentScannerImpl$TrailingMiscDispatcher.dispatch(Unknown Source)
	at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl.scanDocument(Unknown Source)
	at org.apache.xerces.parsers.XML11Configuration.parse(Unknown Source)
	at org.apache.xerces.parsers.XML11Configuration.parse(Unknown Source)
	at org.apache.xerces.parsers.XMLParser.parse(Unknown Source)
	at org.apache.xerces.parsers.AbstractSAXParser.parse(Unknown Source)
	at org.apache.xerces.jaxp.SAXParserImpl$JAXPSAXParser.parse(Unknown Source)
	at org.apache.xerces.jaxp.SAXParserImpl.parse(Unknown Source)
	at org.eclipse.birt.report.model.parser.ModuleReader.readModule(ModuleReader.java:97)
	at org.eclipse.birt.report.model.parser.DesignReader.read(DesignReader.java:88)
	at org.eclipse.birt.report.model.core.DesignSessionImpl.openDesign(DesignSessionImpl.java:315)
	at org.eclipse.birt.report.model.api.SessionHandleImpl.openDesign(SessionHandleImpl.java:294)
	at org.eclipse.birt.report.engine.parser.ReportParser.getDesignHandle(ReportParser.java:158)
	at org.eclipse.birt.report.engine.api.impl.ReportEngineHelper.getReportDesignHandle(ReportEngineHelper.java:255)
	at org.eclipse.birt.report.engine.api.impl.ReportEngineHelper.openReportDesign(ReportEngineHelper.java:274)
	at org.eclipse.birt.report.engine.api.impl.ReportEngine.openReportDesign(ReportEngine.java:601)
	at org.eclipse.birt.report.service.ReportEngineService.openReportDesign(ReportEngineService.java:387)
	at org.eclipse.birt.report.utility.BirtUtility.getRunnableFromDesignFile(BirtUtility.java:607)
	at org.eclipse.birt.report.context.ViewerAttributeBean.getDesignHandle(ViewerAttributeBean.java:641)
	at org.eclipse.birt.report.context.ViewerAttributeBean.__init(ViewerAttributeBean.java:224)
	at org.eclipse.birt.report.context.BaseAttributeBean.init(BaseAttributeBean.java:233)
	at org.eclipse.birt.report.context.ViewerAttributeBean.<init>(ViewerAttributeBean.java:118)
	at org.eclipse.birt.report.context.BirtContext.__init(BirtContext.java:44)
	at org.eclipse.birt.report.context.BaseContext.<init>(BaseContext.java:69)
	at org.eclipse.birt.report.servlet.ViewerServlet.__getContext(ViewerServlet.java:150)
	at org.eclipse.birt.report.servlet.BirtSoapMessageDispatcherServlet.doPost(BirtSoapMessageDispatcherServlet.java:243)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:595)
	at org.apache.axis.transport.http.AxisServletBase.service(AxisServletBase.java:327)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:668)
	at org.eclipse.birt.report.servlet.BirtSoapMessageDispatcherServlet.service(BirtSoapMessageDispatcherServlet.java:122)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:304)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:210)
	at org.eclipse.birt.report.filter.ViewerFilter.doFilter(ViewerFilter.java:68)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:243)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:210)
	at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:224)
	at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:175)
	at org.apache.geronimo.tomcat.GeronimoStandardContext$SystemMethodValve.invoke(GeronimoStandardContext.java:819)
	at org.apache.geronimo.tomcat.valve.GeronimoBeforeAfterValve.invoke(GeronimoBeforeAfterValve.java:48)
	at org.apache.geronimo.tomcat.valve.ProtectedTargetValve.invoke(ProtectedTargetValve.java:53)
	at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:164)
	at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:100)
	at org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:851)
	at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:118)
	at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:405)
	at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:278)
	at org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process(AbstractProtocol.java:515)
	at org.apache.tomcat.util.net.JIoEndpoint$SocketProcessor.run(JIoEndpoint.java:302)
	at org.apache.geronimo.pool.ThreadPool$1.run(ThreadPool.java:243)
	at org.apache.geronimo.pool.ThreadPool$ContextClassLoaderRunnable.run(ThreadPool.java:373)
	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:897)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:919)
	at java.lang.Thread.run(Thread.java:736)
Caused by: org.eclipse.emf.ecore.xmi.PackageNotFoundException: Package with uri 'siteOfEclipse/ChartModel' not found. (file:///C:/IBM/SDP/test.chart, 1, 314)
	at org.eclipse.emf.ecore.xmi.impl.XMLHandler.getPackageForURI(XMLHandler.java:2591)
	at org.eclipse.emf.ecore.xmi.impl.XMLHandler.getFactoryForPrefix(XMLHandler.java:2422)
	at org.eclipse.emf.ecore.xmi.impl.XMLHandler.createObjectByType(XMLHandler.java:1299)
	at org.eclipse.emf.ecore.xmi.impl.XMLHandler.createTopObject(XMLHandler.java:1468)
	at org.eclipse.emf.ecore.xmi.impl.XMLHandler.processElement(XMLHandler.java:1019)
	at org.eclipse.emf.ecore.xmi.impl.XMLHandler.startElement(XMLHandler.java:1001)
	at org.eclipse.emf.ecore.xmi.impl.XMLHandler.startElement(XMLHandler.java:712)
	at org.apache.xerces.parsers.AbstractSAXParser.startElement(Unknown Source)
	at org.apache.xerces.impl.dtd.XMLDTDValidator.startElement(Unknown Source)
	at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl.scanStartElement(Unknown Source)
	at org.apache.xerces.impl.XMLDocumentScannerImpl$ContentDispatcher.scanRootElementHook(Unknown Source)
	at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl$FragmentContentDispatcher.dispatch(Unknown Source)
	at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl.scanDocument(Unknown Source)
	at org.apache.xerces.parsers.XML11Configuration.parse(Unknown Source)
	at org.apache.xerces.parsers.XML11Configuration.parse(Unknown Source)
	at org.apache.xerces.parsers.XMLParser.parse(Unknown Source)
	at org.apache.xerces.parsers.AbstractSAXParser.parse(Unknown Source)
	at org.apache.xerces.jaxp.SAXParserImpl$JAXPSAXParser.parse(Unknown Source)
	at org.apache.xerces.jaxp.SAXParserImpl.parse(Unknown Source)
	at org.eclipse.emf.ecore.xmi.impl.XMLLoadImpl.load(XMLLoadImpl.java:181)
	... 68 more


Thanks,

Chris
Re: charts in BIRT reports [message #824418 is a reply to message #824313] Mon, 19 March 2012 16:36 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason WeathersbyFriend
Messages: 9167
Registered: July 2009
Senior Member

How are you deploying? This looks like you are only using the chart engine.

Jason

On 3/19/2012 10:23 AM, Chris Houben wrote:
> Hi,
>
> I'm new with birt (using v2.6.2). I'm trying to deploy a simple project
> to a WASCE 3.0.
> My data is getting loaded correctly but my charts are giving errors.
>
> What is missing in my project? Can somebody push me in the right
> direction to find the problem?
>
> WARNING: Exception
> Throwable occurred:
> org.eclipse.emf.ecore.resource.Resource$IOWrappedException: Package with
> uri siteOfEclipse/Char tModel' not found.
> (file:///C:/IBM/SDP/test.chart, 1, 314)
> at
> org.eclipse.emf.ecore.xmi.impl.XMLLoadImpl.handleErrors(XMLLoadImpl.java:83)
>
> at org.eclipse.emf.ecore.xmi.impl.XMLLoadImpl.load(XMLLoadImpl.java:191)
> at
> org.eclipse.emf.ecore.xmi.impl.XMLResourceImpl.doLoad(XMLResourceImpl.java:180)
>
> at
> org.eclipse.emf.ecore.resource.impl.ResourceImpl.load(ResourceImpl.java:1494)
>
> at
> org.eclipse.birt.chart.model.impl.SerializerImpl.fromXml(SerializerImpl.java:465)
>
> at
> org.eclipse.birt.chart.reportitem.ChartReportItemImpl.deserialize(ChartReportItemImpl.java:293)
>
> at
> org.eclipse.birt.report.model.extension.PeerExtensibilityProvider.initializeReportItem(PeerExtensibilityProvider.java:580)
>
> at
> org.eclipse.birt.report.model.elements.ExtendedItem.initializeReportItem(ExtendedItem.java:307)
>
> at
> org.eclipse.birt.report.model.elements.ExtendedItem.doCheck(ExtendedItem.java:642)
>
> at
> org.eclipse.birt.report.model.elements.ExtendedItem.checkCompatibility(ExtendedItem.java:604)
>
> at
> org.eclipse.birt.report.model.parser.ModuleParserHandler.handleExtendedItemCompatibility(ModuleParserHandler.java:455)
>
> at
> org.eclipse.birt.report.model.parser.ModuleParserHandler.endDocument(ModuleParserHandler.java:417)
>
> at org.apache.xerces.parsers.AbstractSAXParser.endDocument(Unknown Source)
> at org.apache.xerces.impl.XMLDocumentScannerImpl.endEntity(Unknown Source)
> at org.apache.xerces.impl.XMLEntityManager.endEntity(Unknown Source)
> at org.apache.xerces.impl.XMLEntityScanner.load(Unknown Source)
> at org.apache.xerces.impl.XMLEntityScanner.skipSpaces(Unknown Source)
> at
> org.apache.xerces.impl.XMLDocumentScannerImpl$TrailingMiscDispatcher.dispatch(Unknown
> Source)
> at
> org.apache.xerces.impl.XMLDocumentFragmentScannerImpl.scanDocument(Unknown
> Source)
> at org.apache.xerces.parsers.XML11Configuration.parse(Unknown Source)
> at org.apache.xerces.parsers.XML11Configuration.parse(Unknown Source)
> at org.apache.xerces.parsers.XMLParser.parse(Unknown Source)
> at org.apache.xerces.parsers.AbstractSAXParser.parse(Unknown Source)
> at org.apache.xerces.jaxp.SAXParserImpl$JAXPSAXParser.parse(Unknown Source)
> at org.apache.xerces.jaxp.SAXParserImpl.parse(Unknown Source)
> at
> org.eclipse.birt.report.model.parser.ModuleReader.readModule(ModuleReader.java:97)
>
> at
> org.eclipse.birt.report.model.parser.DesignReader.read(DesignReader.java:88)
>
> at
> org.eclipse.birt.report.model.core.DesignSessionImpl.openDesign(DesignSessionImpl.java:315)
>
> at
> org.eclipse.birt.report.model.api.SessionHandleImpl.openDesign(SessionHandleImpl.java:294)
>
> at
> org.eclipse.birt.report.engine.parser.ReportParser.getDesignHandle(ReportParser.java:158)
>
> at
> org.eclipse.birt.report.engine.api.impl.ReportEngineHelper.getReportDesignHandle(ReportEngineHelper.java:255)
>
> at
> org.eclipse.birt.report.engine.api.impl.ReportEngineHelper.openReportDesign(ReportEngineHelper.java:274)
>
> at
> org.eclipse.birt.report.engine.api.impl.ReportEngine.openReportDesign(ReportEngine.java:601)
>
> at
> org.eclipse.birt.report.service.ReportEngineService.openReportDesign(ReportEngineService.java:387)
>
> at
> org.eclipse.birt.report.utility.BirtUtility.getRunnableFromDesignFile(BirtUtility.java:607)
>
> at
> org.eclipse.birt.report.context.ViewerAttributeBean.getDesignHandle(ViewerAttributeBean.java:641)
>
> at
> org.eclipse.birt.report.context.ViewerAttributeBean.__init(ViewerAttributeBean.java:224)
>
> at
> org.eclipse.birt.report.context.BaseAttributeBean.init(BaseAttributeBean.java:233)
>
> at
> org.eclipse.birt.report.context.ViewerAttributeBean.<init>(ViewerAttributeBean.java:118)
>
> at org.eclipse.birt.report.context.BirtContext.__init(BirtContext.java:44)
> at org.eclipse.birt.report.context.BaseContext.<init>(BaseContext.java:69)
> at
> org.eclipse.birt.report.servlet.ViewerServlet.__getContext(ViewerServlet.java:150)
>
> at
> org.eclipse.birt.report.servlet.BirtSoapMessageDispatcherServlet.doPost(BirtSoapMessageDispatcherServlet.java:243)
>
> at javax.servlet.http.HttpServlet.service(HttpServlet.java:595)
> at
> org.apache.axis.transport.http.AxisServletBase.service(AxisServletBase.java:327)
>
> at javax.servlet.http.HttpServlet.service(HttpServlet.java:668)
> at
> org.eclipse.birt.report.servlet.BirtSoapMessageDispatcherServlet.service(BirtSoapMessageDispatcherServlet.java:122)
>
> at
> org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:304)
>
> at
> org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:210)
>
> at
> org.eclipse.birt.report.filter.ViewerFilter.doFilter(ViewerFilter.java:68)
> at
> org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:243)
>
> at
> org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:210)
>
> at
> org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:224)
>
> at
> org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:175)
>
> at
> org.apache.geronimo.tomcat.GeronimoStandardContext$SystemMethodValve.invoke(GeronimoStandardContext.java:819)
>
> at
> org.apache.geronimo.tomcat.valve.GeronimoBeforeAfterValve.invoke(GeronimoBeforeAfterValve.java:48)
>
> at
> org.apache.geronimo.tomcat.valve.ProtectedTargetValve.invoke(ProtectedTargetValve.java:53)
>
> at
> org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:164)
>
> at
> org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:100)
>
> at
> org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:851)
> at
> org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:118)
>
> at
> org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:405)
> at
> org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:278)
> at
> org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process(AbstractProtocol.java:515)
>
> at
> org.apache.tomcat.util.net.JIoEndpoint$SocketProcessor.run(JIoEndpoint.java:302)
>
> at org.apache.geronimo.pool.ThreadPool$1.run(ThreadPool.java:243)
> at
> org.apache.geronimo.pool.ThreadPool$ContextClassLoaderRunnable.run(ThreadPool.java:373)
>
> at
> java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:897)
>
> at
> java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:919)
>
> at java.lang.Thread.run(Thread.java:736)
> Caused by: org.eclipse.emf.ecore.xmi.PackageNotFoundException: Package
> with uri 'siteOfEclipse/ChartModel' not found.
> (file:///C:/IBM/SDP/test.chart, 1, 314)
> at
> org.eclipse.emf.ecore.xmi.impl.XMLHandler.getPackageForURI(XMLHandler.java:2591)
>
> at
> org.eclipse.emf.ecore.xmi.impl.XMLHandler.getFactoryForPrefix(XMLHandler.java:2422)
>
> at
> org.eclipse.emf.ecore.xmi.impl.XMLHandler.createObjectByType(XMLHandler.java:1299)
>
> at
> org.eclipse.emf.ecore.xmi.impl.XMLHandler.createTopObject(XMLHandler.java:1468)
>
> at
> org.eclipse.emf.ecore.xmi.impl.XMLHandler.processElement(XMLHandler.java:1019)
>
> at
> org.eclipse.emf.ecore.xmi.impl.XMLHandler.startElement(XMLHandler.java:1001)
>
> at
> org.eclipse.emf.ecore.xmi.impl.XMLHandler.startElement(XMLHandler.java:712)
> at org.apache.xerces.parsers.AbstractSAXParser.startElement(Unknown Source)
> at org.apache.xerces.impl.dtd.XMLDTDValidator.startElement(Unknown Source)
> at
> org.apache.xerces.impl.XMLDocumentFragmentScannerImpl.scanStartElement(Unknown
> Source)
> at
> org.apache.xerces.impl.XMLDocumentScannerImpl$ContentDispatcher.scanRootElementHook(Unknown
> Source)
> at
> org.apache.xerces.impl.XMLDocumentFragmentScannerImpl$FragmentContentDispatcher.dispatch(Unknown
> Source)
> at
> org.apache.xerces.impl.XMLDocumentFragmentScannerImpl.scanDocument(Unknown
> Source)
> at org.apache.xerces.parsers.XML11Configuration.parse(Unknown Source)
> at org.apache.xerces.parsers.XML11Configuration.parse(Unknown Source)
> at org.apache.xerces.parsers.XMLParser.parse(Unknown Source)
> at org.apache.xerces.parsers.AbstractSAXParser.parse(Unknown Source)
> at org.apache.xerces.jaxp.SAXParserImpl$JAXPSAXParser.parse(Unknown Source)
> at org.apache.xerces.jaxp.SAXParserImpl.parse(Unknown Source)
> at org.eclipse.emf.ecore.xmi.impl.XMLLoadImpl.load(XMLLoadImpl.java:181)
> ... 68 more
>
> Thanks,
>
> Chris
Re: charts in BIRT reports [message #824427 is a reply to message #824418] Mon, 19 March 2012 16:54 Go to previous messageGo to next message
Chris Houben is currently offline Chris HoubenFriend
Messages: 15
Registered: November 2011
Junior Member
Hi Jason,

Thx for the fast reply!

I downloaded the birt engine v2.6.2.
I import the birt.war into my eclipse and copy the \birt-runtime-2_6_2\ReportEngine\lib jars into WEB-INF\lib.

Also a copy of \birt-runtime-2_6_2\ReportEngine\plugins was made to WEB-INF\platform\plugins.

After this I export to a new birt.war and deploy it to my WASCE 3.0.

Can this be a problem of class loading ? Do I need to copy the runtime lib's to my WASCE ?

I'm only having this problem when testing test1.rptdesign (so when using charts).
Re: charts in BIRT reports [message #824510 is a reply to message #824427] Mon, 19 March 2012 19:04 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason WeathersbyFriend
Messages: 9167
Registered: July 2009
Senior Member

Are you using the APIs or just the WebViewer?

Jason

On 3/19/2012 12:54 PM, Chris Houben wrote:
> Hi Jason,
>
> Thx for the fast reply!
>
> I downloaded the birt engine v2.6.2.
> I import the birt.war into my eclipse and copy the
> \birt-runtime-2_6_2\ReportEngine\lib jars into WEB-INF\lib.
>
> Also a copy of \birt-runtime-2_6_2\ReportEngine\plugins was made to
> WEB-INF\platform\plugins.
>
> After this I export to a new birt.war and deploy it to my WASCE 3.0.
>
> Can this be a problem of class loading ? Do I need to copy the runtime
> lib's to my WASCE ?
>
> I'm only having this problem when testing test1.rptdesign (so when using
> charts).
Re: charts in BIRT reports [message #824521 is a reply to message #824510] Mon, 19 March 2012 19:22 Go to previous messageGo to next message
Chris Houben is currently offline Chris HoubenFriend
Messages: 15
Registered: November 2011
Junior Member
just using the WebViewer.

I'm doing nothing special.
only download birt-runtime-2_6_2.zip.
Take the birt.war into my eclipse and copy the jars & put on the logging in web.xml.
repackage to war & deploy on my local WASCE.
Re: charts in BIRT reports [message #824648 is a reply to message #824521] Mon, 19 March 2012 22:39 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason WeathersbyFriend
Messages: 9167
Registered: July 2009
Senior Member

For BIRT 3.7 you may want to look here:
http://wiki.eclipse.org/BirtPOJO_Viewer_WebSphere_Deployment

For earlier version you may want to look here:
http://wiki.eclipse.org/BIRT/FAQ/Deployment

In you platform folder do you have a configuration directory containing
a config.ini

Jason

On 3/19/2012 3:22 PM, Chris Houben wrote:
> just using the WebViewer.
>
> I'm doing nothing special. only download birt-runtime-2_6_2.zip. Take
> the birt.war into my eclipse and copy the jars & put on the logging in
> web.xml.
> repackage to war & deploy on my local WASCE.
Re: charts in BIRT reports [message #824941 is a reply to message #824648] Tue, 20 March 2012 09:09 Go to previous messageGo to next message
Chris Houben is currently offline Chris HoubenFriend
Messages: 15
Registered: November 2011
Junior Member
Yes, I have a config.ini file.
#Product Runtime Configuration File
eclipse.product=org.eclipse.birt.report.engine.ReportEngineSDK
osgi.bundles=org.eclipse.equinox.common@2:start, org.eclipse.update.configurator@3:start, org.eclipse.birt.core@start
osgi.framework.extensions=org.eclipse.birt.api
osgi.bundles.defaultStartLevel=4
eclipse.parsers.setTCCL=false




I have imported the birt.war in my eclipse and the geronimo-web.xml and web.xml was automatically set correct when choosing target runtime for WASCE 3.0.
wiki.eclipse.org/Birt_WAS_CE

I'm starting to think the problem is in my settings of WASCE ?
Which test can I do to find the problem ?

When using v2.6.2, do I need to have a look at the OSGi plugins?
Only the charts aren't working, how can I check if my jars are correct for using charts?

Thanks,

Chris

[Updated on: Tue, 20 March 2012 12:26]

Report message to a moderator

Re: charts in BIRT reports [message #825148 is a reply to message #824941] Tue, 20 March 2012 14:30 Go to previous messageGo to next message
Chris Houben is currently offline Chris HoubenFriend
Messages: 15
Registered: November 2011
Junior Member
side info:
my WASCE is running in my eclipse.
my root of my eclipse is C:\IBM\SDP
my root of my WASCE is C:\IBM\WebSphere\AppServerCommunityEdition

when I'm not running my WASCE in eclipse, I receive:
Exception in thread "DefaultThreadPool 69" java.lang.OutOfMemoryError: PermGen space
Re: charts in BIRT reports [message #825248 is a reply to message #825148] Tue, 20 March 2012 16:54 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason WeathersbyFriend
Messages: 9167
Registered: July 2009
Senior Member

I have seen this error:
java.lang.OutOfMemoryError:
> PermGen space

Can you add a jvm parameter ? try:
-XX:MaxPermSize=256m

Jason


On 3/20/2012 10:30 AM, Chris Houben wrote:
> side info:
> my WASCE is running in my eclipse. my root of my eclipse is C:\IBM\SDP
> my root of my WASCE is C:\IBM\WebSphere\AppServerCommunityEdition
>
> when I'm not running my WASCE in eclipse, I receive:
> Exception in thread "DefaultThreadPool 69" java.lang.OutOfMemoryError:
> PermGen space
Re: charts in BIRT reports [message #825307 is a reply to message #824941] Tue, 20 March 2012 17:55 Go to previous messageGo to next message
Chris Houben is currently offline Chris HoubenFriend
Messages: 15
Registered: November 2011
Junior Member
ok, will try this...

Can you give me some answer to the questions below?
is my config.ini correct? What is the best way to continue to find my problem ?

Greets,

CHris


Chris Houben wrote on Tue, 20 March 2012 05:09
Yes, I have a config.ini file.
#Product Runtime Configuration File
eclipse.product=org.eclipse.birt.report.engine.ReportEngineSDK
osgi.bundles=org.eclipse.equinox.common@2:start, org.eclipse.update.configurator@3:start, org.eclipse.birt.core@start
osgi.framework.extensions=org.eclipse.birt.api
osgi.bundles.defaultStartLevel=4
eclipse.parsers.setTCCL=false




I have imported the birt.war in my eclipse and the geronimo-web.xml and web.xml was automatically set correct when choosing target runtime for WASCE 3.0.
wiki.eclipse.org/Birt_WAS_CE

I'm starting to think the problem is in my settings of WASCE ?
Which test can I do to find the problem ?

When using v2.6.2, do I need to have a look at the OSGi plugins?
Only the charts aren't working, how can I check if my jars are correct for using charts?

Thanks,

Chris

Re: charts in BIRT reports [message #825365 is a reply to message #825307] Tue, 20 March 2012 19:13 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason WeathersbyFriend
Messages: 9167
Registered: July 2009
Senior Member

Chris,

If normal tables, reports etc are working and it is just charts that are
failing, I believe this is the perm space issue.

If you have downloaded the runtime for 2.6.2 the correct plugins and
jars from the reportengine/lib directory should be the ones you are
using. One thing you could look at is turning up the log level and
posting the log file.

Jason


On 3/20/2012 1:55 PM, Chris Houben wrote:
> ok, will try this...
>
> Can you give me some answer to the questions below?
> is my config.ini correct? What is the best way to continue to find my
> problem ?
>
> Greets,
>
> CHris
>
>
> Chris Houben wrote on Tue, 20 March 2012 05:09
>> Yes, I have a config.ini file.
>> #Product Runtime Configuration File
>> eclipse.product=org.eclipse.birt.report.engine.ReportEngineSDK
>> osgi.bundles=org.eclipse.equinox.common@2:start,
>> org.eclipse.update.configurator@3:start, org.eclipse.birt.core@start
>> osgi.framework.extensions=org.eclipse.birt.api
>> osgi.bundles.defaultStartLevel=4
>> eclipse.parsers.setTCCL=false
>>
>>
>>
>>
>> I have imported the birt.war in my eclipse and the geronimo-web.xml
>> and web.xml was automatically set correct when choosing target runtime
>> for WASCE 3.0.
>> wiki.eclipse.org/Birt_WAS_CE
>>
>> I'm starting to think the problem is in my settings of WASCE ?
>> Which test can I do to find the problem ?
>>
>> When using v2.6.2, do I need to have a look at the OSGi plugins?
>> Only the charts aren't working, how can I check if my jars are correct
>> for using charts?
>>
>> Thanks,
>>
>> Chris
>
>
Re: charts in BIRT reports [message #825371 is a reply to message #825365] Tue, 20 March 2012 19:23 Go to previous messageGo to next message
Chris Houben is currently offline Chris HoubenFriend
Messages: 15
Registered: November 2011
Junior Member
log file in attach.
loglevel: finest
Re: charts in BIRT reports [message #825837 is a reply to message #825371] Wed, 21 March 2012 10:16 Go to previous messageGo to next message
Chris Houben is currently offline Chris HoubenFriend
Messages: 15
Registered: November 2011
Junior Member
Chris Houben wrote on Tue, 20 March 2012 15:23
log file in attach.
loglevel: finest

Jason,

I changed the maxPermSize and now my WASCE also works without eclipse. But still the charts are giving a problem:

org.eclipse.emf.ecore.resource.Resource$IOWrappedException: Package with uri 'eclipsdir/ChartModel' not found. (file:///C:/IBM/WebSphere/AppServerCommunityEdition/bin/test.chart, 1, 367)

Notice the directory he is giving now... He tries to find test.chart in my websphere/bin directory.

when I start my WASCE from my workbench, He tries to find test.chart in my workbench directory.

I think the problem is the incorrect value of this directory ? How is this value set ?

Greets,
Chris
Re: charts in BIRT reports [message #825928 is a reply to message #825837] Wed, 21 March 2012 12:33 Go to previous messageGo to next message
Chris Houben is currently offline Chris HoubenFriend
Messages: 15
Registered: November 2011
Junior Member
Jason,

I also played with <dep:inverse-classloading/> for my project.

If I use this option i recieve:
java.lang.NoClassDefFoundError: org/apache/commons/logging/LogFactory$1

So I copied the commons-logging jars into my lib of WASCE... but still recieve this error.

Greets,
CHris
Re: charts in BIRT reports [message #826153 is a reply to message #825928] Wed, 21 March 2012 18:25 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason WeathersbyFriend
Messages: 9167
Registered: July 2009
Senior Member

You were not getting this error until you changed classloading correct?
On the chart issue are you just running a report that has a chart in it?
I suspect this is an issue with emf classloading. Look at items 5 and 6
on this page

http://wiki.eclipse.org/Birt_WebSphere_Deployment
Although this is an earlier version of BIRT it may be the same issue.

You could try the new POJO Runtime of BIRT 3.7.2
http://wiki.eclipse.org/BirtPOJO_Viewer_WebSphere_Deployment

Jason

On 3/21/2012 8:33 AM, Chris Houben wrote:
> Jason,
>
> I also played with <dep:inverse-classloading/> for my project.
>
> If I use this option i recieve:
> java.lang.NoClassDefFoundError: org/apache/commons/logging/LogFactory$1
>
> So I copied the commons-logging jars into my lib of WASCE... but still
> recieve this error.
>
> Greets,
> CHris
Re: charts in BIRT reports [message #826160 is a reply to message #826153] Wed, 21 March 2012 18:42 Go to previous messageGo to next message
Chris Houben is currently offline Chris HoubenFriend
Messages: 15
Registered: November 2011
Junior Member
Jason Weathersby wrote on Wed, 21 March 2012 14:25
You were not getting this error until you changed classloading correct?

Correct, only get this when changing classloading.


Jason Weathersby wrote on Wed, 21 March 2012 14:25
On the chart issue are you just running a report that has a chart in it?

I'm running the test.rptdesign and this works perfectly. When I run the test1.rptdesign file, I get the data, but not the charts.


Jason Weathersby wrote on Wed, 21 March 2012 14:25
I suspect this is an issue with emf classloading. Look at items 5 and 6
on this page

eclipse/Birt_WebSphere_Deployment
Although this is an earlier version of BIRT it may be the same issue.

Allready tried this. I can retry, but before it gave me the same error.


Jason Weathersby wrote on Wed, 21 March 2012 14:25

You could try the new POJO Runtime of BIRT 3.7.2
eclipse/BirtPOJO_Viewer_WebSphere_Deployment

A college of mine has tried this, without any result. But tomorrow I will give v3.7.2 a try.

The problems have nothing to do with the incorrect path of test.chart you think ?
Re: charts in BIRT reports [message #826183 is a reply to message #826160] Wed, 21 March 2012 19:19 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason WeathersbyFriend
Messages: 9167
Registered: July 2009
Senior Member

No, test.chart is not even defined in this case. The error I believe is
misleading. The Chart engine uses EMF but normal reports (without
charts) do not. Is the community edition free to download? If so I
will give it a try.

Jason

On 3/21/2012 2:42 PM, Chris Houben wrote:
> Jason Weathersby wrote on Wed, 21 March 2012 14:25
>> You were not getting this error until you changed classloading correct?
>
> Correct, only get this when changing classloading.
>
>
> Jason Weathersby wrote on Wed, 21 March 2012 14:25
>> On the chart issue are you just running a report that has a chart in it?
>
> I'm running the test.rptdesign and this works perfectly. When I run the
> test1.rptdesign file, I get the data, but not the charts.
>
>
> Jason Weathersby wrote on Wed, 21 March 2012 14:25
>> I suspect this is an issue with emf classloading. Look at items 5 and
>> 6 on this page
>>
>> eclipse/Birt_WebSphere_Deployment
>> Although this is an earlier version of BIRT it may be the same issue.
>
> Allready tried this. I can retry, but before it gave me the same error.
>
>
> Jason Weathersby wrote on Wed, 21 March 2012 14:25
>> You could try the new POJO Runtime of BIRT 3.7.2
>> eclipse/BirtPOJO_Viewer_WebSphere_Deployment
>
> A college of mine has tried this, without any result. But tomorrow I
> will give v3.7.2 a try.
>
> The problems have nothing to do with the incorrect path of test.chart
> you think ?
Re: charts in BIRT reports [message #826630 is a reply to message #826183] Thu, 22 March 2012 10:03 Go to previous messageGo to next message
Chris Houben is currently offline Chris HoubenFriend
Messages: 15
Registered: November 2011
Junior Member
Jason Weathersby wrote on Wed, 21 March 2012 15:19
No, test.chart is not even defined in this case. The error I believe is
misleading. The Chart engine uses EMF but normal reports (without
charts) do not. Is the community edition free to download? If so I
will give it a try.

Jason


Jason,

WASCE 3.0 is a free download.
BIRT v2.6.2.

for the plugin for WASCE 3.0 in eclipse:
- Add public.dhe.ibm.com/software/websphere/wasce/updates/ to the list of available software sites and enable the Helios Milestone Repository
- Add WASCE v3.0 Server Adapter Assembly

If you have any problem with the installation, let me know...
Thanks for giving this a try!!

Chris
Re: charts in BIRT reports [message #826903 is a reply to message #826630] Thu, 22 March 2012 16:31 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason WeathersbyFriend
Messages: 9167
Registered: July 2009
Senior Member

If I install WASCE and deploy birt I should get the issue correct? I do
not need to install the eclipse plugins to produce the issue do I?

Jason

On 3/22/2012 6:03 AM, Chris Houben wrote:
> Jason Weathersby wrote on Wed, 21 March 2012 15:19
>> No, test.chart is not even defined in this case. The error I believe
>> is misleading. The Chart engine uses EMF but normal reports (without
>> charts) do not. Is the community edition free to download? If so I
>> will give it a try.
>>
>> Jason
>
>
> Jason,
>
> WASCE 3.0 is a free download.
> BIRT v2.6.2.
>
> for the plugin for WASCE 3.0 in eclipse:
> - Add public.dhe.ibm.com/software/websphere/wasce/updates/ to the list
> of available software sites and enable the Helios Milestone Repository
> - Add WASCE v3.0 Server Adapter Assembly
>
> If you have any problem with the installation, let me know...
> Thanks for giving this a try!!
> Chris
Re: charts in BIRT reports [message #829671 is a reply to message #826903] Mon, 26 March 2012 16:16 Go to previous messageGo to next message
Chris Houben is currently offline Chris HoubenFriend
Messages: 15
Registered: November 2011
Junior Member
I think you need the plugin. Geronimo-web.xml is produced automatically if you import birt.war into eclipse using runtime WASCE. Afterwards you can export to *.war easily.

If you need some help, let me know!!

Chris
Re: charts in BIRT reports [message #830765 is a reply to message #829671] Wed, 28 March 2012 03:06 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason WeathersbyFriend
Messages: 9167
Registered: July 2009
Senior Member

Chris,

I tried a bit on this and essentially went down the path you took. I
also tried with 3.7.2 which exhibits another class loader conflict. I
am going to try to look at this more later in the week, but it would be
good if you could open a bugzilla on this issue. I got the issue just
using WASCE deployer and the birt viewer war.

Jason

On 3/26/2012 12:16 PM, Chris Houben wrote:
> I think you need the plugin. Geronimo-web.xml is produced automatically
> if you import birt.war into eclipse using runtime WASCE. Afterwards you
> can export to *.war easily.
>
> If you need some help, let me know!!
>
> Chris
Re: charts in BIRT reports [message #832689 is a reply to message #824313] Fri, 30 March 2012 13:09 Go to previous messageGo to next message
Chris Houben is currently offline Chris HoubenFriend
Messages: 15
Registered: November 2011
Junior Member
Hi Jason,

Do you get the same errors as me or different ?

bugzilla: Bug 375716
PMR @ ibm: 26944 300 624

Chris
Re: charts in BIRT reports [message #832930 is a reply to message #832689] Fri, 30 March 2012 19:00 Go to previous message
Jason Weathersby is currently offline Jason WeathersbyFriend
Messages: 9167
Registered: July 2009
Senior Member

I got the same errors. Thanks for logging the bug.

Jason

On 3/30/2012 9:09 AM, Chris Houben wrote:
> Hi Jason,
>
> Do you get the same errors as me or different ?
>
> bugzilla: Bug 375716 PMR @ ibm: 26944 300 624
>
> Chris
Previous Topic:Maintaining POJOs in designer across previews
Next Topic:Report parameter doesn't exist (except it does)
Goto Forum:
  


Current Time: Sun Oct 24 01:36:44 GMT 2021

Powered by FUDForum. Page generated in 0.02787 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top